aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-10-15 16:28:00 +0800
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-10-15 16:28:00 +0800
commitd8078fadb94d101916fe560042bfe366ea40c9f1 (patch)
tree5811390fb18d54d8f7916b8183ebde0fc97f4e04 /textproc
parent56aeaec97d2077a1c471ed436c8f5abe0a869d0d (diff)
downloadfreebsd-ports-gnome-d8078fadb94d101916fe560042bfe366ea40c9f1.tar.gz
freebsd-ports-gnome-d8078fadb94d101916fe560042bfe366ea40c9f1.tar.zst
freebsd-ports-gnome-d8078fadb94d101916fe560042bfe366ea40c9f1.zip
Clean up port's makefile
- Sort variables - Replace test make targets with a simple TEST_TARGET=test - Remove unnecessary include <bsd.port.options.mk> Approved by: portmgr blanket
Diffstat (limited to 'textproc')
-rw-r--r--textproc/google-translate-cli/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/textproc/google-translate-cli/Makefile b/textproc/google-translate-cli/Makefile
index a4d95c0627e4..f83706910283 100644
--- a/textproc/google-translate-cli/Makefile
+++ b/textproc/google-translate-cli/Makefile
@@ -17,31 +17,27 @@ RUN_DEPENDS= bash:shells/bash \
gawk:lang/gawk
TEST_DEPENDS= gawk:lang/gawk
-ALL_TARGET= build
-
-FRIBIDI_RUN_DEPENDS= fribidi:converters/fribidi
-
+USE_GITHUB= yes
GH_ACCOUNT= soimort
GH_PROJECT= translate-shell
+ALL_TARGET= build
+TEST_TARGET= test
+PLIST_FILES= bin/trans \
+ man/man1/trans.1.gz
+
OPTIONS_DEFINE= DOCS FRIBIDI READLINE TEXT2SPEECH
-PLIST_FILES= bin/trans man/man1/trans.1.gz
+TEXT2SPEECH_DESC= Enable Text-to-Speech functionality via espeak
+
+FRIBIDI_RUN_DEPENDS= fribidi:converters/fribidi
READLINE_RUN_DEPENDS= rlwrap:devel/rlwrap
-TEXT2SPEECH_DESC= Enable Text-to-Speech functionality via espeak
TEXT2SPEECH_RUN_DEPENDS= espeak:audio/espeak
-USE_GITHUB= yes
-
-.include <bsd.port.options.mk>
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/build/trans ${STAGEDIR}${PREFIX}/bin/trans
${INSTALL_MAN} ${WRKSRC}/man/trans.1 ${STAGEDIR}${MANPREFIX}/man/man1/trans.1
-regression-test test: build
- @(cd ${WRKSRC} && ${MAKE} test)
-
.include <bsd.port.mk>