aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 19:54:20 +0800
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 19:54:20 +0800
commitdb021968e3411b659e079e540742896abe4193f1 (patch)
treead7f282ff1e254cc6c54bfc24d23efee0af4d12e /textproc
parent93028a155ae531c7c9a6c723a6d465b49a90e9df (diff)
downloadfreebsd-ports-gnome-db021968e3411b659e079e540742896abe4193f1.tar.gz
freebsd-ports-gnome-db021968e3411b659e079e540742896abe4193f1.tar.zst
freebsd-ports-gnome-db021968e3411b659e079e540742896abe4193f1.zip
Add PHP 7.1
Thanks to: mat, pi, ale, martin@waschbuesch.de and franco@opnsense.org
Diffstat (limited to 'textproc')
-rw-r--r--textproc/php71-ctype/Makefile9
-rw-r--r--textproc/php71-dom/Makefile9
-rw-r--r--textproc/php71-enchant/Makefile9
-rw-r--r--textproc/php71-pspell/Makefile9
-rw-r--r--textproc/php71-simplexml/Makefile9
-rw-r--r--textproc/php71-simplexml/files/patch-config.m443
-rw-r--r--textproc/php71-wddx/Makefile9
-rw-r--r--textproc/php71-wddx/files/patch-config.m422
-rw-r--r--textproc/php71-wddx/files/patch-wddx.c40
-rw-r--r--textproc/php71-xml/Makefile9
-rw-r--r--textproc/php71-xml/files/patch-compat.c13
-rw-r--r--textproc/php71-xmlreader/Makefile9
-rw-r--r--textproc/php71-xmlwriter/Makefile9
-rw-r--r--textproc/php71-xsl/Makefile9
-rw-r--r--textproc/php71-xsl/files/patch-php_xsl.h11
15 files changed, 219 insertions, 0 deletions
diff --git a/textproc/php71-ctype/Makefile b/textproc/php71-ctype/Makefile
new file mode 100644
index 000000000000..e49199b94ce7
--- /dev/null
+++ b/textproc/php71-ctype/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -ctype
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-dom/Makefile b/textproc/php71-dom/Makefile
new file mode 100644
index 000000000000..dd695bee8d85
--- /dev/null
+++ b/textproc/php71-dom/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -dom
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-enchant/Makefile b/textproc/php71-enchant/Makefile
new file mode 100644
index 000000000000..877eacc520c1
--- /dev/null
+++ b/textproc/php71-enchant/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -enchant
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-pspell/Makefile b/textproc/php71-pspell/Makefile
new file mode 100644
index 000000000000..88bbb59885b3
--- /dev/null
+++ b/textproc/php71-pspell/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -pspell
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-simplexml/Makefile b/textproc/php71-simplexml/Makefile
new file mode 100644
index 000000000000..de86001c09fc
--- /dev/null
+++ b/textproc/php71-simplexml/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -simplexml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-simplexml/files/patch-config.m4 b/textproc/php71-simplexml/files/patch-config.m4
new file mode 100644
index 000000000000..4eeef697dc87
--- /dev/null
+++ b/textproc/php71-simplexml/files/patch-config.m4
@@ -0,0 +1,43 @@
+--- config.m4.orig 2014-05-14 10:14:22.929420181 +0000
++++ config.m4 2014-05-14 10:15:36.967414693 +0000
+@@ -4,6 +4,9 @@
+ PHP_ARG_ENABLE(simplexml, whether to enable SimpleXML support,
+ [ --disable-simplexml Disable SimpleXML support], yes)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir SimpleXML: pcre install prefix], no, no)
++
+ if test -z "$PHP_LIBXML_DIR"; then
+ PHP_ARG_WITH(libxml-dir, libxml2 install dir,
+ [ --with-libxml-dir=DIR SimpleXML: libxml2 install prefix], no, no)
+@@ -11,6 +14,30 @@
+
+ if test "$PHP_SIMPLEXML" != "no"; then
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$PHP_LIBXML" = "no"; then
+ AC_MSG_ERROR([SimpleXML extension requires LIBXML extension, add --enable-libxml])
+ fi
diff --git a/textproc/php71-wddx/Makefile b/textproc/php71-wddx/Makefile
new file mode 100644
index 000000000000..7243bf74e5ab
--- /dev/null
+++ b/textproc/php71-wddx/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -wddx
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-wddx/files/patch-config.m4 b/textproc/php71-wddx/files/patch-config.m4
new file mode 100644
index 000000000000..08787003b8f9
--- /dev/null
+++ b/textproc/php71-wddx/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- config.m4.orig Mon Jul 26 09:05:10 2004
++++ config.m4 Mon Jul 26 09:07:46 2004
+@@ -5,6 +5,9 @@
+ PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
+ [ --enable-wddx Enable WDDX support.])
+
++PHP_ARG_WITH(libxml-dir, libxml2 install dir,
++[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
++
+ if test "$PHP_WDDX" != "no"; then
+ if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
+ AC_MSG_WARN(Activating XML)
+@@ -12,4 +15,9 @@
+ fi
+ AC_DEFINE(HAVE_WDDX, 1, [ ])
+ PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
++
++ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
+ fi
diff --git a/textproc/php71-wddx/files/patch-wddx.c b/textproc/php71-wddx/files/patch-wddx.c
new file mode 100644
index 000000000000..a8a6a79fe47f
--- /dev/null
+++ b/textproc/php71-wddx/files/patch-wddx.c
@@ -0,0 +1,40 @@
+--- wddx.c.orig Sun Jan 1 13:50:16 2006
++++ wddx.c Mon Jan 16 12:56:21 2006
+@@ -18,6 +18,10 @@
+
+ /* $Id: wddx.c,v 1.119.2.8 2006/01/01 12:50:16 sniper Exp $ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include "php.h"
+
+ #if HAVE_WDDX
+@@ -223,7 +227,7 @@
+
+ #include "ext/session/php_session.h"
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* {{{ PS_SERIALIZER_ENCODE_FUNC
+ */
+ PS_SERIALIZER_ENCODE_FUNC(wddx)
+@@ -302,7 +306,7 @@
+ {
+ le_wddx = zend_register_list_destructors_ex(release_wddx_packet_rsrc, NULL, "wddx", module_number);
+
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_session_register_serializer("wddx",
+ PS_SERIALIZER_ENCODE_NAME(wddx),
+ PS_SERIALIZER_DECODE_NAME(wddx));
+@@ -317,7 +321,7 @@
+ PHP_MINFO_FUNCTION(wddx)
+ {
+ php_info_print_table_start();
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ php_info_print_table_header(2, "WDDX Support", "enabled" );
+ php_info_print_table_row(2, "WDDX Session Serializer", "enabled" );
+ #else
diff --git a/textproc/php71-xml/Makefile b/textproc/php71-xml/Makefile
new file mode 100644
index 000000000000..703803a865bc
--- /dev/null
+++ b/textproc/php71-xml/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -xml
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xml/files/patch-compat.c b/textproc/php71-xml/files/patch-compat.c
new file mode 100644
index 000000000000..02125961b20c
--- /dev/null
+++ b/textproc/php71-xml/files/patch-compat.c
@@ -0,0 +1,13 @@
+--- compat.c.orig Tue Jul 20 10:55:02 2004
++++ compat.c Tue Jul 20 10:55:55 2004
+@@ -16,6 +16,10 @@
+ +----------------------------------------------------------------------+
+ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+ #if defined(HAVE_LIBXML) && defined(HAVE_XML) && !defined(HAVE_LIBEXPAT)
+ #include "expat_compat.h"
diff --git a/textproc/php71-xmlreader/Makefile b/textproc/php71-xmlreader/Makefile
new file mode 100644
index 000000000000..087340030e85
--- /dev/null
+++ b/textproc/php71-xmlreader/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -xmlreader
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xmlwriter/Makefile b/textproc/php71-xmlwriter/Makefile
new file mode 100644
index 000000000000..4284c734aa90
--- /dev/null
+++ b/textproc/php71-xmlwriter/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -xmlwriter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xsl/Makefile b/textproc/php71-xsl/Makefile
new file mode 100644
index 000000000000..00f0b650491f
--- /dev/null
+++ b/textproc/php71-xsl/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -xsl
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xsl/files/patch-php_xsl.h b/textproc/php71-xsl/files/patch-php_xsl.h
new file mode 100644
index 000000000000..9777187f8748
--- /dev/null
+++ b/textproc/php71-xsl/files/patch-php_xsl.h
@@ -0,0 +1,11 @@
+--- php_xsl.h.orig Sun Jan 1 13:50:17 2006
++++ php_xsl.h Tue Jan 17 16:23:10 2006
+@@ -43,7 +43,7 @@
+ #include <libexslt/exsltconfig.h>
+ #endif
+
+-#include "../dom/xml_common.h"
++#include "ext/dom/xml_common.h"
+ #include "xsl_fe.h"
+
+ #include <libxslt/extensions.h>