aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-29 23:29:10 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-29 23:29:10 +0800
commitde6082d7bc9c516d4eb9c521a15fefd999a8a428 (patch)
tree78f4c2f6636b3313ca9bef16d5ee1020a0816956 /textproc
parenta8dc0ff9a1546194b015a9b864cbb0a83189df19 (diff)
downloadfreebsd-ports-gnome-de6082d7bc9c516d4eb9c521a15fefd999a8a428.tar.gz
freebsd-ports-gnome-de6082d7bc9c516d4eb9c521a15fefd999a8a428.tar.zst
freebsd-ports-gnome-de6082d7bc9c516d4eb9c521a15fefd999a8a428.zip
Add xlreader.
Read data from Excel spread sheets without Microsoft! Provides an API to allow any application to read Excel documents. The xlreader tool converts Excel data to tab delimited, CSV or SQL inserts. Written in C. Based on the the Java version by Andrew Khan. This project was designed out of frustration. WWW: http://www.giffin.org/xlreader.php PR: ports/82629 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xlreader/Makefile29
-rw-r--r--textproc/xlreader/distinfo2
-rw-r--r--textproc/xlreader/pkg-descr11
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6bbcfba9fedb..4e7c99e1849d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -721,6 +721,7 @@
SUBDIR += xhtml1-xsd
SUBDIR += xincluder
SUBDIR += xlhtml
+ SUBDIR += xlreader
SUBDIR += xls2xml
SUBDIR += xml-i18n-tools
SUBDIR += xml-lite.el
diff --git a/textproc/xlreader/Makefile b/textproc/xlreader/Makefile
new file mode 100644
index 000000000000..7cb1b5259f08
--- /dev/null
+++ b/textproc/xlreader/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xlreader
+# Date created: 25 Jun 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xlreader
+PORTVERSION= 0.9.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.giffin.org/download/ \
+ http://critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Convert .xls spread sheets to tab delimited CSV or SQL inserts
+
+USE_REINPLACE= yes
+PLIST_FILES= bin/xlreader
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-L/usr/local/lib||; s|^CFLAGS=.*||; s|gcc|${CC}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/xlreader/distinfo b/textproc/xlreader/distinfo
new file mode 100644
index 000000000000..cc2d758be950
--- /dev/null
+++ b/textproc/xlreader/distinfo
@@ -0,0 +1,2 @@
+MD5 (xlreader-0.9.0.tgz) = f09a5de0ce69d96a5ee0cff6bdbc043b
+SIZE (xlreader-0.9.0.tgz) = 45838
diff --git a/textproc/xlreader/pkg-descr b/textproc/xlreader/pkg-descr
new file mode 100644
index 000000000000..96df82eb2ed0
--- /dev/null
+++ b/textproc/xlreader/pkg-descr
@@ -0,0 +1,11 @@
+Read data from Excel spread sheets without Microsoft! Provides an API to allow
+any application to read Excel documents. The xlreader tool converts Excel data
+to tab delimited, CSV or SQL inserts. Written in C. Based on the the Java
+version by Andrew Khan.
+
+This project was designed out of frustration.
+
+WWW: http://www.giffin.org/xlreader.php
+
+- ehaupt
+ehaupt@critical.ch