aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-10-30 04:44:19 +0800
committerwg <wg@FreeBSD.org>2013-10-30 04:44:19 +0800
commitdf558e290df00592ba51985b763c3693aa555a65 (patch)
treecccb073b4b36dff82731da0f04f6036a544a0543 /textproc
parenteeab54a8d2d5cc2c2dfc1026ff0176cdc71fc421 (diff)
downloadfreebsd-ports-gnome-df558e290df00592ba51985b763c3693aa555a65.tar.gz
freebsd-ports-gnome-df558e290df00592ba51985b763c3693aa555a65.tar.zst
freebsd-ports-gnome-df558e290df00592ba51985b763c3693aa555a65.zip
textproc/py-pysrt: SubRip (.srt) subtitle parser and writer
WWW: https://github.com/byroot/pysrt/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-pysrt/Makefile25
-rw-r--r--textproc/py-pysrt/distinfo2
-rw-r--r--textproc/py-pysrt/pkg-descr3
4 files changed, 31 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6d3d57ca35ab..6061c8cf6302 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1177,6 +1177,7 @@
SUBDIR += py-pss
SUBDIR += py-pyctpp2
SUBDIR += py-pygments
+ SUBDIR += py-pysrt
SUBDIR += py-pystache
SUBDIR += py-pyx12
SUBDIR += py-qt4-xml
diff --git a/textproc/py-pysrt/Makefile b/textproc/py-pysrt/Makefile
new file mode 100644
index 000000000000..8ab1dab0a24e
--- /dev/null
+++ b/textproc/py-pysrt/Makefile
@@ -0,0 +1,25 @@
+# Created by: William Grzybowski <wg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pysrt
+PORTVERSION= 0.5.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wg@FreeBSD.org
+COMMENT= SubRip (.srt) subtitle parser and writer
+
+LICENSE= GPLv3
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's/="GPLv3",/="GPLv3", zip_safe=False,/' \
+ ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pysrt/distinfo b/textproc/py-pysrt/distinfo
new file mode 100644
index 000000000000..aa991dfdd11c
--- /dev/null
+++ b/textproc/py-pysrt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pysrt-0.5.0.tar.gz) = 21c7919c9aa1e0fe9ed0ce9ec01792c23764de7b82f1cec70a36fa443b19e980
+SIZE (pysrt-0.5.0.tar.gz) = 14804
diff --git a/textproc/py-pysrt/pkg-descr b/textproc/py-pysrt/pkg-descr
new file mode 100644
index 000000000000..96fd60b83734
--- /dev/null
+++ b/textproc/py-pysrt/pkg-descr
@@ -0,0 +1,3 @@
+pysrt is a Python library used to edit or create SubRip files.
+
+WWW: https://github.com/byroot/pysrt/