aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-07 21:20:32 +0800
committeraz <az@FreeBSD.org>2013-08-07 21:20:32 +0800
commite1d59bae7d278db3d48c3da263eeed5ffe98e3bf (patch)
tree1d8dce4b39a3357f2e6741d55cb1b9a1fa54d346 /textproc
parent55cd13e4e11d36f2ede96fa048ad85d6e02b2ba1 (diff)
downloadfreebsd-ports-gnome-e1d59bae7d278db3d48c3da263eeed5ffe98e3bf.tar.gz
freebsd-ports-gnome-e1d59bae7d278db3d48c3da263eeed5ffe98e3bf.tar.zst
freebsd-ports-gnome-e1d59bae7d278db3d48c3da263eeed5ffe98e3bf.zip
- Convert to new perl framework
per port extra changes: devel/p5-Perl-Version remove outage PERL_LEVEL check devel/p5-Devel-LeakTrace-Fast remove perl version requiment 5.12.0- (no need in current version) Approved by: lth@ (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-Devel-TraceSAX/Makefile3
-rw-r--r--textproc/p5-HTML-Quoted/Makefile3
-rw-r--r--textproc/p5-Lingua-EN-Inflect-Number/Makefile3
-rw-r--r--textproc/p5-PPI-HTML/Makefile3
-rw-r--r--textproc/p5-PPI-XS/Makefile3
-rw-r--r--textproc/p5-PPI/Makefile3
-rw-r--r--textproc/p5-Perl-MinimumVersion/Makefile3
-rw-r--r--textproc/p5-Pod-Spell/Makefile3
-rw-r--r--textproc/p5-Regexp-Common-net-CIDR/Makefile3
-rw-r--r--textproc/p5-Regexp-IPv6/Makefile3
-rw-r--r--textproc/p5-String-Truncate/Makefile3
-rw-r--r--textproc/p5-Text-ASCIITable/Makefile3
-rw-r--r--textproc/p5-Text-FixEOL/Makefile3
-rw-r--r--textproc/p5-Text-RecordParser/Makefile3
-rw-r--r--textproc/p5-Text-TabularDisplay/Makefile3
-rw-r--r--textproc/p5-Text-Truncate/Makefile3
-rw-r--r--textproc/p5-Version-Next/Makefile3
-rw-r--r--textproc/p5-XML-Rules/Makefile3
-rw-r--r--textproc/p5-XML-SAX-Expat-Incremental/Makefile3
-rw-r--r--textproc/p5-XML-SemanticDiff/Makefile3
-rw-r--r--textproc/p5-pod2pdf/Makefile3
21 files changed, 42 insertions, 21 deletions
diff --git a/textproc/p5-Devel-TraceSAX/Makefile b/textproc/p5-Devel-TraceSAX/Makefile
index 39f758233891..ac1816d54062 100644
--- a/textproc/p5-Devel-TraceSAX/Makefile
+++ b/textproc/p5-Devel-TraceSAX/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Devel-TraceCalls>=0.03:${PORTSDIR}/devel/p5-Devel-TraceCalls \
p5-XML-SAX-Machines>=0:${PORTSDIR}/textproc/p5-XML-SAX-Machines
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::TraceSAX.3
diff --git a/textproc/p5-HTML-Quoted/Makefile b/textproc/p5-HTML-Quoted/Makefile
index 9997df28b805..b640dad60ffc 100644
--- a/textproc/p5-HTML-Quoted/Makefile
+++ b/textproc/p5-HTML-Quoted/Makefile
@@ -12,7 +12,8 @@ COMMENT= Extract structure of quoted HTML mail message
BUILD_DEPENDS= p5-HTML-Parser>=3.0:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Quoted.3
diff --git a/textproc/p5-Lingua-EN-Inflect-Number/Makefile b/textproc/p5-Lingua-EN-Inflect-Number/Makefile
index 8e5ecd16c212..a4ef264d8e44 100644
--- a/textproc/p5-Lingua-EN-Inflect-Number/Makefile
+++ b/textproc/p5-Lingua-EN-Inflect-Number/Makefile
@@ -16,7 +16,8 @@ COMMENT= Force number of words to singular or plural
BUILD_DEPENDS= p5-Lingua-EN-Inflect>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Lingua::EN::Inflect::Number.3
diff --git a/textproc/p5-PPI-HTML/Makefile b/textproc/p5-PPI-HTML/Makefile
index a2967a9320bc..9e1cc7e0adcc 100644
--- a/textproc/p5-PPI-HTML/Makefile
+++ b/textproc/p5-PPI-HTML/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-PPI>=0.990:${PORTSDIR}/textproc/p5-PPI \
p5-Params-Util>=0.05:${PORTSDIR}/devel/p5-Params-Util
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PPI::HTML.3
diff --git a/textproc/p5-PPI-XS/Makefile b/textproc/p5-PPI-XS/Makefile
index 2d6880f959a0..6329e3347c87 100644
--- a/textproc/p5-PPI-XS/Makefile
+++ b/textproc/p5-PPI-XS/Makefile
@@ -13,7 +13,8 @@ COMMENT= XS acceleration for the PPI perl parser
RUN_DEPENDS= p5-PPI>=1.000:${PORTSDIR}/textproc/p5-PPI
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PPI::XS.3
diff --git a/textproc/p5-PPI/Makefile b/textproc/p5-PPI/Makefile
index da389b7191ea..02295b9f15b1 100644
--- a/textproc/p5-PPI/Makefile
+++ b/textproc/p5-PPI/Makefile
@@ -25,7 +25,8 @@ TEST_DEPENDS= p5-Test-NoWarnings>=0.084:${PORTSDIR}/devel/p5-Test-NoWarnings \
p5-Test-Object>=0.07:${PORTSDIR}/devel/p5-Test-Object \
p5-Test-SubCalls>=1.07:${PORTSDIR}/devel/p5-Test-SubCalls
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PPI.3 \
PPI::Cache.3 \
diff --git a/textproc/p5-Perl-MinimumVersion/Makefile b/textproc/p5-Perl-MinimumVersion/Makefile
index 56127fad3fc4..c3986adda55b 100644
--- a/textproc/p5-Perl-MinimumVersion/Makefile
+++ b/textproc/p5-Perl-MinimumVersion/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-File-Find-Rule>=0.32:${PORTSDIR}/devel/p5-File-Find-Rule \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Script>=0:${PORTSDIR}/devel/p5-Test-Script
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= perlver.1
MAN3= Perl::MinimumVersion.3
diff --git a/textproc/p5-Pod-Spell/Makefile b/textproc/p5-Pod-Spell/Makefile
index e1e61609f373..b7bdd657ca5d 100644
--- a/textproc/p5-Pod-Spell/Makefile
+++ b/textproc/p5-Pod-Spell/Makefile
@@ -12,7 +12,8 @@ COMMENT= A formatter for spellchecking Pod
BUILD_DEPENDS= p5-Pod-Escapes>=1.01:${PORTSDIR}/textproc/p5-Pod-Escapes
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= podspell.1
MAN3= Pod::Spell.3 \
diff --git a/textproc/p5-Regexp-Common-net-CIDR/Makefile b/textproc/p5-Regexp-Common-net-CIDR/Makefile
index e2603179b220..4409731feb57 100644
--- a/textproc/p5-Regexp-Common-net-CIDR/Makefile
+++ b/textproc/p5-Regexp-Common-net-CIDR/Makefile
@@ -17,7 +17,8 @@ COMMENT= Provide patterns for CIDR blocks
BUILD_DEPENDS= p5-Regexp-Common>0:${PORTSDIR}/textproc/p5-Regexp-Common
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Regexp::Common::net::CIDR.3
diff --git a/textproc/p5-Regexp-IPv6/Makefile b/textproc/p5-Regexp-IPv6/Makefile
index 9042eab86297..edf9df3a1e52 100644
--- a/textproc/p5-Regexp-IPv6/Makefile
+++ b/textproc/p5-Regexp-IPv6/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Regular expression for IPv6 addresses
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Regexp::IPv6.3
diff --git a/textproc/p5-String-Truncate/Makefile b/textproc/p5-String-Truncate/Makefile
index 1334eaf341d3..c751804bae86 100644
--- a/textproc/p5-String-Truncate/Makefile
+++ b/textproc/p5-String-Truncate/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-Sub-Exporter>=0.953:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-Sub-Install>=0.03:${PORTSDIR}/devel/p5-Sub-Install
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::Truncate.3
diff --git a/textproc/p5-Text-ASCIITable/Makefile b/textproc/p5-Text-ASCIITable/Makefile
index a9cf486b4d7d..c6b0db20b75a 100644
--- a/textproc/p5-Text-ASCIITable/Makefile
+++ b/textproc/p5-Text-ASCIITable/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Create a nice formatted table using ASCII characters
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::ASCIITable.3 \
Text::ASCIITable::Wrap.3
diff --git a/textproc/p5-Text-FixEOL/Makefile b/textproc/p5-Text-FixEOL/Makefile
index f92246303c09..3b97e99d7632 100644
--- a/textproc/p5-Text-FixEOL/Makefile
+++ b/textproc/p5-Text-FixEOL/Makefile
@@ -17,6 +17,7 @@ COMMENT= Canonicalizes text to a specified EOL/EOF convention
MAN3= Text::FixEOL.3
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/textproc/p5-Text-RecordParser/Makefile b/textproc/p5-Text-RecordParser/Makefile
index 9382851b3e22..cfa8198ad873 100644
--- a/textproc/p5-Text-RecordParser/Makefile
+++ b/textproc/p5-Text-RecordParser/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= tablify.1 tabmerge.1 tab2graph.1
MAN3= Text::RecordParser.3 \
diff --git a/textproc/p5-Text-TabularDisplay/Makefile b/textproc/p5-Text-TabularDisplay/Makefile
index fef503ca2a66..e1dc08f9dfda 100644
--- a/textproc/p5-Text-TabularDisplay/Makefile
+++ b/textproc/p5-Text-TabularDisplay/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Display text in formatted table output
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::TabularDisplay.3
diff --git a/textproc/p5-Text-Truncate/Makefile b/textproc/p5-Text-Truncate/Makefile
index e5c827bd2168..9ae2437affe5 100644
--- a/textproc/p5-Text-Truncate/Makefile
+++ b/textproc/p5-Text-Truncate/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Perl module with simple string truncating routine
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Truncate.3
diff --git a/textproc/p5-Version-Next/Makefile b/textproc/p5-Version-Next/Makefile
index 24f713eee3db..c5dc43a4437c 100644
--- a/textproc/p5-Version-Next/Makefile
+++ b/textproc/p5-Version-Next/Makefile
@@ -13,7 +13,8 @@ COMMENT= Increment module version numbers simply and correctly
BUILD_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Version::Next.3
diff --git a/textproc/p5-XML-Rules/Makefile b/textproc/p5-XML-Rules/Makefile
index 7f4817ecd1a2..7bf03dd679a3 100644
--- a/textproc/p5-XML-Rules/Makefile
+++ b/textproc/p5-XML-Rules/Makefile
@@ -12,7 +12,8 @@ COMMENT= Parse XML and specify rules for individual tags
RUN_DEPENDS= p5-XML-Parser>=2.00:${PORTSDIR}/textproc/p5-XML-Parser
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= XML::Rules.3
diff --git a/textproc/p5-XML-SAX-Expat-Incremental/Makefile b/textproc/p5-XML-SAX-Expat-Incremental/Makefile
index 90e0362c2096..c315837b6bc4 100644
--- a/textproc/p5-XML-SAX-Expat-Incremental/Makefile
+++ b/textproc/p5-XML-SAX-Expat-Incremental/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-XML-Parser>0:${PORTSDIR}/textproc/p5-XML-Parser \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::SAX::Expat::Incremental.3
diff --git a/textproc/p5-XML-SemanticDiff/Makefile b/textproc/p5-XML-SemanticDiff/Makefile
index 22fbdadc5d9a..f43bb9cf6ef5 100644
--- a/textproc/p5-XML-SemanticDiff/Makefile
+++ b/textproc/p5-XML-SemanticDiff/Makefile
@@ -18,7 +18,8 @@ COMMENT= Perl extension for comparing XML documents
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::SemanticDiff.3 \
XML::SemanticDiff::BasicHandler.3
diff --git a/textproc/p5-pod2pdf/Makefile b/textproc/p5-pod2pdf/Makefile
index 48dc56bc7af6..31535ed91194 100644
--- a/textproc/p5-pod2pdf/Makefile
+++ b/textproc/p5-pod2pdf/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-PDF-API2>=0.60:${PORTSDIR}/textproc/p5-PDF-API2 \
p5-Getopt-ArgvFile>0:${PORTSDIR}/devel/p5-Getopt-ArgvFile
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= pod2pdf.1