aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 01:03:31 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 01:03:31 +0800
commite2f96857d066656c848c4f3ba82fef21290d9d5e (patch)
tree2029bb0efe173955773e6000ae9d743508541586 /textproc
parent60c302619012f512e63fad30f32ec2c5a3b2b80f (diff)
downloadfreebsd-ports-gnome-e2f96857d066656c848c4f3ba82fef21290d9d5e.tar.gz
freebsd-ports-gnome-e2f96857d066656c848c4f3ba82fef21290d9d5e.tar.zst
freebsd-ports-gnome-e2f96857d066656c848c4f3ba82fef21290d9d5e.zip
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/dictem/Makefile2
-rw-r--r--textproc/spellutils/Makefile2
-rw-r--r--textproc/sphinxsearch-devel/Makefile2
-rw-r--r--textproc/tokyodystopia/Makefile4
-rw-r--r--textproc/xerces-c2-devel/Makefile2
-rw-r--r--textproc/xmlto/Makefile1
6 files changed, 10 insertions, 3 deletions
diff --git a/textproc/dictem/Makefile b/textproc/dictem/Makefile
index 0cde204e4012..cdfc97cfc53b 100644
--- a/textproc/dictem/Makefile
+++ b/textproc/dictem/Makefile
@@ -27,6 +27,8 @@ PLIST_DIRS+= ${LISPDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS+= README AUTHORS NEWS COPYING TODO
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${EMACS_NAME} == "xemacs"
diff --git a/textproc/spellutils/Makefile b/textproc/spellutils/Makefile
index 1a2fa3767b57..1720aa70acc8 100644
--- a/textproc/spellutils/Makefile
+++ b/textproc/spellutils/Makefile
@@ -20,6 +20,8 @@ LIBS+= -L${LOCALBASE}/lib -lintl
DOCS= NEWS README
EXAMPLES= aspell.sl
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
diff --git a/textproc/sphinxsearch-devel/Makefile b/textproc/sphinxsearch-devel/Makefile
index cb49e01ea317..6d371eaa1e2b 100644
--- a/textproc/sphinxsearch-devel/Makefile
+++ b/textproc/sphinxsearch-devel/Makefile
@@ -28,7 +28,7 @@ LATEST_LINK= sphinxsearch-devel
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
- SYSLOG UNIXODBC
+ SYSLOG UNIXODBC DOCS EXAMPLES
OPTIONS_DEFAULT=ICONV MYSQL SYSLOG
ICONV_CONFIGURE_WITH= iconv
diff --git a/textproc/tokyodystopia/Makefile b/textproc/tokyodystopia/Makefile
index 969d69ea6fde..dd327318b3cc 100644
--- a/textproc/tokyodystopia/Makefile
+++ b/textproc/tokyodystopia/Makefile
@@ -23,6 +23,8 @@ SHLIB_VER_MAJ= 1
PLIST_SUB= SHLIB_VER=${SHLIB_VER} SHLIB_VER_MAJ=${SHLIB_VER_MAJ}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-extract:
@@ -32,7 +34,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|@prefix@/libdata/pkgconfig|' \
-e 's|DATADIR =.*|DATADIR = ${DOCSDIR}|' \
${WRKSRC}/Makefile.in
-.if defined(PORT_OPTIONS:MDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e 's|mkdir -p $$(DESTDIR)$$(DATADIR)||' \
-e 's|cp -Rf $$(DOCUMENTFILES) $$(DESTDIR)$$(DATADIR)||' \
${WRKSRC}/Makefile.in
diff --git a/textproc/xerces-c2-devel/Makefile b/textproc/xerces-c2-devel/Makefile
index 1c0f08712e6d..0e26080f422c 100644
--- a/textproc/xerces-c2-devel/Makefile
+++ b/textproc/xerces-c2-devel/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= xerces_c2-[0-9]* xerces-c3-[0-9]*
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= THREADS DEBUG ICONVFBSD ICU NATIVE
+OPTIONS_DEFINE= THREADS DEBUG ICONVFBSD ICU NATIVE EXAMPLES DOCS
OPTIONS_DEFAULT= THREADS ICONVFBSD
THREADS_DESC= Build a thread enabled shared library
diff --git a/textproc/xmlto/Makefile b/textproc/xmlto/Makefile
index da8557328825..f4720e3d5427 100644
--- a/textproc/xmlto/Makefile
+++ b/textproc/xmlto/Makefile
@@ -31,6 +31,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
OPTIONS_GROUP= BACKEND
OPTIONS_GROUP_BACKEND= DBLATEX FOP PASSIVETEX
BACKEND_DESC= Postprocessor backends to enable