aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-03-26 10:43:02 +0800
committerSteve Wills <swills@FreeBSD.org>2015-03-26 10:43:02 +0800
commite709a7738e59955506f8f5de72f2c0b2c8d9243f (patch)
tree8d14ed63894d0ab8732c7ee0eb56a4321eb312eb /textproc
parentb1147a51f909dad89267bbc2438c278dc4ca4360 (diff)
downloadfreebsd-ports-gnome-e709a7738e59955506f8f5de72f2c0b2c8d9243f.tar.gz
freebsd-ports-gnome-e709a7738e59955506f8f5de72f2c0b2c8d9243f.tar.zst
freebsd-ports-gnome-e709a7738e59955506f8f5de72f2c0b2c8d9243f.zip
textproc/consul-template: create port
Generic template rendering and notifications with Consul
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/consul-template/Makefile54
-rw-r--r--textproc/consul-template/distinfo12
-rw-r--r--textproc/consul-template/pkg-descr3
4 files changed, 70 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 316a7404cc79..0faa8457ff21 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -79,6 +79,7 @@
SUBDIR += colordiff
SUBDIR += confetti
SUBDIR += confget
+ SUBDIR += consul-template
SUBDIR += crimson
SUBDIR += cs-aspell
SUBDIR += cs-mythes
diff --git a/textproc/consul-template/Makefile b/textproc/consul-template/Makefile
new file mode 100644
index 000000000000..577cd7366333
--- /dev/null
+++ b/textproc/consul-template/Makefile
@@ -0,0 +1,54 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= consul-template
+PORTVERSION= 0.3.1
+CATEGORIES= textproc
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/archive/${GH_TAGNAME}.tar.gz?dummy=/:group1 \
+ https://codeload.github.com/armon/consul-api/legacy.tar.gz/0e644b8?dummy=/:group2 \
+ https://codeload.github.com/hashicorp/hcl/legacy.tar.gz/2c88e7e?dummy=/:group3 \
+ https://codeload.github.com/hashicorp/logutils/legacy.tar.gz/23b0af5?dummy=/:group4 \
+ https://codeload.github.com/hashicorp/terraform/legacy.tar.gz/d87fa90?dummy=/:group5 \
+ https://codeload.github.com/mitchellh/mapstructure/legacy.tar.gz/740c764?dummy=/:group6
+DISTFILES= consul-template-0.3.1.tar.gz:group1 \
+ armon-consul-api-0e644b8.tar.gz:group2 \
+ hashicorp-hcl-2c88e7e.tar.gz:group3 \
+ hashicorp-logutils-23b0af5.tar.gz:group4 \
+ hashicorp-terraform-d87fa90.tar.gz:group5 \
+ mitchellh-mapstructure-740c764.tar.gz:group6
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Generic template rendering and notifications with Consul
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= hashicorp
+GH_COMMIT= e22fbf7
+GH_TAGNAME= v${PORTVERSION}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/consul-template
+
+STRIP= # stripping can break go binaries
+
+post-patch:
+ @${MKDIR} ${WRKSRC}/src/github.com/armon
+ @${MKDIR} ${WRKSRC}/src/github.com/hashicorp/consul-template
+ @${MKDIR} ${WRKSRC}/src/github.com/mitchellh
+ @${MV} ${WRKDIR}/armon-consul-api-0e644b8 ${WRKSRC}/src/github.com/armon/consul-api
+ @${MV} ${WRKDIR}/hashicorp-hcl-2c88e7e ${WRKSRC}/src/github.com/hashicorp/hcl
+ @${MV} ${WRKDIR}/hashicorp-logutils-23b0af5 ${WRKSRC}/src/github.com/hashicorp/logutils
+ @${MV} ${WRKDIR}/hashicorp-terraform-d87fa90 ${WRKSRC}/src/github.com/hashicorp/terraform
+ @${MV} ${WRKDIR}/mitchellh-mapstructure-740c764 ${WRKSRC}/src/github.com/mitchellh/mapstructure
+ @${MV} ${WRKSRC}/util ${WRKSRC}/src/github.com/hashicorp/consul-template
+ @${MV} ${WRKSRC}/test ${WRKSRC}/src/github.com/hashicorp/consul-template
+
+do-build:
+ @cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC} go build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/consul-template-${PORTVERSION} ${STAGEDIR}${PREFIX}/bin/consul-template
+
+.include <bsd.port.mk>
diff --git a/textproc/consul-template/distinfo b/textproc/consul-template/distinfo
new file mode 100644
index 000000000000..7eb798d65d9b
--- /dev/null
+++ b/textproc/consul-template/distinfo
@@ -0,0 +1,12 @@
+SHA256 (consul-template-0.3.1.tar.gz) = fc920c58e24913fac4d60c9108b40eaae47d4a7ad23e97dd16ddb36c76723cd9
+SIZE (consul-template-0.3.1.tar.gz) = 37745
+SHA256 (armon-consul-api-0e644b8.tar.gz) = 98ced8eb879ad2aec426e8821973e476ad76d5e91aa467362aaac98b7ae639b0
+SIZE (armon-consul-api-0e644b8.tar.gz) = 17558
+SHA256 (hashicorp-hcl-2c88e7e.tar.gz) = 2f3dc2241a1716b8e9c7bd331d8113b9b780a1233bf2dcf73bb77c68ebe17d0e
+SIZE (hashicorp-hcl-2c88e7e.tar.gz) = 28350
+SHA256 (hashicorp-logutils-23b0af5.tar.gz) = 00187038a1bbf6ac3575e7630216903fdbbe6165dd4d4415023d030736994025
+SIZE (hashicorp-logutils-23b0af5.tar.gz) = 7691
+SHA256 (hashicorp-terraform-d87fa90.tar.gz) = 5657d8f9a596c94e86c72d50e8eedbb4da8942eed56e5317e6611a488c557d54
+SIZE (hashicorp-terraform-d87fa90.tar.gz) = 3245770
+SHA256 (mitchellh-mapstructure-740c764.tar.gz) = 5d140730c448532df9b1413fe03e752462a992d6ff2badcc5d2eb4bb9346a478
+SIZE (mitchellh-mapstructure-740c764.tar.gz) = 11949
diff --git a/textproc/consul-template/pkg-descr b/textproc/consul-template/pkg-descr
new file mode 100644
index 000000000000..dbb8f2920492
--- /dev/null
+++ b/textproc/consul-template/pkg-descr
@@ -0,0 +1,3 @@
+Generic template rendering and notifications with Consul
+
+WWW: https://github.com/hashicorp/consul-template