aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-15 15:06:28 +0800
committermarino <marino@FreeBSD.org>2014-08-15 15:06:28 +0800
commited8d50473f8c49390f181b0e719ba0e3484e2ba5 (patch)
tree08e1ff578accff87f3d0ed4593c5522ca3a51ddc /textproc
parentec2029f4714f49ba80783814fd44665131df264f (diff)
downloadfreebsd-ports-gnome-ed8d50473f8c49390f181b0e719ba0e3484e2ba5.tar.gz
freebsd-ports-gnome-ed8d50473f8c49390f181b0e719ba0e3484e2ba5.tar.zst
freebsd-ports-gnome-ed8d50473f8c49390f181b0e719ba0e3484e2ba5.zip
Stage textproc/rtfx and unbreak 64-bit arches
PR: 192667 Submitted by: Jan Beich
Diffstat (limited to 'textproc')
-rw-r--r--textproc/rtfx/Makefile18
-rw-r--r--textproc/rtfx/files/patch-src-xmlfixups.cpp11
-rw-r--r--textproc/rtfx/pkg-descr3
3 files changed, 17 insertions, 15 deletions
diff --git a/textproc/rtfx/Makefile b/textproc/rtfx/Makefile
index d1c537ecf8ad..d203bcba8b15 100644
--- a/textproc/rtfx/Makefile
+++ b/textproc/rtfx/Makefile
@@ -5,7 +5,7 @@ PORTNAME= rtfx
PORTVERSION= 1.1
PORTREVISION= 1
CATEGORIES= textproc
-MASTER_SITES= http://memberwebs.com/stef/software/rtfx/
+MASTER_SITES= http://thewalter.net/stef/software/rtfx/
MAINTAINER= ports@FreeBSD.org
COMMENT= RTF to XML converter
@@ -13,18 +13,10 @@ COMMENT= RTF to XML converter
LIB_DEPENDS= libmba.so:${PORTSDIR}/devel/libmba \
libdomc.so:${PORTSDIR}/textproc/domc
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX} --datarootdir=${PREFIX}
+GNU_CONFIGURE= yes
USES= gmake
-PLIST_FILES= bin/rtfx
-MAN1= rtfx.1
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64 || ${ARCH} == sparc64
-BROKEN= Does not compile on sparc64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/rtfx/files/patch-src-xmlfixups.cpp b/textproc/rtfx/files/patch-src-xmlfixups.cpp
new file mode 100644
index 000000000000..b2f39c74af1f
--- /dev/null
+++ b/textproc/rtfx/files/patch-src-xmlfixups.cpp
@@ -0,0 +1,11 @@
+--- src/xmlfixups.cpp~
++++ src/xmlfixups.cpp
+@@ -453,7 +453,7 @@ void XmlFixups::runPassTwo(const DOM::Do
+
+ // Mark each node as we've seen it so we don't
+ // do a given element twice
+- if((int)el.getUserData() == PASS_TWO)
++ if((intptr_t)el.getUserData() == (intptr_t)PASS_TWO)
+ continue;
+
+ el.setUserData((void*)PASS_TWO);
diff --git a/textproc/rtfx/pkg-descr b/textproc/rtfx/pkg-descr
index a3180e72f3ac..3a74bbbc6655 100644
--- a/textproc/rtfx/pkg-descr
+++ b/textproc/rtfx/pkg-descr
@@ -7,5 +7,4 @@ RTF features supported: page breaks, section breaks, style names,
lists (various types), tables, footnotes, info block, bold, italic,
underline, super/sub script, hidden text, strike out, text color, fonts.
-Author: Nielsen <nielsen at memberwebs.com>
-WWW: http://memberwebs.com/nielsen/software/rtfx/
+WWW: http://thewalter.net/stef/software/rtfx/