aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-02-24 06:05:58 +0800
committerswills <swills@FreeBSD.org>2012-02-24 06:05:58 +0800
commitf2956c9ee107a33029dd45337368fcb73384921d (patch)
treef5d4cbf881c51bb21ac618f1957cf230521251e1 /textproc
parent14454866337f4a58a250c71c159261d8b2faa17f (diff)
downloadfreebsd-ports-gnome-f2956c9ee107a33029dd45337368fcb73384921d.tar.gz
freebsd-ports-gnome-f2956c9ee107a33029dd45337368fcb73384921d.tar.zst
freebsd-ports-gnome-f2956c9ee107a33029dd45337368fcb73384921d.zip
Generate random Latin looking text
WWW: http://search.cpan.org/dist/Text-Lorem/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Lorem/Makefile22
-rw-r--r--textproc/p5-Text-Lorem/distinfo2
-rw-r--r--textproc/p5-Text-Lorem/pkg-descr3
-rw-r--r--textproc/p5-Text-Lorem/pkg-plist6
5 files changed, 34 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 5cca727ae094..f4b259c6b416 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -794,6 +794,7 @@
SUBDIR += p5-Text-Highlight
SUBDIR += p5-Text-HikiDoc
SUBDIR += p5-Text-Language-Guess
+ SUBDIR += p5-Text-Lorem
SUBDIR += p5-Text-Markdown
SUBDIR += p5-Text-Match-FastAlternatives
SUBDIR += p5-Text-Metaphone
diff --git a/textproc/p5-Text-Lorem/Makefile b/textproc/p5-Text-Lorem/Makefile
new file mode 100644
index 000000000000..a0573ffe30bb
--- /dev/null
+++ b/textproc/p5-Text-Lorem/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Text-Lorem
+# Date created: 2012-02-23
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Lorem
+PORTVERSION= 0.3
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Generate random Latin looking text
+
+PERL_CONFIGURE= yes
+
+MAN1= lorem.1
+MAN3= Text::Lorem.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Lorem/distinfo b/textproc/p5-Text-Lorem/distinfo
new file mode 100644
index 000000000000..05bace8ae7cd
--- /dev/null
+++ b/textproc/p5-Text-Lorem/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Text-Lorem-0.3.tar.gz) = 64bb636fb21213101a646b414ecbdc1b55edf905cbcdc7f5d24774ec5061fe2d
+SIZE (Text-Lorem-0.3.tar.gz) = 4367
diff --git a/textproc/p5-Text-Lorem/pkg-descr b/textproc/p5-Text-Lorem/pkg-descr
new file mode 100644
index 000000000000..16b8ec82b502
--- /dev/null
+++ b/textproc/p5-Text-Lorem/pkg-descr
@@ -0,0 +1,3 @@
+Generate random Latin looking text
+
+WWW: http://search.cpan.org/dist/Text-Lorem/
diff --git a/textproc/p5-Text-Lorem/pkg-plist b/textproc/p5-Text-Lorem/pkg-plist
new file mode 100644
index 000000000000..9bc8e6fb4437
--- /dev/null
+++ b/textproc/p5-Text-Lorem/pkg-plist
@@ -0,0 +1,6 @@
+bin/lorem
+%%SITE_PERL%%/Text/Lorem.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Lorem/.packlist
+@dirrmtry %%SITE_PERL%%/Text
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Lorem
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text