aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-02-19 03:48:05 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2017-02-19 03:48:05 +0800
commitf3c180c3431372077934f7658922b8a244419bdf (patch)
tree4d04227f02c7fda007ad74be01e1393168277b0b /textproc
parent748a0f2465dd8511da6092b69cbe578ce5749586 (diff)
downloadfreebsd-ports-gnome-f3c180c3431372077934f7658922b8a244419bdf.tar.gz
freebsd-ports-gnome-f3c180c3431372077934f7658922b8a244419bdf.tar.zst
freebsd-ports-gnome-f3c180c3431372077934f7658922b8a244419bdf.zip
Update Qt5 to 5.7.1, and unify the Qt4 and Qt5 ports some more
* Update Qt5 to 5.7.1 * Move Qt4 binaries to lib/qt4/bin * Move Qt5 libraries to lib/qt5/lib By moving the libraries we should finally be able to get rid of the inplace upgrade bug (see ports bugs 194088, 195105 and 198720): when Qt5's libraries were lying in /usr/local/lib, which would often get added by pkgconfig to the linker paths via dependencies, the already installed libraries were linked against, instead of the ones that were being built. This forced us to make sure, that -L${WRKSRC}/lib was always coming before -L/usr/local/lib in the linker flags. With this change this should no longer be the case. * Rename some ports to match the rest (foo-qtX -> qtX-foo) * Depend on new port misc/qtchooser [see UPDATING & CHANGES] There are several new Qt5 ports which all have been created by Marie Loise Nolden <nolden@kde.org>. Thanks again. PR: 216797 Exp-Run by: antoine Reviewed by: rakuco, mat, groot_kde.org Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D9213
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile2
-rw-r--r--textproc/goldendict/files/patch-goldendict.pro9
-rw-r--r--textproc/qt4-clucene/Makefile (renamed from textproc/clucene-qt4/Makefile)1
-rw-r--r--textproc/qt4-clucene/files/patch-src__3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp (renamed from textproc/clucene-qt4/files/patch-src__3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp)0
-rw-r--r--textproc/qt4-clucene/pkg-plist (renamed from textproc/clucene-qt4/pkg-plist)0
-rw-r--r--textproc/qt4-xml/Makefile1
-rw-r--r--textproc/qt4-xmlpatterns-tool/Makefile1
-rw-r--r--textproc/qt4-xmlpatterns/Makefile1
-rw-r--r--textproc/qt5-xml/pkg-plist4
-rw-r--r--textproc/qt5-xmlpatterns/pkg-plist4
-rw-r--r--textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in9
11 files changed, 9 insertions, 23 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 308aeaa5abb0..574b6ecc8161 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -80,7 +80,6 @@
SUBDIR += cl-ppcre-sbcl
SUBDIR += clit
SUBDIR += clucene
- SUBDIR += clucene-qt4
SUBDIR += cmark
SUBDIR += coccigrep
SUBDIR += code2html
@@ -1368,6 +1367,7 @@
SUBDIR += qprint
SUBDIR += qrcodegen
SUBDIR += qstardict
+ SUBDIR += qt4-clucene
SUBDIR += qt4-xml
SUBDIR += qt4-xmlpatterns
SUBDIR += qt4-xmlpatterns-tool
diff --git a/textproc/goldendict/files/patch-goldendict.pro b/textproc/goldendict/files/patch-goldendict.pro
index ee38f56b8674..4f7442d0666f 100644
--- a/textproc/goldendict/files/patch-goldendict.pro
+++ b/textproc/goldendict/files/patch-goldendict.pro
@@ -34,12 +34,3 @@
}
DEFINES += PROGRAM_VERSION=\\\"$$VERSION\\\"
-@@ -267,8 +269,6 @@
- }
-
- # This makes qmake generate translations
--win32:# Windows doesn't seem to have *-qt4 symlinks
--isEmpty(QMAKE_LRELEASE):QMAKE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease
- isEmpty(QMAKE_LRELEASE):QMAKE_LRELEASE = $$[QT_INSTALL_BINS]/lrelease-qt4
- updateqm.input = TRANSLATIONS
- updateqm.output = ${QMAKE_FILE_PATH}/${QMAKE_FILE_BASE}.qm
diff --git a/textproc/clucene-qt4/Makefile b/textproc/qt4-clucene/Makefile
index cff5e5a3f878..13b8fe2dd1f2 100644
--- a/textproc/clucene-qt4/Makefile
+++ b/textproc/qt4-clucene/Makefile
@@ -3,6 +3,7 @@
PORTNAME= clucene
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= qt4-
diff --git a/textproc/clucene-qt4/files/patch-src__3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp b/textproc/qt4-clucene/files/patch-src__3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp
index 1e6b73d69a4e..1e6b73d69a4e 100644
--- a/textproc/clucene-qt4/files/patch-src__3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp
+++ b/textproc/qt4-clucene/files/patch-src__3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp
diff --git a/textproc/clucene-qt4/pkg-plist b/textproc/qt4-clucene/pkg-plist
index 09f728cc2feb..09f728cc2feb 100644
--- a/textproc/clucene-qt4/pkg-plist
+++ b/textproc/qt4-clucene/pkg-plist
diff --git a/textproc/qt4-xml/Makefile b/textproc/qt4-xml/Makefile
index 9039e335239e..d70e941022ea 100644
--- a/textproc/qt4-xml/Makefile
+++ b/textproc/qt4-xml/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xml
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= qt4-
diff --git a/textproc/qt4-xmlpatterns-tool/Makefile b/textproc/qt4-xmlpatterns-tool/Makefile
index f4a5bbd9b725..89ccd0b1149a 100644
--- a/textproc/qt4-xmlpatterns-tool/Makefile
+++ b/textproc/qt4-xmlpatterns-tool/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlpatterns-tool
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= qt4-
diff --git a/textproc/qt4-xmlpatterns/Makefile b/textproc/qt4-xmlpatterns/Makefile
index e878a0f1d91e..11012253c4b7 100644
--- a/textproc/qt4-xmlpatterns/Makefile
+++ b/textproc/qt4-xmlpatterns/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlpatterns
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= qt4-
diff --git a/textproc/qt5-xml/pkg-plist b/textproc/qt5-xml/pkg-plist
index 9baf75565a40..01c203e99dce 100644
--- a/textproc/qt5-xml/pkg-plist
+++ b/textproc/qt5-xml/pkg-plist
@@ -37,8 +37,8 @@
%%QT_INCDIR%%/QtXml/qtxmlglobal.h
%%QT_INCDIR%%/QtXml/qtxmlversion.h
%%QT_INCDIR%%/QtXml/qxml.h
-%%QT_LIBDIR%%/cmake/Qt5Xml/Qt5XmlConfig.cmake
-%%QT_LIBDIR%%/cmake/Qt5Xml/Qt5XmlConfigVersion.cmake
+%%QT_CMAKEDIR%%/Qt5Xml/Qt5XmlConfig.cmake
+%%QT_CMAKEDIR%%/Qt5Xml/Qt5XmlConfigVersion.cmake
%%QT_LIBDIR%%/libQt5Xml.prl
%%QT_LIBDIR%%/libQt5Xml.so
%%QT_LIBDIR%%/libQt5Xml.so.5
diff --git a/textproc/qt5-xmlpatterns/pkg-plist b/textproc/qt5-xmlpatterns/pkg-plist
index 66533504ac38..640bf086f872 100644
--- a/textproc/qt5-xmlpatterns/pkg-plist
+++ b/textproc/qt5-xmlpatterns/pkg-plist
@@ -401,8 +401,8 @@
%%QT_INCDIR%%/QtXmlPatterns/qxmlschema.h
%%QT_INCDIR%%/QtXmlPatterns/qxmlschemavalidator.h
%%QT_INCDIR%%/QtXmlPatterns/qxmlserializer.h
-%%QT_LIBDIR%%/cmake/Qt5XmlPatterns/Qt5XmlPatternsConfig.cmake
-%%QT_LIBDIR%%/cmake/Qt5XmlPatterns/Qt5XmlPatternsConfigVersion.cmake
+%%QT_CMAKEDIR%%/Qt5XmlPatterns/Qt5XmlPatternsConfig.cmake
+%%QT_CMAKEDIR%%/Qt5XmlPatterns/Qt5XmlPatternsConfigVersion.cmake
%%QT_LIBDIR%%/libQt5XmlPatterns.prl
%%QT_LIBDIR%%/libQt5XmlPatterns.so
%%QT_LIBDIR%%/libQt5XmlPatterns.so.5
diff --git a/textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in b/textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in
index bb557768a682..293c0745cd88 100644
--- a/textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in
+++ b/textproc/scim-bridge-qt4/files/patch-client-qt_qt4_Makefile.in
@@ -9,12 +9,3 @@
@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@module_LTLIBRARIES = im-scim-bridge.la
@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@im_scim_bridge_la_SOURCES = ../im-scim-bridge-qt.cpp \
@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@ ../scim-bridge-client-qt.cpp \
-@@ -261,7 +261,7 @@
- @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@im_scim_bridge_la_LIBADD = $(top_srcdir)/common/libscimbridgecommon.la \
- @SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@ $(top_srcdir)/client-common/libscimbridgeclientcommon.la
-
--@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@MOC = @QT4_PREFIX@/bin/moc
-+@SCIM_BRIDGE_BUILD_QT4_IMMODULE_TRUE@MOC = @QT4_PREFIX@/bin/moc-qt4
- MAINTAINERCLEANFILES = Makefile.in
- CLEANFILES = moc_scim-bridge-client-qt.cpp
- all: all-am