aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-10-15 17:11:14 +0800
committergahr <gahr@FreeBSD.org>2013-10-15 17:11:14 +0800
commitfc023b76b2cd98ee5d899ca815ce61c36a0a0fb0 (patch)
tree9a943713e84105756de3035c48c610101194e75e /textproc
parent41a6f0d8de0ab2152ff7059b00ac218a52387585 (diff)
downloadfreebsd-ports-gnome-fc023b76b2cd98ee5d899ca815ce61c36a0a0fb0.tar.gz
freebsd-ports-gnome-fc023b76b2cd98ee5d899ca815ce61c36a0a0fb0.tar.zst
freebsd-ports-gnome-fc023b76b2cd98ee5d899ca815ce61c36a0a0fb0.zip
- Convert to USES+=tk
- Convert to OPTIONSng (DOCS) - STAGE-clean
Diffstat (limited to 'textproc')
-rw-r--r--textproc/redet/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/textproc/redet/Makefile b/textproc/redet/Makefile
index e5c6fd75d29c..fc2c7adcebbb 100644
--- a/textproc/redet/Makefile
+++ b/textproc/redet/Makefile
@@ -11,24 +11,27 @@ COMMENT= Visual regexp development and execution
RUN_DEPENDS= ${LOCALBASE}/lib/iwidgets/iwidgets.tcl:${PORTSDIR}/x11-toolkits/iwidgets
+OPTIONS_DEFINE= DOCS
+
NO_BUILD= yes
USE_BZIP2= yes
-USE_TK_RUN= 84
+USES+= tk:run
PORTDOCS= AUTHORS COPYING CREDITS LICENSE NEWS README-General ChangeLog
-MAN1= redet.1
-PLIST_FILES= bin/redet
+PLIST_FILES= bin/redet \
+ man/man1/redet.1.gz
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s@exec wish@exec ${WISH}@" ${WRKSRC}/redet.tcl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/redet.tcl ${PREFIX}/bin/redet
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1/
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/redet.tcl ${STAGEDIR}${PREFIX}/bin/redet
+ ${INSTALL_MAN} ${WRKSRC}/redet.1 ${STAGEDIR}${PREFIX}/man/man1
+.if ${PORT_OPTIONS:MDOCS}
+ @${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>