aboutsummaryrefslogtreecommitdiffstats
path: root/www/Makefile
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-01-03 07:04:15 +0800
committerpgj <pgj@FreeBSD.org>2010-01-03 07:04:15 +0800
commit382b0bb0d47e0b6872e89152a2b291dbbba95853 (patch)
tree2be6c4be83a690388890ffa0871c28e6f3306b68 /www/Makefile
parentf357b6113fcb8b3dd350ecf4cb69e4b736b4ca43 (diff)
downloadfreebsd-ports-gnome-382b0bb0d47e0b6872e89152a2b291dbbba95853.tar.gz
freebsd-ports-gnome-382b0bb0d47e0b6872e89152a2b291dbbba95853.tar.zst
freebsd-ports-gnome-382b0bb0d47e0b6872e89152a2b291dbbba95853.zip
The HTTP package supports client-side web programming in Haskell. It lets
you set up HTTP connections, transmitting requests and processing the responses coming back, all from within the comforts of Haskell. It's dependent on the network package to operate, but other than that, the implementation is all written in Haskell. A basic API for issuing single HTTP requests + receiving responses is provided. On top of that, a session-level abstraction is also on offer (the BrowserAction monad); it taking care of handling the management of persistent connections, proxies, state (cookies) and authentication credentials required to handle multi-step interactions with a web server. The representation of the bytes flowing across is extensible via the use of a type class, letting you pick the representation of requests and responses that best fits your use. Some pre-packaged, common instances are provided for you (ByteString, String.) WWW: http://projects.haskell.org/http/ PR: ports/142178 Submitted by: Jacula Modyun <jacula(at)gmail.com>
Diffstat (limited to 'www/Makefile')
-rw-r--r--www/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 1987d25c4077..719f43e03520 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -288,6 +288,7 @@
SUBDIR += horde-passwd
SUBDIR += horde-trean
SUBDIR += horde-wicked
+ SUBDIR += hs-HTTP
SUBDIR += htdump
SUBDIR += html2hdml
SUBDIR += html2wml