aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache13+ipv6
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>2001-10-23 12:41:45 +0800
committersumikawa <sumikawa@FreeBSD.org>2001-10-23 12:41:45 +0800
commit215b8f2e508e8d76b7ac8833cec59c6e2d26ea5c (patch)
tree65c724bc0b9d0862b190e72cf1dac67f0b642951 /www/apache13+ipv6
parent258e806e429c0e46aa955be5624722ff7419f2f1 (diff)
downloadfreebsd-ports-gnome-215b8f2e508e8d76b7ac8833cec59c6e2d26ea5c.tar.gz
freebsd-ports-gnome-215b8f2e508e8d76b7ac8833cec59c6e2d26ea5c.tar.zst
freebsd-ports-gnome-215b8f2e508e8d76b7ac8833cec59c6e2d26ea5c.zip
Sync with www/apach13.
Diffstat (limited to 'www/apache13+ipv6')
-rw-r--r--www/apache13+ipv6/Makefile22
-rw-r--r--www/apache13+ipv6/files/FreeBSD.layout2
-rw-r--r--www/apache13+ipv6/files/patch-ab47
-rw-r--r--www/apache13+ipv6/pkg-deinstall20
-rw-r--r--www/apache13+ipv6/pkg-install34
-rw-r--r--www/apache13+ipv6/pkg-plist543
6 files changed, 357 insertions, 311 deletions
diff --git a/www/apache13+ipv6/Makefile b/www/apache13+ipv6/Makefile
index bd13e5c65e48..c216cedc9908 100644
--- a/www/apache13+ipv6/Makefile
+++ b/www/apache13+ipv6/Makefile
@@ -8,6 +8,7 @@
PORTNAME= apache+ipv6
PORTVERSION= 1.3.22
CATEGORIES= www ipv6
+PORTREVISION= 1
MASTER_SITES= http://httpd.apache.org/dist/httpd/ \
ftp://ftp.ccs.neu.edu/net/mirrors/ftp.apache.org/apache/dist/httpd/ \
ftp://ftp.rge.com/pub/infosystems/apache/dist/httpd/ \
@@ -30,14 +31,11 @@ PATCHFILES= apache-1.3.22-v6-20011017.diff.gz
MAINTAINER= sumikawa@FreeBSD.org
-#
-# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
-#
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
--prefix=${PREFIX} \
- --server-gid=nogroup \
+ --server-uid=www \
+ --server-gid=www \
--with-perl=${PERL} \
--with-layout=${FILESDIR}/FreeBSD.layout:FreeBSD \
--suexec-docroot=${PREFIX}/www/data \
@@ -54,7 +52,10 @@ OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin\\" \
-DACCEPT_FILTER_NAME=\\"httpready\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
+#
+# Set WITH_APACHE_PERF_TUNING env. variable to YES to get maximum performance
+#
+.if defined(WITH_APACHE_PERF_TUNING) && ${WITH_APACHE_PERF_TUNING} == YES
OPTIM+= -DBUFFERED_LOGS
CFLAGS+= -O6 -fomit-frame-pointer
.endif
@@ -64,11 +65,8 @@ CONFIGURE_ENV= OPTIM='${OPTIM}'
MAN1= dbmmanage.1 htdigest.1 htpasswd.1
MAN8= ab.8 apachectl.8 apxs.8 httpd.8 logresolve.8 rotatelogs.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 400014
-BROKEN= "build only on IPv6 environment"
-.endif
+pre-install:
+ PKG_PREFIX=${PREFIX} ./pkg-install ${PKGNAME} PRE-INSTALL
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
@@ -76,4 +74,4 @@ post-install:
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/apache.sh ${PREFIX}/etc/rc.d/apache.sh; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/apache13+ipv6/files/FreeBSD.layout b/www/apache13+ipv6/files/FreeBSD.layout
index 29ec00a18559..b73ee2ae1484 100644
--- a/www/apache13+ipv6/files/FreeBSD.layout
+++ b/www/apache13+ipv6/files/FreeBSD.layout
@@ -10,7 +10,7 @@
datadir: $prefix/www
iconsdir: $datadir/icons
htdocsdir: $datadir/data
- manualdir: $prefix/share/doc/apache/manual
+ manualdir: $prefix/share/doc/apache
cgidir: $datadir/cgi-bin
includedir: $prefix/include/apache
localstatedir: /var
diff --git a/www/apache13+ipv6/files/patch-ab b/www/apache13+ipv6/files/patch-ab
index 8615b1e3f9e0..9198d26da0da 100644
--- a/www/apache13+ipv6/files/patch-ab
+++ b/www/apache13+ipv6/files/patch-ab
@@ -1,27 +1,21 @@
--- Makefile.tmpl.orig Sun Oct 7 02:01:09 2001
-+++ Makefile.tmpl Sun Oct 14 11:14:32 2001
-@@ -127,6 +127,7 @@
- runtimedir = @runtimedir@
- logfiledir = @logfiledir@
- proxycachedir = @proxycachedir@
-+doc_prefix = $(prefix)/share/doc/apache
-
- libexecdir_relative = @libexecdir_relative@
-
-@@ -270,10 +271,10 @@
++++ Makefile.tmpl Sun Oct 21 23:17:01 2001
+@@ -270,10 +270,12 @@
$(MKDIR) $(root)$(mandir)/man1
$(MKDIR) $(root)$(mandir)/man8
$(MKDIR) $(root)$(sysconfdir)
- $(MKDIR) $(root)$(htdocsdir)
-+ $(MKDIR) $(root)$(doc_prefix)
++ $(RM) -rf $(root)$(htdocsdir).default
++ $(MKDIR) $(root)$(htdocsdir).default
$(MKDIR) $(root)$(manualdir)
$(MKDIR) $(root)$(iconsdir)
- $(MKDIR) $(root)$(cgidir)
++ $(RM) -rf $(root)$(cgidir).default
+ $(MKDIR) $(root)$(cgidir).default
$(MKDIR) $(root)$(includedir)
$(MKDIR) $(root)$(includedir)/xml
$(MKDIR) $(root)$(runtimedir)
-@@ -457,33 +458,41 @@
+@@ -457,33 +459,40 @@
# icons and distributed CGI scripts.
install-data:
@echo "===> [data: Installing initial data files]"
@@ -32,16 +26,16 @@
+# -@if [ -f $(root)$(htdocsdir)/index.html ] || [ -f $(root)$(htdocsdir)/index.html.en ]; then \
+# echo "[PRESERVING EXISTING DATA SUBDIR: $(root)$(htdocsdir)/]"; \
+# else \
-+ echo "Copying tree $(TOP)/htdocs/ -> $(root)$(doc_prefix)/"; \
++ echo "Copying tree $(TOP)/htdocs/ -> $(root)$(htdocsdir).default/"; \
(cd $(TOP)/htdocs/ && $(TAR) $(TAROPT) - index* apache_pb.* ) |\
- (cd $(root)$(htdocsdir)/ && $(TAR) -xf -); \
- find $(root)$(htdocsdir)/ -type d -exec chmod a+rx {} \; ; \
- find $(root)$(htdocsdir)/ -type f -print | xargs chmod a+r ; \
- fi
- -@if [ -d $(TOP)/htdocs/manual ]; then \
-+ (cd $(root)$(doc_prefix)/ && $(TAR) -xf -); \
-+ find $(root)$(doc_prefix)/ -type d -exec chmod a+rx {} \; ; \
-+ find $(root)$(doc_prefix)/ -type f -print | xargs chmod a+r ; \
++ (cd $(root)$(htdocsdir).default/ && $(TAR) -xf -); \
++ find $(root)$(htdocsdir).default/ -type d -exec chmod a+rx {} \; ; \
++ find $(root)$(htdocsdir).default/ -type f -print | xargs chmod a+r ; \
+# fi
+# -@if [ -d $(TOP)/htdocs/manual ]; then \
echo "Copying tree $(TOP)/htdocs/manual -> $(root)/$(manualdir)/"; \
@@ -49,16 +43,14 @@
(cd $(root)$(manualdir)/ && $(TAR) -xf -); \
find $(root)$(manualdir)/ -type d -exec chmod a+rx {} \; ; \
find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ; \
-- fi
++# fi
++ $(LN) -sf $(root)$(manualdir) $(root)$(htdocsdir).default/manual
++ if [ ! -d $(root)$(htdocsdir)/ ]; then \
++ $(LN) -sf $(root)$(htdocsdir).default $(root)$(htdocsdir); \
+ fi
- -@if [ -f $(root)$(cgidir)/printenv ]; then \
- echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
- else \
-+# fi
-+ if [ ! -d $(root)$(htdocsdir) ]; then \
-+ $(LN) -sf $(root)$(doc_prefix) $(root)$(htdocsdir); \
-+ fi
-+ $(RM) $(root)$(htdocsdir).default
-+ $(LN) -s $(root)$(doc_prefix) $(root)$(htdocsdir).default
+# -@if [ -f $(root)$(cgidir)/printenv ]; then \
+# echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
+# else \
@@ -73,13 +65,13 @@
done; \
- fi
+# fi
-+ if [ ! -d $(root)$(cgidir) ]; then \
++ if [ ! -d $(root)$(cgidir)/ ]; then \
+ $(LN) -sf $(root)$(cgidir).default $(root)$(cgidir); \
+ fi
@echo "Copying tree $(TOP)/icons/ -> $(root)$(iconsdir)/"; \
(cd $(TOP)/icons/ && $(TAR) $(TAROPT) - *) |\
(cd $(root)$(iconsdir)/ && $(TAR) -xf -); \
-@@ -522,10 +531,10 @@
+@@ -522,14 +531,14 @@
-e 's;logs/accept\.lock;$(runtimedir)/$(TARGET).lock;' \
-e 's;logs/apache_runtime_status;$(runtimedir)/$(TARGET).scoreboard;' \
-e 's;logs/httpd\.pid;$(runtimedir)/$(TARGET).pid;' \
@@ -94,3 +86,8 @@
-e 's;conf/magic;$(sysconfdir)/magic;' \
-e 's;conf/mime\.types;$(sysconfdir)/mime.types;' \
-e 's;User nobody;User $(conf_user);' \
+- -e 's;Group #-1;Group $(conf_group);' \
++ -e 's;Group "#-1";Group $(conf_group);' \
+ -e 's;Port 80;Port $(conf_port);' \
+ -e 's;ServerAdmin you@your.address;ServerAdmin $(conf_serveradmin);' \
+ -e 's;ServerName new.host.name;ServerName $(conf_servername);' \
diff --git a/www/apache13+ipv6/pkg-deinstall b/www/apache13+ipv6/pkg-deinstall
new file mode 100644
index 000000000000..e2f5775f5836
--- /dev/null
+++ b/www/apache13+ipv6/pkg-deinstall
@@ -0,0 +1,20 @@
+#!/bin/sh
+# $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-deinstall,v 1.1 2001-10-23 04:41:45 sumikawa Exp $
+#
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+USER=www
+
+if pw usershow "${USER}" 2>/dev/null 1>&2; then
+ if pw userdel ${USER}; then
+ echo "Delete user/group \"${USER}\"."
+ else
+ echo "Deleting user/group \"${USER}\" failed..."
+ exit 1
+ fi
+fi
+
+exit 0
diff --git a/www/apache13+ipv6/pkg-install b/www/apache13+ipv6/pkg-install
new file mode 100644
index 000000000000..fb0a4e5df326
--- /dev/null
+++ b/www/apache13+ipv6/pkg-install
@@ -0,0 +1,34 @@
+#!/bin/sh
+# $FreeBSD: /tmp/pcvs/ports/www/apache13+ipv6/Attic/pkg-install,v 1.1 2001-10-23 04:41:45 sumikawa Exp $
+#
+
+if [ "$2" != "PRE-INSTALL" ]; then
+ exit 0
+fi
+
+USER=www
+GROUP=${USER}
+UID=80
+GID=${UID}
+
+if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
+ if pw groupadd ${GROUP} -g ${GID}; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Adding group \"${GROUP}\" failed..."
+ exit 1
+ fi
+fi
+
+if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
+ if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
+ -s "/sbin/nologin" -d "/nonexistent" \
+ -c "World Wide Web Owner"; \
+ then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Adding user \"${USER}\" failed..."
+ exit 1
+ fi
+fi
+exit 0
diff --git a/www/apache13+ipv6/pkg-plist b/www/apache13+ipv6/pkg-plist
index 37bccd6584a2..b059e9f0fc87 100644
--- a/www/apache13+ipv6/pkg-plist
+++ b/www/apache13+ipv6/pkg-plist
@@ -103,275 +103,272 @@ sbin/apxs
sbin/httpd
sbin/logresolve
sbin/rotatelogs
-@exec mkdir -p %D/www
-@exec ln -fs %B %D/www/data.default
-@unexec rm -f %D/www/data.default
-@exec [ -d %D/www/data ] || ln -fs %B %D/www/data
-@exec [ -d %D/www/cgi-bin ] || ln -fs %D/www/cgi-bin.default %D/www/cgi-bin
-share/doc/apache/apache_pb.gif
-share/doc/apache/index.html.ca
-share/doc/apache/index.html.cz
-share/doc/apache/index.html.de
-share/doc/apache/index.html.dk
-share/doc/apache/index.html.ee
-share/doc/apache/index.html.el
+www/data.default/apache_pb.gif
+@exec [ -d %D/www/data/ ] || ln -fs %B %D/www/data
+www/data.default/index.html.ca
+www/data.default/index.html.cz
+www/data.default/index.html.de
+www/data.default/index.html.dk
+www/data.default/index.html.ee
+www/data.default/index.html.el
+www/data.default/index.html.en
+www/data.default/index.html.es
+www/data.default/index.html.fr
+www/data.default/index.html.he.iso8859-8
+www/data.default/index.html.it
+www/data.default/index.html.ja.jis
+www/data.default/index.html.kr.iso-kr
+www/data.default/index.html.lu
+www/data.default/index.html.nl
+www/data.default/index.html.nn
+www/data.default/index.html.no
+www/data.default/index.html.po.iso-pl
+www/data.default/index.html.pt
+www/data.default/index.html.pt-br
+www/data.default/index.html.ru.cp-1251
+www/data.default/index.html.ru.cp866
+www/data.default/index.html.ru.iso-ru
+www/data.default/index.html.ru.koi8-r
+www/data.default/index.html.ru.ucs2
+www/data.default/index.html.ru.ucs4
+www/data.default/index.html.ru.utf8
+www/data.default/index.html.se
+www/data.default/index.html.zh.Big5
+share/doc/apache/LICENSE
+share/doc/apache/bind.html.en
+share/doc/apache/bind.html.fr
+share/doc/apache/bind.html.html
+share/doc/apache/cgi_path.html.en
+share/doc/apache/cgi_path.html.fr
+share/doc/apache/cgi_path.html.html
+share/doc/apache/configuring.html.en
+share/doc/apache/configuring.html.fr
+share/doc/apache/configuring.html.html
+share/doc/apache/configuring.html.ja.jis
+share/doc/apache/content-negotiation.html
+share/doc/apache/custom-error.html.en
+share/doc/apache/custom-error.html.fr
+share/doc/apache/custom-error.html.html
+share/doc/apache/custom-error.html.ja.jis
+share/doc/apache/cygwin.html
+share/doc/apache/dns-caveats.html.en
+share/doc/apache/dns-caveats.html.fr
+share/doc/apache/dns-caveats.html.html
+share/doc/apache/dso.html
+share/doc/apache/ebcdic.html
+share/doc/apache/env.html.en
+share/doc/apache/env.html.html
+share/doc/apache/env.html.ja.jis
+share/doc/apache/footer.html
+share/doc/apache/handler.html.en
+share/doc/apache/handler.html.html
+share/doc/apache/handler.html.ja.jis
+share/doc/apache/header.html
+share/doc/apache/howto/cgi.html.en
+share/doc/apache/howto/cgi.html.html
+share/doc/apache/howto/cgi.html.ja.jis
+share/doc/apache/howto/footer.html
+share/doc/apache/howto/header.html
+share/doc/apache/howto/ssi.html.en
+share/doc/apache/howto/ssi.html.html
+share/doc/apache/howto/ssi.html.ja.jis
+share/doc/apache/images/apache_header.gif
+share/doc/apache/images/custom_errordocs.gif
+share/doc/apache/images/home.gif
+share/doc/apache/images/index.gif
+share/doc/apache/images/mod_rewrite_fig1.fig
+share/doc/apache/images/mod_rewrite_fig1.gif
+share/doc/apache/images/mod_rewrite_fig2.fig
+share/doc/apache/images/mod_rewrite_fig2.gif
+share/doc/apache/images/pixel.gif
+share/doc/apache/images/sub.gif
share/doc/apache/index.html.en
-share/doc/apache/index.html.es
share/doc/apache/index.html.fr
-share/doc/apache/index.html.he.iso8859-8
-share/doc/apache/index.html.it
+share/doc/apache/index.html.html
share/doc/apache/index.html.ja.jis
-share/doc/apache/index.html.kr.iso-kr
-share/doc/apache/index.html.lu
-share/doc/apache/index.html.nl
-share/doc/apache/index.html.nn
-share/doc/apache/index.html.no
-share/doc/apache/index.html.po.iso-pl
-share/doc/apache/index.html.pt
-share/doc/apache/index.html.pt-br
-share/doc/apache/index.html.ru.cp-1251
-share/doc/apache/index.html.ru.cp866
-share/doc/apache/index.html.ru.iso-ru
-share/doc/apache/index.html.ru.koi8-r
-share/doc/apache/index.html.ru.ucs2
-share/doc/apache/index.html.ru.ucs4
-share/doc/apache/index.html.ru.utf8
-share/doc/apache/index.html.se
-share/doc/apache/index.html.zh.Big5
-share/doc/apache/manual/LICENSE
-share/doc/apache/manual/bind.html.en
-share/doc/apache/manual/bind.html.fr
-share/doc/apache/manual/bind.html.html
-share/doc/apache/manual/cgi_path.html.en
-share/doc/apache/manual/cgi_path.html.fr
-share/doc/apache/manual/cgi_path.html.html
-share/doc/apache/manual/configuring.html.en
-share/doc/apache/manual/configuring.html.fr
-share/doc/apache/manual/configuring.html.html
-share/doc/apache/manual/configuring.html.ja.jis
-share/doc/apache/manual/content-negotiation.html
-share/doc/apache/manual/custom-error.html.en
-share/doc/apache/manual/custom-error.html.fr
-share/doc/apache/manual/custom-error.html.html
-share/doc/apache/manual/custom-error.html.ja.jis
-share/doc/apache/manual/cygwin.html
-share/doc/apache/manual/dns-caveats.html.en
-share/doc/apache/manual/dns-caveats.html.fr
-share/doc/apache/manual/dns-caveats.html.html
-share/doc/apache/manual/dso.html
-share/doc/apache/manual/ebcdic.html
-share/doc/apache/manual/env.html.en
-share/doc/apache/manual/env.html.html
-share/doc/apache/manual/env.html.ja.jis
-share/doc/apache/manual/footer.html
-share/doc/apache/manual/handler.html.en
-share/doc/apache/manual/handler.html.html
-share/doc/apache/manual/handler.html.ja.jis
-share/doc/apache/manual/header.html
-share/doc/apache/manual/howto/cgi.html.en
-share/doc/apache/manual/howto/cgi.html.html
-share/doc/apache/manual/howto/cgi.html.ja.jis
-share/doc/apache/manual/howto/footer.html
-share/doc/apache/manual/howto/header.html
-share/doc/apache/manual/howto/ssi.html.en
-share/doc/apache/manual/howto/ssi.html.html
-share/doc/apache/manual/howto/ssi.html.ja.jis
-share/doc/apache/manual/images/apache_header.gif
-share/doc/apache/manual/images/custom_errordocs.gif
-share/doc/apache/manual/images/home.gif
-share/doc/apache/manual/images/index.gif
-share/doc/apache/manual/images/mod_rewrite_fig1.fig
-share/doc/apache/manual/images/mod_rewrite_fig1.gif
-share/doc/apache/manual/images/mod_rewrite_fig2.fig
-share/doc/apache/manual/images/mod_rewrite_fig2.gif
-share/doc/apache/manual/images/pixel.gif
-share/doc/apache/manual/images/sub.gif
-share/doc/apache/manual/index.html.en
-share/doc/apache/manual/index.html.fr
-share/doc/apache/manual/index.html.html
-share/doc/apache/manual/index.html.ja.jis
-share/doc/apache/manual/install-tpf.html
-share/doc/apache/manual/install.html.en
-share/doc/apache/manual/install.html.es
-share/doc/apache/manual/install.html.fr
-share/doc/apache/manual/install.html.html
-share/doc/apache/manual/install.html.ja.jis
-share/doc/apache/manual/invoking.html.en
-share/doc/apache/manual/invoking.html.fr
-share/doc/apache/manual/invoking.html.html
-share/doc/apache/manual/keepalive.html.en
-share/doc/apache/manual/keepalive.html.html
-share/doc/apache/manual/keepalive.html.ja.jis
-share/doc/apache/manual/location.html
-share/doc/apache/manual/logs.html
-share/doc/apache/manual/man-template.html
-share/doc/apache/manual/misc/API.html
-share/doc/apache/manual/misc/FAQ.html
-share/doc/apache/manual/misc/HTTP_Features.tsv
-share/doc/apache/manual/misc/client_block_api.html
-share/doc/apache/manual/misc/compat_notes.html
-share/doc/apache/manual/misc/custom_errordocs.html
-share/doc/apache/manual/misc/descriptors.html
-share/doc/apache/manual/misc/fin_wait_2.html
-share/doc/apache/manual/misc/footer.html
-share/doc/apache/manual/misc/header.html
-share/doc/apache/manual/misc/howto.html
-share/doc/apache/manual/misc/index.html
-share/doc/apache/manual/misc/known_client_problems.html
-share/doc/apache/manual/misc/nopgp.html
-share/doc/apache/manual/misc/perf-bsd44.html
-share/doc/apache/manual/misc/perf-dec.html
-share/doc/apache/manual/misc/perf-hp.html
-share/doc/apache/manual/misc/perf-tuning.html
-share/doc/apache/manual/misc/perf.html
-share/doc/apache/manual/misc/rewriteguide.html
-share/doc/apache/manual/misc/security_tips.html
-share/doc/apache/manual/misc/tutorials.html
-share/doc/apache/manual/misc/vif-info.html
-share/doc/apache/manual/misc/windoz_keepalive.html
-share/doc/apache/manual/mod/core.html.en
-share/doc/apache/manual/mod/core.html.fr
-share/doc/apache/manual/mod/core.html.html
-share/doc/apache/manual/mod/directive-dict.html.en
-share/doc/apache/manual/mod/directive-dict.html.fr
-share/doc/apache/manual/mod/directive-dict.html.html
-share/doc/apache/manual/mod/directive-dict.html.ja.jis
-share/doc/apache/manual/mod/directives.html.de
-share/doc/apache/manual/mod/directives.html.en
-share/doc/apache/manual/mod/directives.html.fr
-share/doc/apache/manual/mod/directives.html.html
-share/doc/apache/manual/mod/directives.html.ja.jis
-share/doc/apache/manual/mod/footer.html
-share/doc/apache/manual/mod/header.html
-share/doc/apache/manual/mod/index-bytype.html.en
-share/doc/apache/manual/mod/index-bytype.html.fr
-share/doc/apache/manual/mod/index-bytype.html.html
-share/doc/apache/manual/mod/index.html.en
-share/doc/apache/manual/mod/index.html.fr
-share/doc/apache/manual/mod/index.html.html
-share/doc/apache/manual/mod/index.html.ja.jis
-share/doc/apache/manual/mod/mod_access.html
-share/doc/apache/manual/mod/mod_actions.html
-share/doc/apache/manual/mod/mod_alias.html
-share/doc/apache/manual/mod/mod_asis.html
-share/doc/apache/manual/mod/mod_auth.html
-share/doc/apache/manual/mod/mod_auth_anon.html
-share/doc/apache/manual/mod/mod_auth_db.html
-share/doc/apache/manual/mod/mod_auth_dbm.html
-share/doc/apache/manual/mod/mod_auth_digest.html
-share/doc/apache/manual/mod/mod_autoindex.html
-share/doc/apache/manual/mod/mod_browser.html
-share/doc/apache/manual/mod/mod_cern_meta.html
-share/doc/apache/manual/mod/mod_cgi.html
-share/doc/apache/manual/mod/mod_cookies.html
-share/doc/apache/manual/mod/mod_digest.html
-share/doc/apache/manual/mod/mod_dir.html
-share/doc/apache/manual/mod/mod_dld.html
-share/doc/apache/manual/mod/mod_env.html.en
-share/doc/apache/manual/mod/mod_env.html.html
-share/doc/apache/manual/mod/mod_env.html.ja.jis
-share/doc/apache/manual/mod/mod_example.html
-share/doc/apache/manual/mod/mod_expires.html
-share/doc/apache/manual/mod/mod_headers.html
-share/doc/apache/manual/mod/mod_imap.html
-share/doc/apache/manual/mod/mod_include.html
-share/doc/apache/manual/mod/mod_info.html
-share/doc/apache/manual/mod/mod_isapi.html
-share/doc/apache/manual/mod/mod_log_agent.html
-share/doc/apache/manual/mod/mod_log_common.html
-share/doc/apache/manual/mod/mod_log_config.html
-share/doc/apache/manual/mod/mod_log_referer.html
-share/doc/apache/manual/mod/mod_mime.html.en
-share/doc/apache/manual/mod/mod_mime.html.html
-share/doc/apache/manual/mod/mod_mime.html.ja.jis
-share/doc/apache/manual/mod/mod_mime_magic.html
-share/doc/apache/manual/mod/mod_mmap_static.html
-share/doc/apache/manual/mod/mod_negotiation.html.en
-share/doc/apache/manual/mod/mod_negotiation.html.html
-share/doc/apache/manual/mod/mod_negotiation.html.ja.jis
-share/doc/apache/manual/mod/mod_proxy.html
-share/doc/apache/manual/mod/mod_rewrite.html
-share/doc/apache/manual/mod/mod_setenvif.html.en
-share/doc/apache/manual/mod/mod_setenvif.html.html
-share/doc/apache/manual/mod/mod_setenvif.html.ja.jis
-share/doc/apache/manual/mod/mod_so.html
-share/doc/apache/manual/mod/mod_speling.html
-share/doc/apache/manual/mod/mod_status.html
-share/doc/apache/manual/mod/mod_unique_id.html
-share/doc/apache/manual/mod/mod_userdir.html
-share/doc/apache/manual/mod/mod_usertrack.html
-share/doc/apache/manual/mod/mod_vhost_alias.html
-share/doc/apache/manual/mod/module-dict.html.en
-share/doc/apache/manual/mod/module-dict.html.html
-share/doc/apache/manual/mod/module-dict.html.ja.jis
-share/doc/apache/manual/mpeix.html
-share/doc/apache/manual/multilogs.html
-share/doc/apache/manual/netware.html
-share/doc/apache/manual/new_features_1_0.html
-share/doc/apache/manual/new_features_1_1.html
-share/doc/apache/manual/new_features_1_2.html
-share/doc/apache/manual/new_features_1_3.html.en
-share/doc/apache/manual/new_features_1_3.html.html
-share/doc/apache/manual/new_features_1_3.html.ja.jis
-share/doc/apache/manual/new_features_2_0.html
-share/doc/apache/manual/process-model.html
-share/doc/apache/manual/programs/ab.html
-share/doc/apache/manual/programs/apachectl.html
-share/doc/apache/manual/programs/apxs.html
-share/doc/apache/manual/programs/dbmmanage.html
-share/doc/apache/manual/programs/footer.html
-share/doc/apache/manual/programs/header.html
-share/doc/apache/manual/programs/htdigest.html
-share/doc/apache/manual/programs/htpasswd.html
-share/doc/apache/manual/programs/httpd.html
-share/doc/apache/manual/programs/index.html.en
-share/doc/apache/manual/programs/index.html.html
-share/doc/apache/manual/programs/index.html.ja.jis
-share/doc/apache/manual/programs/logresolve.html
-share/doc/apache/manual/programs/other.html
-share/doc/apache/manual/programs/rotatelogs.html
-share/doc/apache/manual/programs/suexec.html
-share/doc/apache/manual/readme-tpf.html
-share/doc/apache/manual/search/manual-index.cgi
-share/doc/apache/manual/sections.html
-share/doc/apache/manual/server-wide.html.en
-share/doc/apache/manual/server-wide.html.fr
-share/doc/apache/manual/server-wide.html.html
-share/doc/apache/manual/server-wide.html.ja.jis
-share/doc/apache/manual/sourcereorg.html
-share/doc/apache/manual/stopping.html.en
-share/doc/apache/manual/stopping.html.fr
-share/doc/apache/manual/stopping.html.html
-share/doc/apache/manual/suexec.html.en
-share/doc/apache/manual/suexec.html.html
-share/doc/apache/manual/suexec.html.ja.jis
-share/doc/apache/manual/suexec_1_2.html
-share/doc/apache/manual/unixware.html
-share/doc/apache/manual/upgrading_to_1_3.html
-share/doc/apache/manual/urlmapping.html
-share/doc/apache/manual/vhosts/details.html
-share/doc/apache/manual/vhosts/details_1_2.html
-share/doc/apache/manual/vhosts/examples.html
-share/doc/apache/manual/vhosts/fd-limits.html
-share/doc/apache/manual/vhosts/footer.html
-share/doc/apache/manual/vhosts/header.html
-share/doc/apache/manual/vhosts/host.html
-share/doc/apache/manual/vhosts/index.html.en
-share/doc/apache/manual/vhosts/index.html.html
-share/doc/apache/manual/vhosts/index.html.ja.jis
-share/doc/apache/manual/vhosts/ip-based.html
-share/doc/apache/manual/vhosts/mass.html
-share/doc/apache/manual/vhosts/name-based.html.en
-share/doc/apache/manual/vhosts/name-based.html.html
-share/doc/apache/manual/vhosts/name-based.html.ja.jis
-share/doc/apache/manual/vhosts/vhosts-in-depth.html
-share/doc/apache/manual/vhosts/virtual-host.html
-share/doc/apache/manual/win_compiling.html
-share/doc/apache/manual/win_service.html.en
-share/doc/apache/manual/win_service.html.html
-share/doc/apache/manual/win_service.html.ja.jis
-share/doc/apache/manual/windows.html
+share/doc/apache/install-tpf.html
+share/doc/apache/install.html.en
+share/doc/apache/install.html.es
+share/doc/apache/install.html.fr
+share/doc/apache/install.html.html
+share/doc/apache/install.html.ja.jis
+share/doc/apache/invoking.html.en
+share/doc/apache/invoking.html.fr
+share/doc/apache/invoking.html.html
+share/doc/apache/keepalive.html.en
+share/doc/apache/keepalive.html.html
+share/doc/apache/keepalive.html.ja.jis
+share/doc/apache/location.html
+share/doc/apache/logs.html
+share/doc/apache/man-template.html
+share/doc/apache/misc/API.html
+share/doc/apache/misc/FAQ.html
+share/doc/apache/misc/HTTP_Features.tsv
+share/doc/apache/misc/client_block_api.html
+share/doc/apache/misc/compat_notes.html
+share/doc/apache/misc/custom_errordocs.html
+share/doc/apache/misc/descriptors.html
+share/doc/apache/misc/fin_wait_2.html
+share/doc/apache/misc/footer.html
+share/doc/apache/misc/header.html
+share/doc/apache/misc/howto.html
+share/doc/apache/misc/index.html
+share/doc/apache/misc/known_client_problems.html
+share/doc/apache/misc/nopgp.html
+share/doc/apache/misc/perf-bsd44.html
+share/doc/apache/misc/perf-dec.html
+share/doc/apache/misc/perf-hp.html
+share/doc/apache/misc/perf-tuning.html
+share/doc/apache/misc/perf.html
+share/doc/apache/misc/rewriteguide.html
+share/doc/apache/misc/security_tips.html
+share/doc/apache/misc/tutorials.html
+share/doc/apache/misc/vif-info.html
+share/doc/apache/misc/windoz_keepalive.html
+share/doc/apache/mod/core.html.en
+share/doc/apache/mod/core.html.fr
+share/doc/apache/mod/core.html.html
+share/doc/apache/mod/directive-dict.html.en
+share/doc/apache/mod/directive-dict.html.fr
+share/doc/apache/mod/directive-dict.html.html
+share/doc/apache/mod/directive-dict.html.ja.jis
+share/doc/apache/mod/directives.html.de
+share/doc/apache/mod/directives.html.en
+share/doc/apache/mod/directives.html.fr
+share/doc/apache/mod/directives.html.html
+share/doc/apache/mod/directives.html.ja.jis
+share/doc/apache/mod/footer.html
+share/doc/apache/mod/header.html
+share/doc/apache/mod/index-bytype.html.en
+share/doc/apache/mod/index-bytype.html.fr
+share/doc/apache/mod/index-bytype.html.html
+share/doc/apache/mod/index.html.en
+share/doc/apache/mod/index.html.fr
+share/doc/apache/mod/index.html.html
+share/doc/apache/mod/index.html.ja.jis
+share/doc/apache/mod/mod_access.html
+share/doc/apache/mod/mod_actions.html
+share/doc/apache/mod/mod_alias.html
+share/doc/apache/mod/mod_asis.html
+share/doc/apache/mod/mod_auth.html
+share/doc/apache/mod/mod_auth_anon.html
+share/doc/apache/mod/mod_auth_db.html
+share/doc/apache/mod/mod_auth_dbm.html
+share/doc/apache/mod/mod_auth_digest.html
+share/doc/apache/mod/mod_autoindex.html
+share/doc/apache/mod/mod_browser.html
+share/doc/apache/mod/mod_cern_meta.html
+share/doc/apache/mod/mod_cgi.html
+share/doc/apache/mod/mod_cookies.html
+share/doc/apache/mod/mod_digest.html
+share/doc/apache/mod/mod_dir.html
+share/doc/apache/mod/mod_dld.html
+share/doc/apache/mod/mod_env.html.en
+share/doc/apache/mod/mod_env.html.html
+share/doc/apache/mod/mod_env.html.ja.jis
+share/doc/apache/mod/mod_example.html
+share/doc/apache/mod/mod_expires.html
+share/doc/apache/mod/mod_headers.html
+share/doc/apache/mod/mod_imap.html
+share/doc/apache/mod/mod_include.html
+share/doc/apache/mod/mod_info.html
+share/doc/apache/mod/mod_isapi.html
+share/doc/apache/mod/mod_log_agent.html
+share/doc/apache/mod/mod_log_common.html
+share/doc/apache/mod/mod_log_config.html
+share/doc/apache/mod/mod_log_referer.html
+share/doc/apache/mod/mod_mime.html.en
+share/doc/apache/mod/mod_mime.html.html
+share/doc/apache/mod/mod_mime.html.ja.jis
+share/doc/apache/mod/mod_mime_magic.html
+share/doc/apache/mod/mod_mmap_static.html
+share/doc/apache/mod/mod_negotiation.html.en
+share/doc/apache/mod/mod_negotiation.html.html
+share/doc/apache/mod/mod_negotiation.html.ja.jis
+share/doc/apache/mod/mod_proxy.html
+share/doc/apache/mod/mod_rewrite.html
+share/doc/apache/mod/mod_setenvif.html.en
+share/doc/apache/mod/mod_setenvif.html.html
+share/doc/apache/mod/mod_setenvif.html.ja.jis
+share/doc/apache/mod/mod_so.html
+share/doc/apache/mod/mod_speling.html
+share/doc/apache/mod/mod_status.html
+share/doc/apache/mod/mod_unique_id.html
+share/doc/apache/mod/mod_userdir.html
+share/doc/apache/mod/mod_usertrack.html
+share/doc/apache/mod/mod_vhost_alias.html
+share/doc/apache/mod/module-dict.html.en
+share/doc/apache/mod/module-dict.html.html
+share/doc/apache/mod/module-dict.html.ja.jis
+share/doc/apache/mpeix.html
+share/doc/apache/multilogs.html
+share/doc/apache/netware.html
+share/doc/apache/new_features_1_0.html
+share/doc/apache/new_features_1_1.html
+share/doc/apache/new_features_1_2.html
+share/doc/apache/new_features_1_3.html.en
+share/doc/apache/new_features_1_3.html.html
+share/doc/apache/new_features_1_3.html.ja.jis
+share/doc/apache/new_features_2_0.html
+share/doc/apache/process-model.html
+share/doc/apache/programs/ab.html
+share/doc/apache/programs/apachectl.html
+share/doc/apache/programs/apxs.html
+share/doc/apache/programs/dbmmanage.html
+share/doc/apache/programs/footer.html
+share/doc/apache/programs/header.html
+share/doc/apache/programs/htdigest.html
+share/doc/apache/programs/htpasswd.html
+share/doc/apache/programs/httpd.html
+share/doc/apache/programs/index.html.en
+share/doc/apache/programs/index.html.html
+share/doc/apache/programs/index.html.ja.jis
+share/doc/apache/programs/logresolve.html
+share/doc/apache/programs/other.html
+share/doc/apache/programs/rotatelogs.html
+share/doc/apache/programs/suexec.html
+share/doc/apache/readme-tpf.html
+share/doc/apache/search/manual-index.cgi
+share/doc/apache/sections.html
+share/doc/apache/server-wide.html.en
+share/doc/apache/server-wide.html.fr
+share/doc/apache/server-wide.html.html
+share/doc/apache/server-wide.html.ja.jis
+share/doc/apache/sourcereorg.html
+share/doc/apache/stopping.html.en
+share/doc/apache/stopping.html.fr
+share/doc/apache/stopping.html.html
+share/doc/apache/suexec.html.en
+share/doc/apache/suexec.html.html
+share/doc/apache/suexec.html.ja.jis
+share/doc/apache/suexec_1_2.html
+share/doc/apache/unixware.html
+share/doc/apache/upgrading_to_1_3.html
+share/doc/apache/urlmapping.html
+share/doc/apache/vhosts/details.html
+share/doc/apache/vhosts/details_1_2.html
+share/doc/apache/vhosts/examples.html
+share/doc/apache/vhosts/fd-limits.html
+share/doc/apache/vhosts/footer.html
+share/doc/apache/vhosts/header.html
+share/doc/apache/vhosts/host.html
+share/doc/apache/vhosts/index.html.en
+share/doc/apache/vhosts/index.html.html
+share/doc/apache/vhosts/index.html.ja.jis
+share/doc/apache/vhosts/ip-based.html
+share/doc/apache/vhosts/mass.html
+share/doc/apache/vhosts/name-based.html.en
+share/doc/apache/vhosts/name-based.html.html
+share/doc/apache/vhosts/name-based.html.ja.jis
+share/doc/apache/vhosts/vhosts-in-depth.html
+share/doc/apache/vhosts/virtual-host.html
+share/doc/apache/win_compiling.html
+share/doc/apache/win_service.html.en
+share/doc/apache/win_service.html.html
+share/doc/apache/win_service.html.ja.jis
+share/doc/apache/windows.html
www/cgi-bin.default/printenv
+@exec [ -d %D/www/cgi-bin/ ] || ln -fs %B %D/www/cgi-bin
www/cgi-bin.default/test-cgi
www/icons/README
www/icons/a.gif
@@ -596,15 +593,15 @@ www/icons/world2.png
@dirrm include/apache/xml
@dirrm include/apache
@dirrm libexec/apache
-@dirrm share/doc/apache/manual/howto
-@dirrm share/doc/apache/manual/images
-@dirrm share/doc/apache/manual/misc
-@dirrm share/doc/apache/manual/mod
-@dirrm share/doc/apache/manual/programs
-@dirrm share/doc/apache/manual/search
-@dirrm share/doc/apache/manual/vhosts
-@dirrm share/doc/apache/manual
+@dirrm share/doc/apache/howto
+@dirrm share/doc/apache/images
+@dirrm share/doc/apache/misc
+@dirrm share/doc/apache/mod
+@dirrm share/doc/apache/programs
+@dirrm share/doc/apache/search
+@dirrm share/doc/apache/vhosts
@dirrm share/doc/apache
+@dirrm www/data.default
@dirrm www/cgi-bin.default
@dirrm www/icons/small
@dirrm www/icons