aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache13-fp/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-11-10 09:56:01 +0800
committersteve <steve@FreeBSD.org>1998-11-10 09:56:01 +0800
commitfb78164b4829217db239aad57723d77e28bb751a (patch)
tree46b1879e6b74d2218a6f87fe5e671941722a85c9 /www/apache13-fp/Makefile
parent53fb01f0c0a9fba2fcd65d675420e626dfc081e2 (diff)
downloadfreebsd-ports-gnome-fb78164b4829217db239aad57723d77e28bb751a.tar.gz
freebsd-ports-gnome-fb78164b4829217db239aad57723d77e28bb751a.tar.zst
freebsd-ports-gnome-fb78164b4829217db239aad57723d77e28bb751a.zip
Fixup port to provide Apache version 1.3.3 with FrontPage extensions.
PR: 8522 Submitted by: maintainer
Diffstat (limited to 'www/apache13-fp/Makefile')
-rw-r--r--www/apache13-fp/Makefile124
1 files changed, 81 insertions, 43 deletions
diff --git a/www/apache13-fp/Makefile b/www/apache13-fp/Makefile
index dbaac7d3b08a..23060f7c53e8 100644
--- a/www/apache13-fp/Makefile
+++ b/www/apache13-fp/Makefile
@@ -1,32 +1,38 @@
-# New ports collection makefile for: apache HTTPD w/FrontPage
-# Version required: 1.2.6 3.0.4 (3.0.2.1330)
-# Date created: Fri Oct 17 13:36:00 CDT 1997
+# New ports collection makefile for: apache HTTPD w/FrontPage Module
+# Version required: 1.3* 3.0.4 (3.0.2.1330)
+# Date created: Sat Oct 31 16:30:00 CDT 1997
# Whom: hetzels@westbend.net
#
-# $Id: Makefile,v 1.1.1.1 1998/05/29 04:46:49 mph Exp $
+# $Id$
#
-BROKEN= awaiting upgrade after repository copy
-
-DISTNAME= apache_1.2.6
-PKGNAME= apache_fp-1.2.6
+DISTNAME= apache_1.3.3
+PKGNAME= apache_fp-1.3.3
CATEGORIES= www
MASTER_SITES= ftp://www.apache.org/apache/dist/ \
- ftp://ftp.microsoft.com/products/frontpage/\
+ ftp://ftp.microsoft.com/products/frontpage/
-MAINTAINER= hetzels@westbend.net
+PATCH_SITES= ftp://www.apache.org/apache/dist/patches/apply_to_1.3.3/ \
+ http://www.apache.org/dist/patches/apply_to_1.3.3/
-APACHE= ${DISTNAME}${EXTRACT_SUFX}
-FRONTPAGE= fp30.bsdi3
+PATCHFILES= core_404_log_bug.txt proxy_segv.txt
-DISTFILES= ${APACHE} ${FRONTPAGE}.tar.Z
+# This file will not apply, fails on hunk 2 for main/http_protocol.c
+#PATCHFILES+= server_error_filename.txt
.if defined(PATCH_DEBUG)
-PATCH_DIST_ARGS= -d ${WRKSRC}/src -E ${PATCH_DIST_STRIP}
+PATCH_DIST_ARGS= -d ${WRKSRC}/src -E ${PATCH_DIST_STRIP}
.else
-PATCH_DIST_ARGS= -d ${WRKSRC}/src --forward --quiet -E ${PATCH_DIST_STRIP}
+PATCH_DIST_ARGS= -d ${WRKSRC}/src --forward --quiet -E ${PATCH_DIST_STRIP}
.endif
+MAINTAINER= hetzels@westbend.net
+
+APACHE= ${DISTNAME}${EXTRACT_SUFX}
+FRONTPAGE= fp30.bsdi3.tar.Z
+
+DISTFILES= ${APACHE} ${FRONTPAGE}
+
EXTRACT_ONLY= ${APACHE}
IS_INTERACTIVE= YES
@@ -35,53 +41,85 @@ NO_PACKAGE= \
FPINSTALL= frontpage/version3.0/fp_install.sh
CHANGESERVER= frontpage/version3.0/change_server.sh
-FPPATCH= frontpage/version3.0/apache-fp/fp-patch-apache_1.2.5
+MOD_FP= ${FILESDIR}/mod_frontpage.c
INSTALL_FILE=${INSTALL} -c -m 555 -o bin -g bin
-MAN1= htpasswd.1
-MAN8= httpd.8
-DOCDIR= ${PREFIX}/share/doc/apache
+#
+# Set APACHE_PERF_TUNING env. variable to YES to get maximum performance
+#
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= \
+ --sysconfdir=${PREFIX}/etc/apache \
+ --includedir=${PREFIX}/include/apache \
+ --logfiledir=/var/log \
+ --runtimedir=/var/run \
+ --datadir=${PREFIX}/www \
+ --proxycachedir=${PREFIX}/www/proxy \
+ --libexecdir=${PREFIX}/libexec/apache \
+ --without-confadjust \
+ --enable-shared=remain \
+ --enable-module=most \
+ --enable-module=auth_db \
+ --disable-module=auth_dbm \
+ --add-module=${MOD_FP} \
+ --enable-shared=frontpage
+
+# Currently perl version doesn't matter
+# --with-perl=${PERL5}
+
+OPTIM=-DHARD_SERVER_LIMIT=512 \
+-DDOCUMENT_LOCATION=\\"${PREFIX}/www/data/\\" \
+-DDEFAULT_PATH=\\"/bin:/usr/bin:${PREFIX}/bin\\"
+
+.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
+OPTIM+= -DBUFFERED_LOGS
+CFLAGS+= -O6 -fomit-frame-pointer
+.endif
+
+CONFIGURE_ENV= OPTIM='${OPTIM}'
+
+MAN1= ab.1 apachectl.1 dbmmanage.1 htdigest.1 htpasswd.1
+MAN8= apxs.8 httpd.8 logresolve.8 rotatelogs.8
+
+.if defined(SUEXEC)
+HTTPD_USER?=www
+USER_DIR?=public_html
+CONFIGURE_ARGS+= --enable-suexec \
+ --suexec-caller=${HTTPD_USER} \
+ --suexec-userdir=${USER_DIR}
+MAN8+= suexec.8
+.endif
pre-fetch:
- @if [ ! -f /usr/lib/libdescrypt.a -a ! -f /usr/lib/libdescrypt.so.* ] ; then \
+ @if ! ${LDCONFIG} -r | ${GREP} -q -e "-ldescrypt"; then \
${ECHO} ; \
- ${ECHO} "WARNING: MS Frontpage Extentions require the DES Library"; \
+ ${ECHO} "WARNING: MS FrontPage Extentions require the DES Library"; \
${ECHO} "WARNING: Install the DES Library, then build apache-fp"; \
${ECHO} ; \
${FALSE} ; \
fi
post-extract:
- @${ECHO} "===> Extracting FrontPage patch, and install scripts"
+ @${ECHO} "===> Extracting FrontPage install scripts"
@cd ${WRKSRC} && \
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE}.tar.Z ${FPINSTALL} ${FPPATCH} ${CHANGESERVER}
-
-pre-patch:
- @${ECHO} "===> Applying FrontPage patch"
- @cd ${WRKSRC} && ${PATCH} ${PATCH_DIST_ARGS} < ${WRKSRC}/${FPPATCH}
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${DISTDIR}/${FRONTPAGE} ${FPINSTALL} ${CHANGESERVER}
post-install:
+ @${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh.tmpl file."
+ @${CAT} ${FILESDIR}/apache.sh.tmpl | \
+ ${SED} -e 's;PREFIX;${PREFIX};' -e 's;PERL5;${PERL};' \
+ > ${PREFIX}/etc/rc.d/apache.sh.tmpl
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
- ${ECHO} "#!${SH}" > ${PREFIX}/etc/rc.d/apache.sh; \
- ${ECHO} "[ -x ${PREFIX}/sbin/httpd ] && ${PREFIX}/sbin/httpd && ${ECHO} -n ' httpd'" >> ${PREFIX}/etc/rc.d/apache.sh; \
+ ${CP} ${PREFIX}/etc/rc.d/apache.sh.tmpl ${PREFIX}/etc/rc.d/apache.sh; \
chmod 751 ${PREFIX}/etc/rc.d/apache.sh; \
+ else \
+ ${ECHO} "apache.sh exists, please compare with apache.sh.tmpl."; \
+ ${ECHO} "The template will regenerate the FrontPage suidkey"; \
+ ${ECHO} "file when the apache server is started/restarted."; \
fi
-.for i in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/support/$i ${PREFIX}/man/man1
-.endfor
-.for i in ${MAN8}
- ${INSTALL_MAN} ${WRKSRC}/support/$i ${PREFIX}/man/man8
-.endfor
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCDIR}
-.for i in README LICENSE ABOUT_APACHE
- ${INSTALL_DATA} ${WRKSRC}/$i ${DOCDIR}
-.endfor
- @cd ${WRKSRC}/htdocs; ${EXTRACT_CMD} cf - . | (cd ${DOCDIR} ; \
- ${EXTRACT_CMD} xf -)
-.endif
@${SH} ${WRKSRC}/${FPINSTALL}
@${INSTALL_FILE} ${WRKSRC}/${FPINSTALL} ${PREFIX}/${FPINSTALL}
@${INSTALL_FILE} ${WRKSRC}/${CHANGESERVER} ${PREFIX}/${CHANGESERVER}
ports-graphics/commit/math?id=5fcbc182ecfbc5acae214c3ebd4e9eab7a1b79c0'>- Update to 1.3.2.stephen2012-09-132-6/+6 * update to v096bf2012-09-132-3/+3 * Update to 16.0.4ehaupt2012-09-132-3/+3 * - Deprecate math/guppi. It's not developed anymore. Expiry in one monthgahr2012-09-131-0/+3 * update to 5.28.0bf2012-09-134-10/+10 * update to 3.1.2bf2012-09-132-3/+3 * update lang/sbcl to 1.0.58 and switch to the new options format;bf2012-09-134-3/+4 * - Update to 5.3.stephen2012-09-124-7/+5 * * updates to 0.2.3maho2012-09-105-420/+32 * - Update to 0.0-20tota2012-09-103-10/+4 * - Update to 16.0.3ehaupt2012-09-092-8/+3 * - Update to 1.0.20.stephen2012-09-092-3/+3 * - Update to 1.1.1.stephen2012-09-092-4/+3 * - Update to 0.10swills2012-09-093-4/+5 * Update ised to 2.4.0eadler2012-09-083-3/+24 * Remove useless metadata from ports I created.des2012-09-052-10/+0 * - Add a new port: math/R-cran-gtabletota2012-09-054-0/+22 * Chase Emacs updatesashish2012-09-052-2/+2 * - Update to 0.7.1wen2012-09-043-406/+414 * - Update to 0.5-50tota2012-09-022-9/+3 * - Stop installing FindAnalitza.cmake now that math/analitza providesavilla2012-09-023-9/+1 * Update to 1.11kevlo2012-08-312-4/+3 * - Update to 1.3.1.stephen2012-08-302-3/+3 * - Update to 2.3.53.stephen2012-08-282-3/+3 * - Update to 0.4.1.stephen2012-08-272-3/+3 * Add an math/openblas.maho2012-08-2614-0/+811 * Update to 3.4.1.maho2012-08-2610-1152/+6 * - Update to 1.3.0.stephen2012-08-262-4/+3 * Update to 3.1.1.rakuco2012-08-253-6/+7 * Fix build with clangbapt2012-08-241-0/+11 * Fix build with clangbapt2012-08-245-3/+117 * Fix typos in COMMENT sectionskreuzer2012-08-241-1/+1 * An R interface to the Lawson-Hanson implementation of an algorithm forskreuzer2012-08-224-0/+28 * - Update to 0.1.2.stephen2012-08-182-3/+3 * Add py-pandas , flexible, high-performance data analysis in Python.rm2012-08-166-0/+530 * - Update to 5.0.5bdrewery2012-08-152-3/+3 * - Add optional dependency math/octave-forge-lssa.stephen2012-08-151-1/+5 * - New port, math/octave-forge-lssa.stephen2012-08-155-0/+44 * - Update to 6.21sunpoet2012-08-143-7/+7 * - Fix and sort PLISTsunpoet2012-08-142-5/+4 * Update to 3.1.1 release and enable TLS on supported FreeBSD versions.ale2012-08-132-32/+17 * - Update to 3.15sunpoet2012-08-132-3/+3 * - Update to 1.3.0.stephen2012-08-092-8/+6 * Update to 16.0.2ehaupt2012-08-072-3/+3 * - Update to 1.16wen2012-08-072-3/+5 * Advise PORTSCOUT not to run into a false positive due to thegerald2012-08-061-2/+4 * - Remove some empty filesmiwi2012-08-051-0/+0 * - Update to 1.4.3.20110119miwi2012-08-054-18/+18 * Switch from libglut to freeglut and retire libglut. Libglut hasn't beenkwm2012-08-054-3/+4 * Update to 4.2.rakuco2012-08-043-4/+11 * - Update to 1.3.2.stephen2012-08-042-4/+3 * Remove unecessary OPTIONS_DEFAULT definitions added on r301957garga2012-08-041-1/+0 * - Update to 2.00scheidell2012-08-044-5/+17 * Fix typos and make small modifications in COMMENT (according to Porter'scs2012-08-037-7/+7 * Add DOCS, EXAMPLES and NLS to OPTIONS_DEFINE to my portsgarga2012-08-031-1/+4 * OpenGL Mathematics (GLM) is a header only C++ mathematics library fordemon2012-08-035-0/+272 * - Update to 0.8.2pgj2012-08-032-3/+3 * - Update to 1.3.4pgj2012-08-032-3/+3 * - Update to 2.1.2pgj2012-08-032-3/+3 * - Teach the Haskell Cabal ports to use the new options frameworkpgj2012-08-0317-9/+23 * - Update to my new maintainer addressbdrewery2012-08-031-2/+2 * - Bump PORTREVISION to chase Emacs port updatesashish2012-08-022-2/+2 * Remove DEPRECATED and EXPIRATION_DATE as the main site appears back online.wxs2012-07-312-9/+1 * - Update to 5.2.stephen2012-07-314-22/+4 * - Update to 6.19sunpoet2012-07-312-4/+3 * - Update to 1.00sunpoet2012-07-312-9/+8 * Fix typos in COMMENTcs2012-07-2914-14/+14 * Fix typos in COMMENTcs2012-07-283-3/+3 * - Restore distinfo of fenv.c/fenv.h for older FreeBSD which were removed in t...sunpoet2012-07-281-0/+8 * - Convert my ports to new options frameworkmakc2012-07-274-28/+38 * switch to USE_PKGCONFIGnaddy2012-07-272-4/+5 * new devel/pkgconf added to replace devel/pkg-config. new version of pkg-configbapt2012-07-261-1/+1 * - Update to 1.2.9.stephen2012-07-262-3/+4 * - Update to 1.0.2.stephen2012-07-262-5/+4 * - Update to 1.1.0.stephen2012-07-262-5/+16 * Fix typos in COMMENTcs2012-07-251-1/+1 * Deprecate these ports as upstream has abandoned them for a while now.wxs2012-07-252-0/+6 * dlmodeler is a set of user-friendly functions to simplify the state-spacewen2012-07-244-0/+33 * - Update to 0.15.1wen2012-07-242-4/+3 * - Update to 1.5.3wen2012-07-242-4/+3 * Update gap to 4.5.4johans2012-07-242-4/+4 * - Update to 12.04.0nivit2012-07-235-9/+30 * Update to 16.0.1ehaupt2012-07-222-3/+3 * - Add optional dependency math/octave-forge-ncarray.stephen2012-07-211-1/+5 * - New port math/octave-forge-ncarray.stephen2012-07-215-0/+46 * - Update to 0.48culot2012-07-183-11/+10 * - Update to 5.6 [1]jase2012-07-174-15/+63 * - Rename spkg-patch files in files directory to include generic packagestephen2012-07-16