aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2012-08-03 23:13:10 +0800
committerdemon <demon@FreeBSD.org>2012-08-03 23:13:10 +0800
commitae3269a560e6cc21c2625fb41441b9213776e1b2 (patch)
treee0a5156752e04db7a2ac489ed6ff88c06f124f75 /math
parentba013d1ec3e89f7c0c2dbec65093f17ee16dc224 (diff)
downloadfreebsd-ports-graphics-ae3269a560e6cc21c2625fb41441b9213776e1b2.tar.gz
freebsd-ports-graphics-ae3269a560e6cc21c2625fb41441b9213776e1b2.tar.zst
freebsd-ports-graphics-ae3269a560e6cc21c2625fb41441b9213776e1b2.zip
OpenGL Mathematics (GLM) is a header only C++ mathematics library for
graphics software based on the OpenGL Shading Language (GLSL) specification. GLM provides classes and functions designed and implemented with the same naming conventions and functionalities than GLSL so that when a programmer knows GLSL, he knows GLM as well which makes it really easy to use.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/glm/Makefile23
-rw-r--r--math/glm/distinfo2
-rw-r--r--math/glm/pkg-descr18
-rw-r--r--math/glm/pkg-plist228
5 files changed, 272 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 46758dbc3b4..dd0294daea2 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -128,6 +128,7 @@
SUBDIR += giacxcas
SUBDIR += givaro
SUBDIR += glgraph
+ SUBDIR += glm
SUBDIR += glpk
SUBDIR += gmm++
SUBDIR += gmp
diff --git a/math/glm/Makefile b/math/glm/Makefile
new file mode 100644
index 00000000000..d484cfbb21a
--- /dev/null
+++ b/math/glm/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: glm
+# Date created: Aug 03 2012
+# Whom: demon@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= glm
+PORTVERSION= 0.9.3.4
+CATEGORIES= math graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ogl-math/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= C++ mathematics library for software based on the OpenGL GLSL
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+do-install:
+ cd ${WRKSRC} && ${FIND} glm -print -depth | ${CPIO} -pdm ${PREFIX}/include/
+
+.include <bsd.port.mk>
diff --git a/math/glm/distinfo b/math/glm/distinfo
new file mode 100644
index 00000000000..01913796c99
--- /dev/null
+++ b/math/glm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (glm-0.9.3.4.zip) = 0646b29718cf3ad2ee9c4c9dcb2d5b1d9b483fc0b71764e93b369934203d90ce
+SIZE (glm-0.9.3.4.zip) = 6371127
diff --git a/math/glm/pkg-descr b/math/glm/pkg-descr
new file mode 100644
index 00000000000..511e33ef47a
--- /dev/null
+++ b/math/glm/pkg-descr
@@ -0,0 +1,18 @@
+OpenGL Mathematics (GLM) is a header only C++ mathematics library for
+graphics software based on the OpenGL Shading Language (GLSL) specification.
+
+GLM provides classes and functions designed and implemented with the same
+naming conventions and functionalities than GLSL so that when a programmer
+knows GLSL, he knows GLM as well which makes it really easy to use.
+
+This project isn't limited to GLSL features. An extension system, based on
+the GLSL extension conventions, provides extended capabilities: matrix
+transformations, quaternions, half-based types, random numbers, procedural
+noise functions, etc...
+
+This library works perfectly with OpenGL but it also ensures interoperability
+with third party libraries and SDKs. It is a good candidate for software
+rendering (Raytracing / Rasterisation), image processing, physic simulations
+and any context that requires a simple and convenient mathematics library.
+
+WWW: http://glm.g-truc.net/
diff --git a/math/glm/pkg-plist b/math/glm/pkg-plist
new file mode 100644
index 00000000000..c314c6699d3
--- /dev/null
+++ b/math/glm/pkg-plist
@@ -0,0 +1,228 @@
+include/glm/CMakeLists.txt
+include/glm/core/_detail.hpp
+include/glm/core/_fixes.hpp
+include/glm/core/_swizzle.hpp
+include/glm/core/_swizzle_func.hpp
+include/glm/core/_vectorize.hpp
+include/glm/core/dummy.cpp
+include/glm/core/func_common.hpp
+include/glm/core/func_common.inl
+include/glm/core/func_exponential.hpp
+include/glm/core/func_exponential.inl
+include/glm/core/func_geometric.hpp
+include/glm/core/func_geometric.inl
+include/glm/core/func_integer.hpp
+include/glm/core/func_integer.inl
+include/glm/core/func_matrix.hpp
+include/glm/core/func_matrix.inl
+include/glm/core/func_noise.hpp
+include/glm/core/func_noise.inl
+include/glm/core/func_packing.hpp
+include/glm/core/func_packing.inl
+include/glm/core/func_trigonometric.hpp
+include/glm/core/func_trigonometric.inl
+include/glm/core/func_vector_relational.hpp
+include/glm/core/func_vector_relational.inl
+include/glm/core/hint.hpp
+include/glm/core/intrinsic_common.hpp
+include/glm/core/intrinsic_common.inl
+include/glm/core/intrinsic_exponential.hpp
+include/glm/core/intrinsic_exponential.inl
+include/glm/core/intrinsic_geometric.hpp
+include/glm/core/intrinsic_geometric.inl
+include/glm/core/intrinsic_matrix.hpp
+include/glm/core/intrinsic_matrix.inl
+include/glm/core/intrinsic_trigonometric.hpp
+include/glm/core/intrinsic_trigonometric.inl
+include/glm/core/intrinsic_vector_relational.hpp
+include/glm/core/intrinsic_vector_relational.inl
+include/glm/core/setup.hpp
+include/glm/core/type.hpp
+include/glm/core/type_float.hpp
+include/glm/core/type_gentype.hpp
+include/glm/core/type_gentype.inl
+include/glm/core/type_half.hpp
+include/glm/core/type_half.inl
+include/glm/core/type_int.hpp
+include/glm/core/type_mat.hpp
+include/glm/core/type_mat.inl
+include/glm/core/type_mat2x2.hpp
+include/glm/core/type_mat2x2.inl
+include/glm/core/type_mat2x3.hpp
+include/glm/core/type_mat2x3.inl
+include/glm/core/type_mat2x4.hpp
+include/glm/core/type_mat2x4.inl
+include/glm/core/type_mat3x2.hpp
+include/glm/core/type_mat3x2.inl
+include/glm/core/type_mat3x3.hpp
+include/glm/core/type_mat3x3.inl
+include/glm/core/type_mat3x4.hpp
+include/glm/core/type_mat3x4.inl
+include/glm/core/type_mat4x2.hpp
+include/glm/core/type_mat4x2.inl
+include/glm/core/type_mat4x3.hpp
+include/glm/core/type_mat4x3.inl
+include/glm/core/type_mat4x4.hpp
+include/glm/core/type_mat4x4.inl
+include/glm/core/type_size.hpp
+include/glm/core/type_vec.hpp
+include/glm/core/type_vec.inl
+include/glm/core/type_vec1.hpp
+include/glm/core/type_vec1.inl
+include/glm/core/type_vec2.hpp
+include/glm/core/type_vec2.inl
+include/glm/core/type_vec3.hpp
+include/glm/core/type_vec3.inl
+include/glm/core/type_vec4.hpp
+include/glm/core/type_vec4.inl
+include/glm/ext.hpp
+include/glm/glm.hpp
+include/glm/gtc/half_float.hpp
+include/glm/gtc/half_float.inl
+include/glm/gtc/matrix_access.hpp
+include/glm/gtc/matrix_access.inl
+include/glm/gtc/matrix_integer.hpp
+include/glm/gtc/matrix_inverse.hpp
+include/glm/gtc/matrix_inverse.inl
+include/glm/gtc/matrix_transform.hpp
+include/glm/gtc/matrix_transform.inl
+include/glm/gtc/noise.hpp
+include/glm/gtc/noise.inl
+include/glm/gtc/quaternion.hpp
+include/glm/gtc/quaternion.inl
+include/glm/gtc/random.hpp
+include/glm/gtc/random.inl
+include/glm/gtc/swizzle.hpp
+include/glm/gtc/swizzle.inl
+include/glm/gtc/type_precision.hpp
+include/glm/gtc/type_precision.inl
+include/glm/gtc/type_ptr.hpp
+include/glm/gtc/type_ptr.inl
+include/glm/gtx/associated_min_max.hpp
+include/glm/gtx/associated_min_max.inl
+include/glm/gtx/bit.hpp
+include/glm/gtx/bit.inl
+include/glm/gtx/closest_point.hpp
+include/glm/gtx/closest_point.inl
+include/glm/gtx/color_cast.hpp
+include/glm/gtx/color_cast.inl
+include/glm/gtx/color_space.hpp
+include/glm/gtx/color_space.inl
+include/glm/gtx/color_space_YCoCg.hpp
+include/glm/gtx/color_space_YCoCg.inl
+include/glm/gtx/compatibility.hpp
+include/glm/gtx/compatibility.inl
+include/glm/gtx/component_wise.hpp
+include/glm/gtx/component_wise.inl
+include/glm/gtx/constants.hpp
+include/glm/gtx/constants.inl
+include/glm/gtx/epsilon.hpp
+include/glm/gtx/epsilon.inl
+include/glm/gtx/euler_angles.hpp
+include/glm/gtx/euler_angles.inl
+include/glm/gtx/extend.hpp
+include/glm/gtx/extend.inl
+include/glm/gtx/extented_min_max.hpp
+include/glm/gtx/extented_min_max.inl
+include/glm/gtx/fast_exponential.hpp
+include/glm/gtx/fast_exponential.inl
+include/glm/gtx/fast_square_root.hpp
+include/glm/gtx/fast_square_root.inl
+include/glm/gtx/fast_trigonometry.hpp
+include/glm/gtx/fast_trigonometry.inl
+include/glm/gtx/gradient_paint.hpp
+include/glm/gtx/gradient_paint.inl
+include/glm/gtx/handed_coordinate_space.hpp
+include/glm/gtx/handed_coordinate_space.inl
+include/glm/gtx/inertia.hpp
+include/glm/gtx/inertia.inl
+include/glm/gtx/int_10_10_10_2.hpp
+include/glm/gtx/int_10_10_10_2.inl
+include/glm/gtx/integer.hpp
+include/glm/gtx/integer.inl
+include/glm/gtx/intersect.hpp
+include/glm/gtx/intersect.inl
+include/glm/gtx/log_base.hpp
+include/glm/gtx/log_base.inl
+include/glm/gtx/matrix_cross_product.hpp
+include/glm/gtx/matrix_cross_product.inl
+include/glm/gtx/matrix_interpolation.hpp
+include/glm/gtx/matrix_interpolation.inl
+include/glm/gtx/matrix_major_storage.hpp
+include/glm/gtx/matrix_major_storage.inl
+include/glm/gtx/matrix_operation.hpp
+include/glm/gtx/matrix_operation.inl
+include/glm/gtx/matrix_query.hpp
+include/glm/gtx/matrix_query.inl
+include/glm/gtx/mixed_product.hpp
+include/glm/gtx/mixed_product.inl
+include/glm/gtx/multiple.hpp
+include/glm/gtx/multiple.inl
+include/glm/gtx/noise.hpp
+include/glm/gtx/noise.inl
+include/glm/gtx/norm.hpp
+include/glm/gtx/norm.inl
+include/glm/gtx/normal.hpp
+include/glm/gtx/normal.inl
+include/glm/gtx/normalize_dot.hpp
+include/glm/gtx/normalize_dot.inl
+include/glm/gtx/number_precision.hpp
+include/glm/gtx/number_precision.inl
+include/glm/gtx/ocl_type.hpp
+include/glm/gtx/ocl_type.inl
+include/glm/gtx/optimum_pow.hpp
+include/glm/gtx/optimum_pow.inl
+include/glm/gtx/orthonormalize.hpp
+include/glm/gtx/orthonormalize.inl
+include/glm/gtx/perpendicular.hpp
+include/glm/gtx/perpendicular.inl
+include/glm/gtx/polar_coordinates.hpp
+include/glm/gtx/polar_coordinates.inl
+include/glm/gtx/projection.hpp
+include/glm/gtx/projection.inl
+include/glm/gtx/quaternion.hpp
+include/glm/gtx/quaternion.inl
+include/glm/gtx/random.hpp
+include/glm/gtx/random.inl
+include/glm/gtx/raw_data.hpp
+include/glm/gtx/raw_data.inl
+include/glm/gtx/reciprocal.hpp
+include/glm/gtx/reciprocal.inl
+include/glm/gtx/rotate_vector.hpp
+include/glm/gtx/rotate_vector.inl
+include/glm/gtx/simd_mat4.hpp
+include/glm/gtx/simd_mat4.inl
+include/glm/gtx/simd_vec4.hpp
+include/glm/gtx/simd_vec4.inl
+include/glm/gtx/spline.hpp
+include/glm/gtx/spline.inl
+include/glm/gtx/std_based_type.hpp
+include/glm/gtx/std_based_type.inl
+include/glm/gtx/string_cast.hpp
+include/glm/gtx/string_cast.inl
+include/glm/gtx/transform.hpp
+include/glm/gtx/transform.inl
+include/glm/gtx/transform2.hpp
+include/glm/gtx/transform2.inl
+include/glm/gtx/ulp.hpp
+include/glm/gtx/ulp.inl
+include/glm/gtx/unsigned_int.hpp
+include/glm/gtx/unsigned_int.inl
+include/glm/gtx/vec1.hpp
+include/glm/gtx/vec1.inl
+include/glm/gtx/vector_access.hpp
+include/glm/gtx/vector_access.inl
+include/glm/gtx/vector_angle.hpp
+include/glm/gtx/vector_angle.inl
+include/glm/gtx/vector_query.hpp
+include/glm/gtx/vector_query.inl
+include/glm/gtx/verbose_operator.hpp
+include/glm/gtx/verbose_operator.inl
+include/glm/gtx/wrap.hpp
+include/glm/gtx/wrap.inl
+include/glm/virtrev/xstream.hpp
+@dirrm include/glm/virtrev
+@dirrm include/glm/gtx
+@dirrm include/glm/gtc
+@dirrm include/glm/core
+@dirrm include/glm