aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache20/Makefile
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-07-31 01:04:47 +0800
committerclement <clement@FreeBSD.org>2004-07-31 01:04:47 +0800
commit7963a078c6ae65f468289bbd113bd2f78fc603f6 (patch)
treeeee5429c073d6626473dccf7ad207b450103a4a0 /www/apache20/Makefile
parent36f639036c59b2771c3beacbe6286e98a18bc1a3 (diff)
downloadfreebsd-ports-gnome-7963a078c6ae65f468289bbd113bd2f78fc603f6.tar.gz
freebsd-ports-gnome-7963a078c6ae65f468289bbd113bd2f78fc603f6.tar.zst
freebsd-ports-gnome-7963a078c6ae65f468289bbd113bd2f78fc603f6.zip
apache2 NG patch 1/5.
o Changes in httpd.conf - mod_userdir: . set Userdir if mod_userdir is loaded [1] . Userdir is denied for users from /etc/ftpusers - set more "secure" permissions. By default, policy is to deny access to filesystem. You HAVE to _ENABLE_ access to your filesystem in httpd.conf. - Add an "Includes" directory to ${PREFIX}/etc/apache2/ to make configuration more flexible ${PREFIX}/etc/apache2/*.conf files are now automatically loaded. o apache.sh - be closer to apachectl, apache.sh need envvars [2] It should restore subversion behavior. Partially submitted by: kuriyama [1], Gregory (Grisha) Trubetskoy <grisha at apache dot org> [2] Future changes are mostly written, they should be committed during the week-end. If you're interrested in changes, feel free contact me.
Diffstat (limited to 'www/apache20/Makefile')
-rw-r--r--www/apache20/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 3e06a63f474c..0b856bfbfa15 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -172,9 +172,6 @@ pre-everything::
post-extract:
@${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/powerlogo.gif ${WRKSRC}/docs/icons/freebsd.gif
-pre-configure:
- @cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ./buildconf
-
post-patch:
@cd ${WRKSRC}/docs/docroot && \
for f in index.html.*; do (\
@@ -190,10 +187,19 @@ post-patch:
${WRKSRC}/server/core.c
@${INSTALL_DATA} ${WRKSRC}/NOTICE ${WRKSRC}/docs/manual
+pre-configure:
+ @cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ./buildconf
+
+post-configure:
+ @FTPUSERS=`${EGREP} -v '^#' /etc/ftpusers| ${TR} -s "\n" " "` ;\
+ ${REINPLACE_CMD} -e "s,%%FTPUSERS%%,$$FTPUSERS," \
+ ${WRKSRC}/docs/conf/httpd-std.conf
+
pre-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
+ @${MKDIR} ${PREFIX}/etc/apache2/Includes
@if [ ! -f ${PREFIX}/etc/rc.d/apache2.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache2.sh startup file."; \
${INSTALL_SCRIPT} -m 751 ${WRKDIR}/apache2.sh ${PREFIX}/etc/rc.d/apache2.sh; \