aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache20
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-05-07 05:10:36 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-05-07 05:10:36 +0800
commit3e834d126f69813d98a051a8bbb0ed0b457bede7 (patch)
tree58092a5d82910239a5de4479a26e372cbef93490 /www/apache20
parentbb00f7807c91f90f2e6aee65340be7a5e973376a (diff)
downloadfreebsd-ports-gnome-3e834d126f69813d98a051a8bbb0ed0b457bede7.tar.gz
freebsd-ports-gnome-3e834d126f69813d98a051a8bbb0ed0b457bede7.tar.zst
freebsd-ports-gnome-3e834d126f69813d98a051a8bbb0ed0b457bede7.zip
- Fix compile with security/openssl
- No PORTREVISION bump [security/openssl is not the default] PR: ports/146218 Submitted by: Kazuo Dohzono <dohzono@axion-software.com> Obtained from: http://mail-index.netbsd.org/pkgsrc-users/2009/08/25/msg010537.html With Hat: apache@ [I will contemplate sending this back to dev@httpd for branches/2.0.x for 2.0.64]
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile4
-rw-r--r--www/apache20/files/extra-openssl-9.8up.patch40
2 files changed, 44 insertions, 0 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 625a648fe9cf..0babc647c0b4 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -135,6 +135,10 @@ CONFIGURE_ARGS+= --with-ldap \
.include "${APACHEDIR}/Makefile.modules"
.include <bsd.port.pre.mk>
+.if defined(OPENSSL_INSTALLED)
+EXTRA_PATCHES+= ${FILESDIR}/extra-openssl-9.8up.patch
+.endif
+
.if ${OSVERSION} < 700014 && ${ARCH} == i386
BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
.endif
diff --git a/www/apache20/files/extra-openssl-9.8up.patch b/www/apache20/files/extra-openssl-9.8up.patch
new file mode 100644
index 000000000000..fb8bf993d92c
--- /dev/null
+++ b/www/apache20/files/extra-openssl-9.8up.patch
@@ -0,0 +1,40 @@
+--- ./modules/ssl/ssl_engine_init.c.orig 2010-05-06 16:52:31.600756207 -0400
++++ ./modules/ssl/ssl_engine_init.c 2010-05-06 16:53:33.937798326 -0400
+@@ -531,7 +531,7 @@
+ ssl_die();
+ }
+
+- SSL_CTX_set_client_CA_list(ctx, (STACK *)ca_list);
++ SSL_CTX_set_client_CA_list(ctx, ca_list);
+ }
+
+ /*
+--- ./modules/ssl/ssl_util_ssl.c.orig 2010-05-06 16:52:50.473746445 -0400
++++ ./modules/ssl/ssl_util_ssl.c 2010-05-06 16:54:44.811924436 -0400
+@@ -291,7 +291,7 @@
+ #ifdef HAVE_SSL_X509V3_EXT_d2i
+ X509_EXTENSION *ext;
+ int ext_nid;
+- STACK *sk;
++ STACK_OF(SSL_CIPHER) *sk;
+ BOOL is_sgc;
+ int idx;
+ int i;
+@@ -300,7 +300,7 @@
+ idx = X509_get_ext_by_NID(cert, NID_ext_key_usage, -1);
+ if (idx >= 0) {
+ ext = X509_get_ext(cert, idx);
+- if ((sk = (STACK *)X509V3_EXT_d2i(ext)) != NULL) {
++ if ((sk = X509V3_EXT_d2i(ext)) != NULL) {
+ for (i = 0; i < sk_num(sk); i++) {
+ ext_nid = OBJ_obj2nid((ASN1_OBJECT *)sk_value(sk, i));
+ if (ext_nid == NID_ms_sgc || ext_nid == NID_ns_sgc) {
+@@ -466,7 +466,7 @@
+ X509 *x509;
+ unsigned long err;
+ int n;
+- STACK *extra_certs;
++ STACK_OF(X509) *extra_certs;
+
+ if ((bio = BIO_new(BIO_s_file_internal())) == NULL)
+ return -1;