aboutsummaryrefslogtreecommitdiffstats
path: root/www/apache22
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2007-09-20 15:57:36 +0800
committerclement <clement@FreeBSD.org>2007-09-20 15:57:36 +0800
commita5b4ca48d31f770600090e888172e4d222bdb4a1 (patch)
tree5d80f030cb80f05073fab45941f57f7422c9e4df /www/apache22
parent897b76e9ca33ad35cd9865734c3e6ac946e1690d (diff)
downloadfreebsd-ports-gnome-a5b4ca48d31f770600090e888172e4d222bdb4a1.tar.gz
freebsd-ports-gnome-a5b4ca48d31f770600090e888172e4d222bdb4a1.tar.zst
freebsd-ports-gnome-a5b4ca48d31f770600090e888172e4d222bdb4a1.zip
- Fix PCRE_FROM_PORTS. it wasn't processed by OPTIONS stff [1]
- Preserve index.html - We no longer install images in default DocumentRoot (there're still in icons/) - Various plist cleanup - bump PORTREVISION since we are now safe with index.html Reminded by: bland@
Diffstat (limited to 'www/apache22')
-rw-r--r--www/apache22/Makefile1
-rw-r--r--www/apache22/files/patch-Makefile.in21
-rw-r--r--www/apache22/pkg-plist11
3 files changed, 16 insertions, 17 deletions
diff --git a/www/apache22/Makefile b/www/apache22/Makefile
index 149eff65f1ed..5b582f249750 100644
--- a/www/apache22/Makefile
+++ b/www/apache22/Makefile
@@ -9,6 +9,7 @@
PORTNAME= apache
PORTVERSION= 2.2.6
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD} \
${MASTER_SITE_LOCAL:S/%SUBDIR%\//clement\/:aprmysql/}
diff --git a/www/apache22/files/patch-Makefile.in b/www/apache22/files/patch-Makefile.in
index 39b10ca54633..d401ae9b84ec 100644
--- a/www/apache22/files/patch-Makefile.in
+++ b/www/apache22/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Tue Apr 24 13:08:01 2007
-+++ Makefile.in Wed Sep 19 21:28:08 2007
+--- Makefile.in.orig 2007-04-24 13:08:01.000000000 +0200
++++ Makefile.in 2007-09-20 08:47:23.000000000 +0200
@@ -31,9 +31,11 @@
install-conf:
@echo Installing configuration files
@@ -31,7 +31,7 @@
fi; \
fi; \
done ; \
-@@ -117,48 +119,32 @@
+@@ -117,48 +119,28 @@
doxygen $(top_srcdir)/docs/doxygen.conf
install-htdocs:
@@ -41,14 +41,15 @@
- echo Installing HTML documents ; \
+ @echo Installing HTML documents ; \
$(MKINSTALLDIRS) $(DESTDIR)$(htdocsdir) ; \
- if test -d $(htdocs-srcdir) && test "x$(RSYNC)" != "x" && test -x $(RSYNC) ; then \
- $(RSYNC) --exclude .svn -rlpt --numeric-ids $(htdocs-srcdir)/ $(DESTDIR)$(htdocsdir)/; \
- else \
- test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(DESTDIR)$(htdocsdir)) ; \
- cd $(DESTDIR)$(htdocsdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
+- if test -d $(htdocs-srcdir) && test "x$(RSYNC)" != "x" && test -x $(RSYNC) ; then \
+- $(RSYNC) --exclude .svn -rlpt --numeric-ids $(htdocs-srcdir)/ $(DESTDIR)$(htdocsdir)/; \
+- else \
+- test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp * $(DESTDIR)$(htdocsdir)) ; \
+- cd $(DESTDIR)$(htdocsdir) && find . -name ".svn" -type d -print | xargs rm -rf 2>/dev/null || true; \
- fi; \
- fi
-+ fi;
++ test -d $(htdocs-srcdir) && (cd $(htdocs-srcdir) && cp -rp index.html $(DESTDIR)$(EXAMPLESDIR)) && \
++ ( [ ! -f $(DESTDIR)$(htdocsdir)/index.html ] && cp -p $(DESTDIR)$(EXAMPLESDIR)/index.html $(DESTDIR)$(htdocsdir)/index.html)
install-error:
- -@if [ -d $(DESTDIR)$(errordir) ]; then \
@@ -88,7 +89,7 @@
install-other:
@test -d $(DESTDIR)$(logfiledir) || $(MKINSTALLDIRS) $(DESTDIR)$(logfiledir)
-@@ -206,12 +192,14 @@
+@@ -206,12 +188,14 @@
@test -d $(DESTDIR)$(manualdir) || $(MKINSTALLDIRS) $(DESTDIR)$(manualdir)
@cp -p $(top_srcdir)/docs/man/*.1 $(DESTDIR)$(mandir)/man1
@cp -p $(top_srcdir)/docs/man/*.8 $(DESTDIR)$(mandir)/man8
diff --git a/www/apache22/pkg-plist b/www/apache22/pkg-plist
index a5091e72d7f6..3839655128ba 100644
--- a/www/apache22/pkg-plist
+++ b/www/apache22/pkg-plist
@@ -275,12 +275,9 @@ share/apache22/build/rules.mk
share/apache22/build/special.mk
www/apache22/cgi-bin/printenv
www/apache22/cgi-bin/test-cgi
-www/apache22/data/apache_pb.gif
-www/apache22/data/apache_pb.png
-www/apache22/data/apache_pb22.gif
-www/apache22/data/apache_pb22.png
-www/apache22/data/apache_pb22_ani.gif
-www/apache22/data/index.html
+@unexec if cmp -s %D/www/apache22/data/index.html %D/%%EXAMPLESDIR%%/index.html; then rm -f %D/www/apache22/data/index.html; fi
+%%EXAMPLESDIR%%/index.html
+@exec [ -f %D/www/apache22/data/index.html ] || cp %D/%%EXAMPLESDIR%%/www/apache22/data/index.html %D/www/apache22/data/index.html
www/apache22/error/HTTP_BAD_GATEWAY.html.var
www/apache22/error/HTTP_BAD_REQUEST.html.var
www/apache22/error/HTTP_FORBIDDEN.html.var
@@ -528,7 +525,7 @@ www/apache22/icons/world2.png
@dirrm www/apache22/icons
@dirrm www/apache22/error/include
@dirrm www/apache22/error
-@dirrm www/apache22/data
+@dirrmtry www/apache22/data
@dirrm www/apache22/cgi-bin
@dirrm %%EXAMPLESDIR%%/extra
@dirrm %%EXAMPLESDIR%%