aboutsummaryrefslogtreecommitdiffstats
path: root/www/aws-demos
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-11-11 00:22:47 +0800
committermarino <marino@FreeBSD.org>2013-11-11 00:22:47 +0800
commit1a02b34fe51c223647befd066b3edcc351170e9a (patch)
tree87ae787445669414b4eb3d13a0246f57fd18ca71 /www/aws-demos
parent2a272b1408123daf7c479f59515adf61c0fa5f37 (diff)
downloadfreebsd-ports-gnome-1a02b34fe51c223647befd066b3edcc351170e9a.tar.gz
freebsd-ports-gnome-1a02b34fe51c223647befd066b3edcc351170e9a.tar.zst
freebsd-ports-gnome-1a02b34fe51c223647befd066b3edcc351170e9a.zip
www/aws(-demos): Convert to staging
* Convert USE_GMAKE to USES
Diffstat (limited to 'www/aws-demos')
-rw-r--r--www/aws-demos/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/aws-demos/Makefile b/www/aws-demos/Makefile
index 47d8ac3a991b..8afeeed24380 100644
--- a/www/aws-demos/Makefile
+++ b/www/aws-demos/Makefile
@@ -15,8 +15,7 @@ BUILD_DEPENDS+= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
aws>=3.1:${PORTSDIR}/www/aws
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= ada
+USES= ada gmake
CONF_ARGS= PROCESSORS=1
CONF_ARGS+= GCC=ada
@@ -58,7 +57,6 @@ DEMO_DIRS+= zdemo
#DEMO_DIRS+= hello_wsdl
#DEMO_DIRS+= interoplab
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSL}
@@ -96,10 +94,10 @@ do-build:
.endfor
do-install:
- @${MKDIR} ${PREFIX}/share/examples/aws-demos
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/examples/aws-demos
.for dd in ${DEMO_DIRS}
${FIND} ${WRKSRC}/demos/${dd} -type f -perm -0001 \
- -exec ${INSTALL} {} ${PREFIX}/share/examples/aws-demos/ \;
+ -exec ${INSTALL} {} ${STAGEDIR}${PREFIX}/share/examples/aws-demos/ \;
.endfor
.include <bsd.port.mk>