aboutsummaryrefslogtreecommitdiffstats
path: root/www/axis2
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-09-28 02:38:18 +0800
committercrees <crees@FreeBSD.org>2011-09-28 02:38:18 +0800
commit7a00904b79b9e0182c67abc902eb7bb64b0331bc (patch)
treec557e9367a2a4bb427775da9bf855cf98c55fa78 /www/axis2
parent42be7d015e40a873620afe3bc5109805d4438b71 (diff)
downloadfreebsd-ports-gnome-7a00904b79b9e0182c67abc902eb7bb64b0331bc.tar.gz
freebsd-ports-gnome-7a00904b79b9e0182c67abc902eb7bb64b0331bc.tar.zst
freebsd-ports-gnome-7a00904b79b9e0182c67abc902eb7bb64b0331bc.zip
Fix build and fail if no app servers are selected.
Submitted by: Jason Helfman (maintainer), eadler
Diffstat (limited to 'www/axis2')
-rw-r--r--www/axis2/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/www/axis2/Makefile b/www/axis2/Makefile
index 15a2dd3d3237..6248d362e91f 100644
--- a/www/axis2/Makefile
+++ b/www/axis2/Makefile
@@ -16,6 +16,8 @@ COMMENT= Provides a Web Services,SOAP and WSDL engine from Apache
LICENSE= ASL
+USE_ZIP= yes
+
OPTIONS= TOMCAT5 "Enable Tomcat 5.x support" on \
TOMCAT6 "Enable Tomcat 6.x support" off \
TOMCAT7 "Enable Tomcat 7.x support" off
@@ -47,18 +49,23 @@ WEBAPPDIR= ${APPHOME}/webapps
IGNORE= you can only define one application server
.elif ( defined(WITH_TOMCAT6) && defined(WITH_TOMCAT7) )
IGNORE= you can only define one application server
+.elif !defined(WEBAPPDIR)
+IGNORE= you need at least one application server
.endif
-.include <bsd.port.options.mk>
-
-USE_ZIP= yes
-NO_BUILD= YES
USE_JAVA= yes
JAVA_VERSION= 1.6+
+SHAREOWN= www
+SHAREGRP= www
PLIST_SUB+= WEBAPPS=${WEBAPPDIR:S|^${PREFIX}/||}
+do-build:
+ @${MKDIR} ${WRKSRC}
+ @(cd ${WRKSRC} && ${TAR} xf ${WRKDIR}/${PORTNAME}.war)
+
do-install:
${MKDIR} ${WEBAPPDIR}/${PORTNAME}
${UNZIP_CMD} ${WRKDIR}/${PORTNAME}.war -d ${WEBAPPDIR}/${PORTNAME}
+ ( cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTNAME} )
.include <bsd.port.mk>