aboutsummaryrefslogtreecommitdiffstats
path: root/www/cadaver
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-02-08 01:14:35 +0800
committervd <vd@FreeBSD.org>2006-02-08 01:14:35 +0800
commit98c4ee98c81b4fc5fad78617c720a71a8a372b43 (patch)
treed68940315657e8f278b9f6f532c3c362d448b299 /www/cadaver
parentffdf3c01b55e86f9ad02ff4aa5374c3c238e5223 (diff)
downloadfreebsd-ports-gnome-98c4ee98c81b4fc5fad78617c720a71a8a372b43.tar.gz
freebsd-ports-gnome-98c4ee98c81b4fc5fad78617c720a71a8a372b43.tar.zst
freebsd-ports-gnome-98c4ee98c81b4fc5fad78617c720a71a8a372b43.zip
* Fix build by adding missing dependency to gettext and make that
conditional by WITHOUT_NLS being set or not * Fix path in EXTRACT_AFTER_ARGS * Bump PORTREVISION because internationalization can now be turned on and off PR: ports/91756, ports/91962 Submitted by: rushani, Josh Paetzel <josh@tcbug.org> (maintainer) Approved by: garga (mentor), Josh Paetzel <josh@tcbug.org> (maintainer)
Diffstat (limited to 'www/cadaver')
-rw-r--r--www/cadaver/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 56ba188acc22..f6e24009e8af 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cadaver
PORTVERSION= 0.22.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/cadaver/ \
http://www.tcbug.org/
@@ -18,8 +19,6 @@ COMMENT= Commandline client for DAV
LIB_DEPENDS= neon.25:${PORTSDIR}/www/neon
-BROKEN= Does not compile
-
USE_GPG?= yes
SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.asc
USE_GETOPT_LONG= yes
@@ -31,13 +30,15 @@ ALL_TARGET= cadaver
MAN1= cadaver.1
PLIST_FILES= bin/cadaver
+
# Neither expat nor libneon are needed at all, but the configure
# script breaks if it can not find the Makefile* in them. Exclude
# them to be sure, a stray .h is not included instead of what's
# found under PREFIX (installed by the neon port):
EXTRACT_AFTER_ARGS= | ${TAR} -xf - \
- --exclude '${PORTNAME}-${PORTVERSION}/expat/*.[ch]' \
- --exclude '${PORTNAME}-${PORTVERSION}/libneon/*.[ch]'
+ --exclude '${PORTNAME}-${PORTVERSION}/lib/expat/*.[ch]' \
+ --exclude '${PORTNAME}-${PORTVERSION}/lib/intl/*.[ch]' \
+ --exclude '${PORTNAME}-${PORTVERSION}/lib/neon/*.[ch]'
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -47,4 +48,19 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl --with-force-ssl
.endif
+.if !defined(WITHOUT_NLS)
+USE_ICONV= yes
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+LANGS=en@quot es it
+.for lang in ${LANGS}
+PLIST_FILES+= share/locale/${lang}/LC_MESSAGES/cadaver.mo
+.endfor
+.else
+CONFIGURE_ARGS+=--disable-nls \
+ --without-libiconv-prefix \
+ --without-libintl-prefix
+.endif
+
.include <bsd.port.mk>