aboutsummaryrefslogtreecommitdiffstats
path: root/www/cherokee-devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-09-20 18:33:33 +0800
committermiwi <miwi@FreeBSD.org>2006-09-20 18:33:33 +0800
commit0bb668790e278294f5dd689285cdfa0fa122b7d9 (patch)
treec4320653ce2d798fa99883ac9a7766f5c52fa2d5 /www/cherokee-devel
parent31d46739389e98747dd0a8fa3ada9a1dc57b763e (diff)
downloadfreebsd-ports-gnome-0bb668790e278294f5dd689285cdfa0fa122b7d9.tar.gz
freebsd-ports-gnome-0bb668790e278294f5dd689285cdfa0fa122b7d9.tar.zst
freebsd-ports-gnome-0bb668790e278294f5dd689285cdfa0fa122b7d9.zip
- Update to 0.5.5
PR: ports/103228 Submitted by: chinsan <chinsan.tw@gmail.com>
Diffstat (limited to 'www/cherokee-devel')
-rw-r--r--www/cherokee-devel/Makefile2
-rw-r--r--www/cherokee-devel/distinfo6
-rw-r--r--www/cherokee-devel/files/patch-cherokee-connection.c33
-rw-r--r--www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c4
-rw-r--r--www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c20
-rw-r--r--www/cherokee-devel/files/patch-cherokee-socket.c22
-rw-r--r--www/cherokee-devel/files/patch-cherokee-util.h10
7 files changed, 73 insertions, 24 deletions
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index ad4c405f6770..c73136f33923 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.5.4
+PORTVERSION= 0.5.5
CATEGORIES= www
MASTER_SITES= http://www.0x50.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
diff --git a/www/cherokee-devel/distinfo b/www/cherokee-devel/distinfo
index 7bbb8683bd2b..7d479d4ae9f4 100644
--- a/www/cherokee-devel/distinfo
+++ b/www/cherokee-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (cherokee-0.5.4.tar.gz) = 4e207961bc8204a2e2026391649dd8af
-SHA256 (cherokee-0.5.4.tar.gz) = f44f16e8cf581ba8a7b22e4c9631e432967f43c9af50cf706432e8ad58a9c331
-SIZE (cherokee-0.5.4.tar.gz) = 1556342
+MD5 (cherokee-0.5.5.tar.gz) = fb891b3da7eb921c09a5eb93e296f5e1
+SHA256 (cherokee-0.5.5.tar.gz) = e9c6feee2a626a38cd69c726ed31ffbbf55d288386f50fe6f90fa63de410d67a
+SIZE (cherokee-0.5.5.tar.gz) = 1559655
diff --git a/www/cherokee-devel/files/patch-cherokee-connection.c b/www/cherokee-devel/files/patch-cherokee-connection.c
new file mode 100644
index 000000000000..2a36cb00bae4
--- /dev/null
+++ b/www/cherokee-devel/files/patch-cherokee-connection.c
@@ -0,0 +1,33 @@
+--- cherokee/connection.c.orig Wed Sep 20 21:17:53 2006
++++ cherokee/connection.c Wed Sep 20 21:17:53 2006
+@@ -33,6 +33,12 @@
+ #include <time.h>
+ #include <sys/types.h>
+
++#undef fr_atoll
++#define fr_atoll(nptr) strtoll(nptr, (char **)NULL, 10)
++
++#include <stdlib.h>
++#include <limits.h>
++
+ #ifdef HAVE_PWD_H
+ # include <pwd.h>
+ #endif
+@@ -1210,7 +1216,7 @@
+ }
+ tmp[num_len] = '\0';
+ if (num_len != 0) {
+- cnt->range_start = atoll (tmp);
++ cnt->range_start = fr_atoll (tmp);
+ if (cnt->range_start < 0) {
+ return ret_error;
+ }
+@@ -1236,7 +1242,7 @@
+ num_len++;
+ }
+ tmp[num_len] = '\0';
+- cnt->range_end = atoll (tmp);
++ cnt->range_end = fr_atoll (tmp);
+ if (cnt->range_end < 1){
+ return ret_error;
+ }
diff --git a/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c b/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
index 07ecb82c1bab..145916b5486b 100644
--- a/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
+++ b/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
@@ -1,5 +1,5 @@
---- cherokee/fdpoll-kqueue.c.orig Fri May 27 02:42:27 2005
-+++ cherokee/fdpoll-kqueue.c Fri Sep 16 00:03:37 2005
+--- cherokee/fdpoll-kqueue.c.orig Wed Sep 13 21:45:31 2006
++++ cherokee/fdpoll-kqueue.c Wed Sep 13 21:45:13 2006
@@ -27,6 +27,7 @@
#include "fdpoll-protected.h"
diff --git a/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c b/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c
new file mode 100644
index 000000000000..7270ff234a64
--- /dev/null
+++ b/www/cherokee-devel/files/patch-cherokee-handler_cgi_base.c
@@ -0,0 +1,20 @@
+--- cherokee/handler_cgi_base.c.orig Wed Sep 20 21:17:09 2006
++++ cherokee/handler_cgi_base.c Wed Sep 20 21:17:09 2006
+@@ -21,6 +21,8 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+ * USA
+ */
++#include <stdlib.h>
++#include <limits.h>
+
+ #include "common-internal.h"
+ #include "handler_cgi_base.h"
+@@ -578,7 +580,7 @@
+ cherokee_buffer_t tmp = CHEROKEE_BUF_INIT;
+
+ cherokee_buffer_add (&tmp, begin+16, end - (begin+16));
+- cgi->content_length = atoll (tmp.buf);
++ cgi->content_length = fr_atoll (tmp.buf);
+ cherokee_buffer_mrproper (&tmp);
+
+ cherokee_buffer_remove_chunk (buffer, begin - buffer->buf, end2 - begin);
diff --git a/www/cherokee-devel/files/patch-cherokee-socket.c b/www/cherokee-devel/files/patch-cherokee-socket.c
index 9e2f4f133ffc..27451dba8e0c 100644
--- a/www/cherokee-devel/files/patch-cherokee-socket.c
+++ b/www/cherokee-devel/files/patch-cherokee-socket.c
@@ -1,27 +1,23 @@
---- cherokee/socket.c.orig Tue Aug 2 05:32:12 2005
-+++ cherokee/socket.c Thu Aug 4 21:17:27 2005
-@@ -1052,15 +1052,20 @@
+--- cherokee/socket.c.orig Wed Sep 13 21:48:51 2006
++++ cherokee/socket.c Wed Sep 13 22:06:35 2006
+@@ -1122,13 +1122,17 @@
cherokee_socket_init_client_tls (cherokee_socket_t *socket)
{
#ifdef HAVE_TLS
- int re;
-
-- socket->is_tls = TLS;
--
# ifdef HAVE_GNUTLS
+
- const int kx_priority[] = {GNUTLS_KX_ANON_DH, 0};
-
+ const int kx_priority[] = {GNUTLS_KX_ANON_DH, 0};
gnutls_anon_client_credentials anoncred;
+-
+
-+# endif
++#endif
+
-+ int re;
-
-+ socket->is_tls = TLS;
++ int re;
+ socket->is_tls = TLS;
+
+# ifdef HAVE_GNUTLS
-+
+
/* Acredentials
*/
- gnutls_anon_allocate_client_credentials(&anoncred);
diff --git a/www/cherokee-devel/files/patch-cherokee-util.h b/www/cherokee-devel/files/patch-cherokee-util.h
index 180fecacac4e..6a3ea92b1589 100644
--- a/www/cherokee-devel/files/patch-cherokee-util.h
+++ b/www/cherokee-devel/files/patch-cherokee-util.h
@@ -1,5 +1,5 @@
---- cherokee/util.h.orig Sat Oct 15 19:31:05 2005
-+++ cherokee/util.h Thu Oct 20 00:59:40 2005
+--- cherokee/util.h.orig Wed Sep 13 22:13:07 2006
++++ cherokee/util.h Wed Sep 13 22:15:20 2006
@@ -31,6 +31,14 @@
#include <cherokee/common.h>
@@ -12,6 +12,6 @@
+# include <sys/socket.h>
+#endif
+
- #ifdef HAVE_NETINET_IN_H
- # include <netinet/in.h>
- #endif
+ #include <time.h>
+ #include <dirent.h>
+