aboutsummaryrefslogtreecommitdiffstats
path: root/www/cherokee-devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-20 03:07:20 +0800
committerpav <pav@FreeBSD.org>2006-01-20 03:07:20 +0800
commit6580bc1fb74d7c8f7aad73915260bb626b2aebd0 (patch)
treedf2e38c24ac19116de022739216b941bcb670b82 /www/cherokee-devel
parentb969e0b899ef6b76fc5bc2c98a9edc34a2e30b7f (diff)
downloadfreebsd-ports-gnome-6580bc1fb74d7c8f7aad73915260bb626b2aebd0.tar.gz
freebsd-ports-gnome-6580bc1fb74d7c8f7aad73915260bb626b2aebd0.tar.zst
freebsd-ports-gnome-6580bc1fb74d7c8f7aad73915260bb626b2aebd0.zip
- Update to 0.4.30
PR: ports/92013 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'www/cherokee-devel')
-rw-r--r--www/cherokee-devel/Makefile5
-rw-r--r--www/cherokee-devel/distinfo6
-rw-r--r--www/cherokee-devel/files/patch-Makefile.in14
-rw-r--r--www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c9
-rw-r--r--www/cherokee-devel/files/patch-cherokee-request.h11
-rw-r--r--www/cherokee-devel/pkg-plist6
6 files changed, 17 insertions, 34 deletions
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index eb7066748745..003ad8333bd3 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.4.29
-PORTREVISION= 1
+PORTVERSION= 0.4.30
CATEGORIES= www
MASTER_SITES= http://www.0x50.org/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION:R}/${PORTVERSION}
@@ -18,6 +17,7 @@ COMMENT= An extremely fast and flexible web server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= gnomehack gnometarget pkgconfig
+USE_GCC= 3.4+
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -51,6 +51,7 @@ PLIST_SUB+= PAM="@comment "
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|@mkdir_p@|${MKDIR} --|g'
+ @${REINPLACE_CMD} -e '/^if/s|==|=|g' ${WRKSRC}/configure
pre-build:
.for file in advanced.conf cherokee.conf mods-ssl sites-default sites-example
diff --git a/www/cherokee-devel/distinfo b/www/cherokee-devel/distinfo
index 186ad43fb628..6a443c77f48b 100644
--- a/www/cherokee-devel/distinfo
+++ b/www/cherokee-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (cherokee-0.4.29.tar.gz) = 854e6e61a69781746496012658d8ef98
-SHA256 (cherokee-0.4.29.tar.gz) = 7091536ef2a51d2548ac6268cc846dda9c37f7f7348597868c793f42b9be7d78
-SIZE (cherokee-0.4.29.tar.gz) = 1474498
+MD5 (cherokee-0.4.30.tar.gz) = bedcf9997928faeb550f54bc6621c13b
+SHA256 (cherokee-0.4.30.tar.gz) = 336cc7008fc2ee65d0f5f45892e3404e8d5b36a8b903358c45aa2ddc090bc71d
+SIZE (cherokee-0.4.30.tar.gz) = 1367424
diff --git a/www/cherokee-devel/files/patch-Makefile.in b/www/cherokee-devel/files/patch-Makefile.in
index 6f5e65d3c217..f1ef24f4b3e6 100644
--- a/www/cherokee-devel/files/patch-Makefile.in
+++ b/www/cherokee-devel/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig Thu Jul 7 23:03:20 2005
-+++ Makefile.in Tue Jul 12 01:18:30 2005
-@@ -305,7 +305,7 @@
+--- Makefile.in.orig Thu Jan 19 03:58:11 2006
++++ Makefile.in Thu Jan 19 14:01:55 2006
+@@ -314,7 +314,7 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@@ -9,7 +9,7 @@
bin_SCRIPTS = cherokee-config
SUFFIXES = .sample.pre .sample
-@@ -961,7 +961,7 @@
+@@ -978,7 +978,7 @@
.sample.pre.sample:
@@ -18,10 +18,10 @@
install-data-local-config:
@$(mkinstalldirs) $(DESTDIR)$(pkgincludedir);
-@@ -999,9 +999,6 @@
- echo "$@ will not overwrite existing $(cherokeeconfdir)/mime.conf"; \
+@@ -1021,9 +1021,6 @@
+ echo "$@ will not overwrite existing $(cherokeeconfdir)/mime.compression.types"; \
else \
- $(INSTALL_DATA) $(top_srcdir)/mime.conf.sample $(DESTDIR)$(cherokeeconfdir)/mime.conf; \
+ $(INSTALL_DATA) $(top_srcdir)/mime.compression.types.sample $(DESTDIR)$(cherokeeconfdir)/mime.compression.types; \
- fi
- @if test -d $(DESTDIR)$(sysconfdir)/pam.d && test ! -d $(DESTDIR)$(sysconfdir)/pam.d/cherokee ; then \
- $(INSTALL_DATA) $(top_srcdir)/pam.d_cherokee $(DESTDIR)$(sysconfdir)/pam.d/cherokee; \
diff --git a/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c b/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
index 9ea4d2c45b86..07ecb82c1bab 100644
--- a/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
+++ b/www/cherokee-devel/files/patch-cherokee-fdpoll-kqueue.c
@@ -8,12 +8,3 @@
#include <sys/event.h>
#include <sys/time.h>
#include <unistd.h>
-@@ -92,7 +93,7 @@
- */
- index = fdp->nchanges;
- if ( index > FDPOLL(fdp)->nfiles) {
-- PRINT_ERROR ("ERROR: Maximum number of fd exeeded\n");
-+ PRINT_ERROR_S ("ERROR: Maximum number of fd exeeded\n");
- return ret_error;
- }
- fdp->idx_fd_chlist[fd] = index;
diff --git a/www/cherokee-devel/files/patch-cherokee-request.h b/www/cherokee-devel/files/patch-cherokee-request.h
deleted file mode 100644
index ea45584c6dbf..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-request.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- cherokee/request.h.orig Tue Jun 28 01:25:32 2005
-+++ cherokee/request.h Sat Sep 17 21:22:39 2005
-@@ -25,6 +25,8 @@
- #ifndef CHEROKEE_REQUEST_H
- #define CHEROKEE_REQUEST_H
-
-+#include <sys/types.h>
-+
- #include "common.h"
- #include "url.h"
- #include "http.h"
diff --git a/www/cherokee-devel/pkg-plist b/www/cherokee-devel/pkg-plist
index c9881fe23a01..d9933fc61797 100644
--- a/www/cherokee-devel/pkg-plist
+++ b/www/cherokee-devel/pkg-plist
@@ -5,7 +5,8 @@ bin/cherokee_logrotate
etc/cherokee/advanced.conf
etc/cherokee/cherokee.conf
etc/cherokee/icons.conf
-etc/cherokee/mime.conf
+etc/cherokee/mime.compression.types
+etc/cherokee/mime.types
etc/cherokee/mods-available/admin
etc/cherokee/mods-available/ssl
etc/cherokee/sites-available/default
@@ -29,6 +30,7 @@ include/cherokee/list_merge_sort.h
include/cherokee/logger.h
include/cherokee/macros.h
include/cherokee/mime.h
+include/cherokee/mime_entry.h
include/cherokee/module.h
include/cherokee/module_loader.h
include/cherokee/nonce.h
@@ -129,8 +131,8 @@ share/aclocal/cherokee.m4
%%PORTDOCS%%%%DOCSDIR%%/cherokee.png
%%PORTDOCS%%%%DOCSDIR%%/index.html
www/images/cherokee-logo.png
+www/images/default-bg.png
www/images/powered_by_cherokee.png
-www/images/top-layer.png
www/index.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/icons