aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorgonzo <gonzo@FreeBSD.org>2017-12-04 13:44:24 +0800
committergonzo <gonzo@FreeBSD.org>2017-12-04 13:44:24 +0800
commita55fccd3f76dc358e1b2256bd63a71a367962ed4 (patch)
tree1b5455dfbff41a05c15c9a33dcc47f70a7db23e5 /www/chromium/Makefile
parent3eaa20e6892a91c1dfca0b2478d7f7895dc1a380 (diff)
downloadfreebsd-ports-gnome-a55fccd3f76dc358e1b2256bd63a71a367962ed4.tar.gz
freebsd-ports-gnome-a55fccd3f76dc358e1b2256bd63a71a367962ed4.tar.zst
freebsd-ports-gnome-a55fccd3f76dc358e1b2256bd63a71a367962ed4.zip
www/chromium: add support for USB U2F devices
Implement enough of chrome.hid API to make U2F security keys work. Due to FreeBSD's HID API limitations it's not possible to consistently report vedor id or product id values for HID devices so if javascript library relies on this information to detect supported keys it won't work, only report descriptor based detection works. Also by default uhid(4) devices accessible only to root user, current solution is to change /dev/uhidX node permission using devd. For example create /usr/local/etc/devd/yubi.conf with following content and restart devd: attach 20 { match "vendor" "0x1050"; action "/bin/chmod 766 /dev/$device-name"; }; Work on u2f-devd port is in progress (see PR). When done it will take care of maintaining devd rulesets for U2F devices. PR: 196754 Approved by: cpm
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index b7fa4f1a59ac..84ac2c2c1895 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= chromium
PORTVERSION= 61.0.3163.100
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}