aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2017-09-17 19:10:43 +0800
committercpm <cpm@FreeBSD.org>2017-09-17 19:10:43 +0800
commitba328f924693244580182b8656ccdacb1a4d01b8 (patch)
tree1bbf19adfa65f203d6dc4e226b48c372853bdb2d /www/chromium/Makefile
parent9c5c05f7978f034a003454b43edc88cb12085751 (diff)
downloadfreebsd-ports-gnome-ba328f924693244580182b8656ccdacb1a4d01b8.tar.gz
freebsd-ports-gnome-ba328f924693244580182b8656ccdacb1a4d01b8.tar.zst
freebsd-ports-gnome-ba328f924693244580182b8656ccdacb1a4d01b8.zip
www/chromium: update to 61.0.3163.79
- Add arm64 support [1] - Fix segfault on i386 [2] - Switch to USES=compiler:c++14-lang for devel/chromium-gn because chromium needs __builtin_add_overflow and friends to build. Changelog: https://chromium.googlesource.com/chromium/src/+log/60.0.3112.113..61.0.3163.79?pretty=fuller&n=10000 PR: 220291 [1], 221266 [2] Submitted by: Andrew [1] Reported by: Patrick <doctorwhoguy@gmail.com> [2] MFH: 2017Q3
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 0c4792da00ea..4dd19bf62ceb 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 60.0.3112.113
-PORTREVISION= 1
+PORTVERSION= 61.0.3163.79
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -62,11 +61,11 @@ LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher \
RUN_DEPENDS= xdg-open:devel/xdg-utils \
droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= aarch64 amd64 i386
.endif
.if defined(GN_ONLY)
-USES= compiler:c++11-lib ninja pkgconfig python:2,build shebangfix tar:xz
+USES= compiler:c++14-lang ninja pkgconfig python:2,build shebangfix tar:xz
.else
USES= bison cpe desktop-file-utils execinfo jpeg ninja perl5 pkgconfig \
python:2,build shebangfix tar:xz
@@ -201,6 +200,13 @@ MAKE_ENV+= C_INCLUDE_PATH=${LOCALBASE}/include \
# Work around base r261801
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100508
GN_ARGS+= extra_cxxflags="-D_LIBCPP_TRIVIAL_PAIR_COPY_CTOR=1"
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libc++-old
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libc++-new
+.endif
+
+.if ${ARCH} == aarch64
+GN_ARGS+= use_vulcanize=false
.endif
.if !defined(GN_ONLY)