aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2018-07-22 18:28:49 +0800
committercpm <cpm@FreeBSD.org>2018-07-22 18:28:49 +0800
commitdd58a310c74e357174b6604ab724ea296cf246a5 (patch)
tree029b1a5de0832499b90c4e4c54ec7bbff32684c1 /www/chromium/Makefile
parentb30535b46dd27a53117ecf7fd08a4f785c7b8eff (diff)
downloadfreebsd-ports-gnome-dd58a310c74e357174b6604ab724ea296cf246a5.tar.gz
freebsd-ports-gnome-dd58a310c74e357174b6604ab724ea296cf246a5.tar.zst
freebsd-ports-gnome-dd58a310c74e357174b6604ab724ea296cf246a5.zip
www/chromium: update to 67.0.3396.87
Changelog: https://chromium.googlesource.com/chromium/src/+log/65.0.3325.181..67.0.3396.87?pretty=fuller&n=10000 MFH: 2018Q3 Security: https://vuxml.freebsd.org/freebsd/36ff7a74-47b1-11e8-a7d6-54e1ad544088.html Security: https://vuxml.freebsd.org/freebsd/006bee4e-4c49-11e8-9c32-54ee754af08e.html Security: https://vuxml.freebsd.org/freebsd/e457978b-5484-11e8-9b85-54ee754af08e.html Security: https://vuxml.freebsd.org/freebsd/427b0f58-644c-11e8-9e1b-e8e0b747a45a.html Security: https://vuxml.freebsd.org/freebsd/4cb49a23-6c89-11e8-8b33-e8e0b747a45a.html
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index cdecd7234d7d..cf8ec63a1d3b 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 65.0.3325.181
-PORTREVISION= 6
+PORTVERSION= 67.0.3396.87
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -19,7 +18,8 @@ BUILD_DEPENDS= bash:shells/bash \
${PYTHON_PKGNAMEPREFIX}ply>0:devel/py-ply@${PY_FLAVOR} \
.if !defined(GN_ONLY)
-BUILD_DEPENDS+= gperf:devel/gperf \
+BUILD_DEPENDS+= git:devel/git \
+ gperf:devel/gperf \
yasm:devel/yasm \
ffmpeg>=3.2.2,1:multimedia/ffmpeg \
flock:sysutils/flock \
@@ -49,7 +49,6 @@ LIB_DEPENDS= libatk-bridge-2.0.so:accessibility/at-spi2-atk \
libpng.so:graphics/png \
libwebp.so:graphics/webp \
libavcodec.so:multimedia/ffmpeg \
- libvpx.so:multimedia/libvpx \
libopenh264.so:multimedia/openh264 \
libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz \
@@ -121,7 +120,6 @@ GN_ARGS+= clang_use_chrome_plugins=false \
use_system_freetype=true \
use_system_harfbuzz=true \
use_system_libjpeg=true \
- use_system_sqlite=false \
extra_cxxflags="-I${LOCALBASE}/include" \
extra_ldflags="-L${LOCALBASE}/lib"
# TODO: investigate building with these options:
@@ -243,7 +241,7 @@ pre-configure:
#./build/linux/unbundle/remove_bundled_libraries.py [list of preserved]
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${PYTHON_CMD} \
./build/linux/unbundle/replace_gn_files.py --system-libraries \
- ffmpeg flac freetype harfbuzz-ng libdrm libvpx libwebp libxml libxslt openh264 opus snappy yasm || ${FALSE}
+ ffmpeg flac freetype harfbuzz-ng libdrm libusb libwebp libxml libxslt openh264 opus snappy yasm || ${FALSE}
.endif
do-configure: