aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium/Makefile
diff options
context:
space:
mode:
authorcmt <cmt@FreeBSD.org>2016-04-10 03:53:29 +0800
committercmt <cmt@FreeBSD.org>2016-04-10 03:53:29 +0800
commite1df0c6753fa94f0080aeb96c61a3ef19e8a7cb8 (patch)
tree5091328aab903cd99e4e09850ca26b5e2b53425b /www/chromium/Makefile
parent19dc0e501916630ce6f7adfcc709c42995856459 (diff)
downloadfreebsd-ports-gnome-e1df0c6753fa94f0080aeb96c61a3ef19e8a7cb8.tar.gz
freebsd-ports-gnome-e1df0c6753fa94f0080aeb96c61a3ef19e8a7cb8.tar.zst
freebsd-ports-gnome-e1df0c6753fa94f0080aeb96c61a3ef19e8a7cb8.zip
Update chromium to 49.0.2623.112
while here, unbreak build on FreeBSD 9 Approved by: rene (mentor) MFH: 2016Q2
Diffstat (limited to 'www/chromium/Makefile')
-rw-r--r--www/chromium/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 828344f79a11..b004c95816e7 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= chromium
-PORTVERSION= 49.0.2623.110
-PORTREVISION= 1
+PORTVERSION= 49.0.2623.112
CATEGORIES= www
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # default, but needed to get distinfo correct if TEST is on
@@ -57,8 +56,19 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-pl
xdg-open:devel/xdg-utils
ONLY_FOR_ARCHS= i386 amd64
-USES= bison compiler:c++14-lang cpe desktop-file-utils execinfo jpeg \
+USES= bison cpe desktop-file-utils execinfo jpeg \
ninja perl5 pkgconfig python:2,build shebangfix tar:xz
+# chromium requires a recent compiler (C++11 capable, but clang 3.4 is
+# not able to build chromium. OTOH clang36 on FreeBSD 9.3 cannot build
+# chromium as the libc++ includes are not up to the task. USES flags
+# have to be set before bsd.ports.pre.mk and thereby cannot depend on
+# bsd.ports.pre.mk's variables, so I'm using a hack here.
+.if exists(/usr/lib/libc++.a)
+USES+= compiler:c++14-lang
+.else
+USES+= compiler:c++11-lib
+.endif
+
CPE_VENDOR= google
CPE_PRODUCT= chrome
USE_PERL5= build