aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-11-15 05:12:19 +0800
committerdinoex <dinoex@FreeBSD.org>2010-11-15 05:12:19 +0800
commit53c3ffd7c9e0ac9a1acf908e4ff2abca5aa062e8 (patch)
tree04a67bf8623342869b1c1d41339afa8fac425704 /www/chromium
parent3efd5c2bb4518a5b293b80a2bdf611f5f1b599bd (diff)
downloadfreebsd-ports-gnome-53c3ffd7c9e0ac9a1acf908e4ff2abca5aa062e8.tar.gz
freebsd-ports-gnome-53c3ffd7c9e0ac9a1acf908e4ff2abca5aa062e8.tar.zst
freebsd-ports-gnome-53c3ffd7c9e0ac9a1acf908e4ff2abca5aa062e8.zip
- forcing the port versions of gperf and flex
Submitted by: rubenbb (maintainer)
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 4f8cac40e8e9..026ec4cf815a 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -88,8 +88,6 @@ BUILDTYPE= Release
BUILDTYPE= Debug
.endif
-#pull newer flex and gperf in from ports
-MAKE_ENV+= PATH=${LOCALBASE}/bin:${PATH}
MAKE_ENV+= BUILDTYPE=${BUILDTYPE}
MAKE_JOBS_SAFE= yes
STRIP=
@@ -108,6 +106,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" \
${WRKSRC}/base/base.gypi \
${WRKSRC}/build/common.gypi \
+ ${WRKSRC}/third_party/ffmpeg/ffmpeg.gyp \
${WRKSRC}/third_party/icu/public/common/unicode/pfreebsd.h \
${WRKSRC}/third_party/tcmalloc/chromium/src/config_freebsd.h \
${WRKSRC}/third_party/WebKit/WebCore/plugins/PluginDatabase.cpp \
@@ -115,6 +114,13 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/gcc|${CC}|' \
${WRKSRC}/third_party/WebKit/WebCore/bindings/scripts/IDLParser.pm \
${WRKSRC}/third_party/WebKit/WebCore/dom/make_names.pl
+ @${REINPLACE_CMD} -e "s|'flex'|'${LOCALBASE}/bin/flex'|" \
+ ${WRKSRC}/third_party/angle/src/build_angle.gyp \
+ ${WRKSRC}/third_party/WebKit/WebCore/WebCore.gyp/scripts/action_maketokenizer.py
+ @${REINPLACE_CMD} -e 's|gperf --key-positions|${LOCALBASE}/bin/gperf --key-positions|' \
+ ${WRKSRC}/third_party/WebKit/WebCore/css/makeprop.pl \
+ ${WRKSRC}/third_party/WebKit/WebCore/css/makevalues.pl \
+ ${WRKSRC}/third_party/WebKit/WebCore/make-hash-tools.pl
do-configure:
cd ${WRKSRC} && \