aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2012-04-01 08:50:57 +0800
committerrene <rene@FreeBSD.org>2012-04-01 08:50:57 +0800
commitac5eec60f30cb0dd52839bce69a3bd2565e7e894 (patch)
treef8d57432a2934d98aed745189880deaea32e151e /www/chromium
parent7a3506b3c116546c20c946e7326e5cbb6a823f66 (diff)
downloadfreebsd-ports-gnome-ac5eec60f30cb0dd52839bce69a3bd2565e7e894.tar.gz
freebsd-ports-gnome-ac5eec60f30cb0dd52839bce69a3bd2565e7e894.tar.zst
freebsd-ports-gnome-ac5eec60f30cb0dd52839bce69a3bd2565e7e894.zip
Update to 18.0.1025.142
Note that clang is now the default compiler (GCC 4.6 is optionable), base GCC became too old. Submitted by: George Liaskos Security: http://www.vuxml.org/freebsd/b8f0a391-7910-11e1-8a43-00262d5ed8ee.html Feature safe: yes
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile13
-rw-r--r--www/chromium/distinfo4
-rw-r--r--www/chromium/files/patch-base__allocator__allocator.gyp68
-rw-r--r--www/chromium/files/patch-base__sys_byteorder.h20
-rw-r--r--www/chromium/files/patch-build__build_config.h12
-rw-r--r--www/chromium/files/patch-chrome__browser__extensions__process_map.cc11
-rw-r--r--www/chromium/files/patch-content__content_browser.gypi15
-rw-r--r--www/chromium/files/patch-content__renderer__media__media_stream_dependency_factory_stub.cc60
-rw-r--r--www/chromium/files/patch-content__renderer__media__media_stream_impl_stub.cc46
-rw-r--r--www/chromium/files/patch-content__renderer__pepper_plugin_delegate_impl.cc16
-rw-r--r--www/chromium/files/patch-crypto__encryptor.cc14
-rw-r--r--www/chromium/files/patch-ppapi__proxy__ppb_image_data_proxy.cc16
-rw-r--r--www/chromium/files/patch-ppapi__proxy__serialized_structs.h10
-rw-r--r--www/chromium/files/patch-third_party__WebKit__Source__JavaScriptCore__wtf__NumberOfCores.cpp10
-rw-r--r--www/chromium/files/patch-third_party__WebKit__Source__WebCore__WebCore.gyp__WebCore.gyp38
-rw-r--r--www/chromium/files/patch-third_party__WebKit__Source__WebKit__chromium__WebKit.gyp10
-rw-r--r--www/chromium/files/patch-third_party__libjingle__source__talk__base__timing.cc11
-rw-r--r--www/chromium/files/patch-third_party__libvpx__libvpx.gyp11
-rw-r--r--www/chromium/files/patch-tools__gyp__pylib__gyp__common.py11
-rw-r--r--www/chromium/pkg-plist4
20 files changed, 241 insertions, 159 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 61f73f1aafd9..a0d84a2679c2 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -7,7 +7,7 @@
PORTNAME= chromium
DISTVERSIONPREFIX= courgette-redacted-
-DISTVERSION= 17.0.963.83
+DISTVERSION= 18.0.1025.142
CATEGORIES= www
MASTER_SITES= http://download.goodking.org/downloads/ \
ftp://rene-ladan.nl/pub/distfiles/ \
@@ -20,6 +20,8 @@ COMMENT= A mostly BSD-licensed web browser based on WebKit and Gtk+
LICENSE= BSD LGPL21 MPL
LICENSE_COMB= multi
+CFLAGS+= -Wno-error
+
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
bash:${PORTSDIR}/shells/bash \
@@ -76,7 +78,7 @@ GYP_DEFINES+= use_cups=1 \
OPTIONS= CODECS "Compile and enable patented codecs like H.264" on \
GCONF "Use GConf2 for preferences" on \
PULSEAUDIO "Enable Pulse Audio support" off \
- CLANG "Build Chromium with Clang" off \
+ CLANG "Build Chromium with Clang" on \
GCC46 "Build Chromium with GCC 4.6+" off \
DEBUG "Compile with debug symbols and verbose output" off
@@ -113,6 +115,10 @@ GYP_DEFINES+= use_pulseaudio=0
GYP_DEFINES+= disable_sse2=1
.endif
+.if !defined(WITH_GCC46) && !defined(WITH_CLANG)
+IGNORE= does not compile with base gcc
+.endif
+
.if defined(WITH_GCC46) && defined(WITH_CLANG)
IGNORE= conflicting options (CLANG or GCC46)
.endif
@@ -173,8 +179,7 @@ post-patch:
${WRKSRC}/third_party/WebKit/Source/WebCore/bindings/scripts/IDLParser.pm \
${WRKSRC}/third_party/WebKit/Source/WebCore/dom/make_names.pl
@${REINPLACE_CMD} -e "s|'flex'|'${LOCALBASE}/bin/flex'|" \
- ${WRKSRC}/third_party/angle/src/build_angle.gyp \
- ${WRKSRC}/third_party/WebKit/Source/WebCore/WebCore.gyp/scripts/action_maketokenizer.py
+ ${WRKSRC}/third_party/angle/src/build_angle.gyp
@${REINPLACE_CMD} -e 's|gperf --key-positions|${LOCALBASE}/bin/gperf --key-positions|' \
${WRKSRC}/third_party/WebKit/Source/WebCore/css/makeprop.pl \
${WRKSRC}/third_party/WebKit/Source/WebCore/css/makevalues.pl \
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index 7196c6d665ad..ef70848870bc 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chromium-courgette-redacted-17.0.963.83.tar.xz) = c33e7c3ddfbc390c1ffabe8f647a755aa52c3956ac0122d586d5d902bba0608b
-SIZE (chromium-courgette-redacted-17.0.963.83.tar.xz) = 134278492
+SHA256 (chromium-courgette-redacted-18.0.1025.142.tar.xz) = 1185489497241a3563bfa89d0cbc6e49bca4c4ddbe2bdf8421bf66923edd5a77
+SIZE (chromium-courgette-redacted-18.0.1025.142.tar.xz) = 142470108
diff --git a/www/chromium/files/patch-base__allocator__allocator.gyp b/www/chromium/files/patch-base__allocator__allocator.gyp
index 623eea863dca..5c6a3bf493a3 100644
--- a/www/chromium/files/patch-base__allocator__allocator.gyp
+++ b/www/chromium/files/patch-base__allocator__allocator.gyp
@@ -1,6 +1,12 @@
---- base/allocator/allocator.gyp.orig 2012-01-05 10:01:52.000000000 +0200
-+++ base/allocator/allocator.gyp 2012-01-09 22:00:51.000000000 +0200
-@@ -7,326 +7,198 @@
+--- base/allocator/allocator.gyp.orig 2012-03-28 00:39:56.000000000 +0300
++++ base/allocator/allocator.gyp 2012-03-28 00:41:11.709398120 +0300
+@@ -1,4 +1,4 @@
+-# Copyright (c) 2012 The Chromium Authors. All rights reserved.
++# Copyright (c) 2009 The Chromium Authors. All rights reserved.
+ # Use of this source code is governed by a BSD-style license that can be
+ # found in the LICENSE file.
+
+@@ -7,331 +7,203 @@
'jemalloc_dir': '../../third_party/jemalloc/chromium',
'tcmalloc_dir': '../../third_party/tcmalloc/chromium',
},
@@ -8,6 +14,11 @@
- {
- 'target_name': 'allocator',
- 'type': 'static_library',
+- # Make sure the allocation library is optimized to
+- # the hilt in official builds.
+- 'variables': {
+- 'optimize': 'max',
+- },
- 'include_dirs': [
- '.',
- '<(tcmalloc_dir)/src/base',
@@ -301,6 +312,11 @@
+ {
+ 'target_name': 'allocator',
+ 'type': 'static_library',
++ # Make sure the allocation library is optimized to
++ # the hilt in official builds.
++ 'variables': {
++ 'optimize': 'max',
++ },
'include_dirs': [
- '<(tcmalloc_dir)/src/windows',
- ],
@@ -498,7 +514,7 @@
# jemalloc files
'<(jemalloc_dir)/jemalloc.c',
'<(jemalloc_dir)/jemalloc.h',
-@@ -334,85 +206,236 @@
+@@ -339,87 +211,238 @@
'<(jemalloc_dir)/qr.h',
'<(jemalloc_dir)/rb.h',
@@ -529,14 +545,18 @@
- ]},
- }],
- [ 'linux_use_debugallocation==1', {
-+ # sources! means that these are not compiled directly.
- 'sources!': [
+- 'sources!': [
- # debugallocation.cc #includes tcmalloc.cc,
- # so only one of them should be used.
- '<(tcmalloc_dir)/src/tcmalloc.cc',
- ],
-- 'cflags': [
-- '-DTCMALLOC_FOR_DEBUGALLOCATION',
+- 'defines': [
+- 'TCMALLOC_FOR_DEBUGALLOCATION',
+- ],
+- }, { # linux_use_debugallocation != 1
++ # sources! means that these are not compiled directly.
+ 'sources!': [
+- '<(tcmalloc_dir)/src/debugallocation.cc',
+ # Included by allocator_shim.cc for maximal inlining.
+ 'generic_allocators.cc',
+ 'win_allocator.cc',
@@ -598,18 +618,17 @@
+ '<(tcmalloc_dir)/src/windows/preamble_patcher.h',
+ '<(tcmalloc_dir)/src/windows/preamble_patcher_with_stub.cc',
],
-- }, { # linux_use_debugallocation != 1
-- 'sources!': [
-- '<(tcmalloc_dir)/src/debugallocation.cc',
-+ 'dependencies': [
-+ '../third_party/dynamic_annotations/dynamic_annotations.gyp:dynamic_annotations',
- ],
- }],
- [ 'linux_keep_shadow_stacks==1', {
- 'sources': [
- '<(tcmalloc_dir)/src/linux_shadow_stacks.cc',
- '<(tcmalloc_dir)/src/linux_shadow_stacks.h',
- '<(tcmalloc_dir)/src/stacktrace_shadow-inl.h',
++ 'dependencies': [
++ '../third_party/dynamic_annotations/dynamic_annotations.gyp:dynamic_annotations',
+ ],
+- 'cflags': [
+- '-finstrument-functions',
+ 'msvs_settings': {
+ # TODO(sgk): merge this with build/common.gypi settings
+ 'VCLibrarianTool': {
@@ -718,8 +737,8 @@
+ # so only one of them should be used.
+ '<(tcmalloc_dir)/src/tcmalloc.cc',
+ ],
-+ 'cflags': [
-+ '-DTCMALLOC_FOR_DEBUGALLOCATION',
++ 'defines': [
++ 'TCMALLOC_FOR_DEBUGALLOCATION',
+ ],
+ }, { # linux_use_debugallocation != 1
+ 'sources!': [
@@ -734,7 +753,9 @@
+ ],
+ 'cflags': [
+ '-finstrument-functions',
-+ '-DKEEP_SHADOW_STACKS',
++ ],
++ 'defines': [
++ 'KEEP_SHADOW_STACKS',
+ ],
+ }],
+ [ 'linux_use_heapchecker==0', {
@@ -744,14 +765,13 @@
+ '<(tcmalloc_dir)/src/heap-checker.cc',
+ ],
+ # Disable the heap checker in tcmalloc.
-+ 'cflags': [
-+ '-DNO_HEAP_CHECK',
++ 'defines': [
++ 'NO_HEAP_CHECK',
+ ],
+ }],
],
-- 'cflags': [
-- '-finstrument-functions',
-- '-DKEEP_SHADOW_STACKS',
+- 'defines': [
+- 'KEEP_SHADOW_STACKS',
+ },
+ {
+ 'target_name': 'allocator_unittests',
@@ -773,8 +793,8 @@
+ '../..',
],
- # Disable the heap checker in tcmalloc.
-- 'cflags': [
-- '-DNO_HEAP_CHECK',
+- 'defines': [
+- 'NO_HEAP_CHECK',
+ 'sources': [
+ 'allocator_unittests.cc',
],
diff --git a/www/chromium/files/patch-base__sys_byteorder.h b/www/chromium/files/patch-base__sys_byteorder.h
new file mode 100644
index 000000000000..deb765325ecf
--- /dev/null
+++ b/www/chromium/files/patch-base__sys_byteorder.h
@@ -0,0 +1,20 @@
+--- base/sys_byteorder.h.orig 2012-03-30 01:34:16.000000000 +0300
++++ base/sys_byteorder.h 2012-03-30 01:35:48.000000000 +0300
+@@ -27,7 +27,7 @@
+ #include <stdlib.h>
+ #elif defined(OS_MACOSX)
+ #include <libkern/OSByteOrder.h>
+-#elif defined(OS_OPENBSD)
++#elif defined(OS_OPENBSD) || defined(OS_FREEBSD)
+ #include <sys/endian.h>
+ #else
+ #include <byteswap.h>
+@@ -44,6 +44,8 @@
+ return OSSwapInt64(x);
+ #elif defined(OS_OPENBSD)
+ return swap64(x);
++#elif defined(OS_FREEBSD)
++ return bswap64(x);
+ #else
+ return bswap_64(x);
+ #endif
diff --git a/www/chromium/files/patch-build__build_config.h b/www/chromium/files/patch-build__build_config.h
index 1cc471d2a17f..ef749158c6da 100644
--- a/www/chromium/files/patch-build__build_config.h
+++ b/www/chromium/files/patch-build__build_config.h
@@ -1,6 +1,6 @@
---- ./build/build_config.h.orig 2010-12-16 02:11:47.000000000 +0100
-+++ ./build/build_config.h 2010-12-20 20:15:08.000000000 +0100
-@@ -69,12 +69,12 @@
+--- build/build_config.h.orig 2012-03-24 09:01:53.000000000 +0200
++++ build/build_config.h 2012-03-28 00:55:12.000000000 +0300
+@@ -67,7 +67,7 @@
#endif
// Use tcmalloc
@@ -9,9 +9,3 @@
#define USE_TCMALLOC 1
#endif
- // Use heapchecker.
--#if defined(OS_LINUX) && !defined(NO_HEAPCHECKER)
-+#if (defined(OS_LINUX) || defined(OS_FREEBSD)) && !defined(NO_HEAPCHECKER)
- #define USE_HEAPCHECKER 1
- #endif
-
diff --git a/www/chromium/files/patch-chrome__browser__extensions__process_map.cc b/www/chromium/files/patch-chrome__browser__extensions__process_map.cc
deleted file mode 100644
index 66c9cff41152..000000000000
--- a/www/chromium/files/patch-chrome__browser__extensions__process_map.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- chrome/browser/extensions/process_map.cc.orig 2012-01-31 21:06:11.000000000 +0200
-+++ chrome/browser/extensions/process_map.cc 2012-01-31 21:06:50.000000000 +0200
-@@ -11,7 +11,7 @@
- Item() {
- }
-
-- explicit Item(const ProcessMap::Item& other)
-+ Item(const ProcessMap::Item& other)
- : extension_id(other.extension_id),
- process_id(other.process_id),
- site_instance_id(other.site_instance_id) {
diff --git a/www/chromium/files/patch-content__content_browser.gypi b/www/chromium/files/patch-content__content_browser.gypi
deleted file mode 100644
index dc833cdbf4e2..000000000000
--- a/www/chromium/files/patch-content__content_browser.gypi
+++ /dev/null
@@ -1,15 +0,0 @@
---- content/content_browser.gypi.orig 2011-11-01 10:42:35.000000000 +0200
-+++ content/content_browser.gypi 2011-11-21 21:36:39.000000000 +0200
-@@ -625,6 +625,12 @@
- '../views/views.gyp:views',
- ],
- }],
-+ ['OS=="freebsd" or OS=="openbsd"', {
-+ 'sources/': [
-+ ['exclude', '^browser/geolocation/wifi_data_provider_linux.cc'],
-+ ['exclude', '^browser/geolocation/wifi_data_provider_linux.h'],
-+ ]
-+ }],
- ['OS=="mac"', {
- 'sources!': [
- 'browser/power_save_blocker_stub.cc',
diff --git a/www/chromium/files/patch-content__renderer__media__media_stream_dependency_factory_stub.cc b/www/chromium/files/patch-content__renderer__media__media_stream_dependency_factory_stub.cc
new file mode 100644
index 000000000000..e51a81ed864d
--- /dev/null
+++ b/www/chromium/files/patch-content__renderer__media__media_stream_dependency_factory_stub.cc
@@ -0,0 +1,60 @@
+--- content/renderer/media/media_stream_dependency_factory_stub.cc.orig 2012-04-01 01:08:09.000000000 +0300
++++ content/renderer/media/media_stream_dependency_factory_stub.cc 2012-04-01 01:09:34.000000000 +0300
+@@ -8,34 +8,40 @@
+
+ MediaStreamDependencyFactory::~MediaStreamDependencyFactory() {}
+
+-cricket::WebRtcMediaEngine*
+-MediaStreamDependencyFactory::CreateWebRtcMediaEngine() {
+- return NULL;
+-}
+-
+ bool MediaStreamDependencyFactory::CreatePeerConnectionFactory(
+- cricket::MediaEngineInterface* media_engine,
+- talk_base::Thread* worker_thread) {
++ talk_base::Thread* worker_thread,
++ talk_base::Thread* signaling_thread,
++ content::P2PSocketDispatcher* socket_dispatcher,
++ talk_base::NetworkManager* network_manager,
++ talk_base::PacketSocketFactory* socket_factory) {
+ return false;
+ }
+
+-void MediaStreamDependencyFactory::DeletePeerConnectionFactory() {
+-}
++void MediaStreamDependencyFactory::ReleasePeerConnectionFactory() {}
+
+ bool MediaStreamDependencyFactory::PeerConnectionFactoryCreated() {
+ return false;
+ }
+
+-cricket::PortAllocator* MediaStreamDependencyFactory::CreatePortAllocator(
+- content::P2PSocketDispatcher* socket_dispatcher,
+- talk_base::NetworkManager* network_manager,
+- talk_base::PacketSocketFactory* socket_factory,
+- const webkit_glue::P2PTransport::Config& config) {
++talk_base::scoped_refptr<webrtc::PeerConnectionInterface>
++ MediaStreamDependencyFactory::CreatePeerConnection(const std::string& config,
++ webrtc::PeerConnectionObserver* observer) {
++ return NULL;
++}
++
++talk_base::scoped_refptr<webrtc::LocalMediaStreamInterface>
++ MediaStreamDependencyFactory::CreateLocalMediaStream(const std::string& label) {
++ return NULL;
++}
++
++talk_base::scoped_refptr<webrtc::LocalVideoTrackInterface>
++ MediaStreamDependencyFactory::CreateLocalVideoTrack(const std::string& label,
++ cricket::VideoCapturer* video_device) {
+ return NULL;
+ }
+
+-webrtc::PeerConnection* MediaStreamDependencyFactory::CreatePeerConnection(
+- cricket::PortAllocator* port_allocator,
+- talk_base::Thread* signaling_thread) {
++talk_base::scoped_refptr<webrtc::LocalAudioTrackInterface>
++ MediaStreamDependencyFactory::CreateLocalAudioTrack(const std::string& label,
++ webrtc::AudioDeviceModule* audio_device) {
+ return NULL;
+ }
diff --git a/www/chromium/files/patch-content__renderer__media__media_stream_impl_stub.cc b/www/chromium/files/patch-content__renderer__media__media_stream_impl_stub.cc
new file mode 100644
index 000000000000..47efade88f19
--- /dev/null
+++ b/www/chromium/files/patch-content__renderer__media__media_stream_impl_stub.cc
@@ -0,0 +1,46 @@
+--- content/renderer/media/media_stream_impl_stub.cc.orig 2012-04-01 01:08:49.000000000 +0300
++++ content/renderer/media/media_stream_impl_stub.cc 2012-04-01 01:09:17.000000000 +0300
+@@ -16,7 +16,6 @@
+ MediaStreamDependencyFactory* dependency_factory)
+ : dependency_factory_(dependency_factory),
+ media_stream_dispatcher_(media_stream_dispatcher),
+- media_engine_(NULL),
+ p2p_socket_dispatcher_(p2p_socket_dispatcher),
+ network_manager_(NULL),
+ vc_manager_(vc_manager),
+@@ -24,14 +23,11 @@
+ message_loop_proxy_(base::MessageLoopProxy::current()),
+ signaling_thread_(NULL),
+ worker_thread_(NULL),
+- chrome_worker_thread_("Chrome_libJingle_WorkerThread"),
+- vcm_created_(false) {
++ chrome_worker_thread_("Chrome_libJingle_WorkerThread") {
+ }
+
+ MediaStreamImpl::~MediaStreamImpl() {
+ DCHECK(!peer_connection_handler_);
+- if (dependency_factory_.get())
+- dependency_factory_->DeletePeerConnectionFactory();
+ }
+
+ WebKit::WebPeerConnectionHandler* MediaStreamImpl::CreatePeerConnectionHandler(
+@@ -42,10 +38,6 @@
+ void MediaStreamImpl::ClosePeerConnection() {
+ }
+
+-bool MediaStreamImpl::SetVideoCaptureModule(const std::string& label) {
+- return false;
+-}
+-
+ void MediaStreamImpl::requestUserMedia(
+ const WebKit::WebUserMediaRequest& user_media_request,
+ const WebKit::WebVector<WebKit::WebMediaStreamSource>&
+@@ -96,3 +88,8 @@
+
+ void MediaStreamImpl::OnDeviceOpenFailed(int request_id) {
+ }
++
++webrtc::MediaStreamTrackInterface* MediaStreamImpl::GetLocalMediaStreamTrack(
++ const std::string& label) {
++ return NULL;
++}
diff --git a/www/chromium/files/patch-content__renderer__pepper_plugin_delegate_impl.cc b/www/chromium/files/patch-content__renderer__pepper_plugin_delegate_impl.cc
index 30d9fc55bc7e..aaa3789e5ef2 100644
--- a/www/chromium/files/patch-content__renderer__pepper_plugin_delegate_impl.cc
+++ b/www/chromium/files/patch-content__renderer__pepper_plugin_delegate_impl.cc
@@ -1,6 +1,6 @@
---- content/renderer/pepper_plugin_delegate_impl.cc.orig 2011-05-06 12:02:55.000000000 +0300
-+++ content/renderer/pepper_plugin_delegate_impl.cc 2011-06-04 14:31:17.879380898 +0300
-@@ -112,7 +112,7 @@
+--- content/renderer/pepper_plugin_delegate_impl.cc.orig 2012-02-21 10:34:09.000000000 +0200
++++ content/renderer/pepper_plugin_delegate_impl.cc 2012-02-27 18:05:36.000000000 +0200
+@@ -124,7 +124,7 @@
dib_(dib) {
}
@@ -9,16 +9,16 @@
// On Mac, we have to tell the browser to free the transport DIB.
virtual ~PlatformImage2DImpl() {
if (dib_.get()) {
-@@ -130,7 +130,7 @@
+@@ -142,7 +142,7 @@
*byte_count = dib_->size();
#if defined(OS_WIN)
return reinterpret_cast<intptr_t>(dib_->handle());
--#elif defined(OS_MACOSX)
-+#elif defined(OS_MACOSX) || defined(OS_FREEBSD)
+-#elif defined(OS_MACOSX) || defined(OS_ANDROID)
++#elif defined(OS_MACOSX) || defined(OS_ANDROID) || defined(OS_FREEBSD)
return static_cast<intptr_t>(dib_->handle().fd);
- #elif defined(OS_LINUX)
+ #elif defined(OS_POSIX)
return static_cast<intptr_t>(dib_->handle());
-@@ -758,7 +758,7 @@
+@@ -1208,7 +1208,7 @@
uint32 buffer_size = width * height * 4;
// Allocate the transport DIB and the PlatformCanvas pointing to it.
diff --git a/www/chromium/files/patch-crypto__encryptor.cc b/www/chromium/files/patch-crypto__encryptor.cc
deleted file mode 100644
index fb552ab688c6..000000000000
--- a/www/chromium/files/patch-crypto__encryptor.cc
+++ /dev/null
@@ -1,14 +0,0 @@
---- crypto/encryptor.cc.orig 2012-01-18 11:11:42.000000000 +0200
-+++ crypto/encryptor.cc 2012-01-29 17:11:33.000000000 +0200
-@@ -13,6 +13,11 @@
- #define bswap_16(x) _byteswap_ushort(x)
- #define bswap_32(x) _byteswap_ulong(x)
- #define bswap_64(x) _byteswap_uint64(x)
-+#elif defined(OS_FREEBSD)
-+#include <sys/endian.h>
-+#define bswap_16(x) bswap16(x)
-+#define bswap_32(x) bswap32(x)
-+#define bswap_64(x) bswap64(x)
- #elif defined(OS_MACOSX)
- #include <libkern/OSByteOrder.h>
- #define bswap_16(x) OSSwapInt16(x)
diff --git a/www/chromium/files/patch-ppapi__proxy__ppb_image_data_proxy.cc b/www/chromium/files/patch-ppapi__proxy__ppb_image_data_proxy.cc
index b4f7bd82abae..d6143a0557e6 100644
--- a/www/chromium/files/patch-ppapi__proxy__ppb_image_data_proxy.cc
+++ b/www/chromium/files/patch-ppapi__proxy__ppb_image_data_proxy.cc
@@ -1,20 +1,20 @@
---- ppapi/proxy/ppb_image_data_proxy.cc.orig 2011-06-28 23:59:12.540806582 +0300
-+++ ppapi/proxy/ppb_image_data_proxy.cc 2011-06-28 23:59:15.075806980 +0300
-@@ -111,7 +111,7 @@
+--- ppapi/proxy/ppb_image_data_proxy.cc.orig 2012-02-21 10:34:02.000000000 +0200
++++ ppapi/proxy/ppb_image_data_proxy.cc 2012-02-27 18:16:23.000000000 +0200
+@@ -83,7 +83,7 @@
#if defined(OS_WIN)
const ImageHandle ImageData::NullHandle = NULL;
--#elif defined(OS_MACOSX)
-+#elif defined(OS_MACOSX) || defined(OS_FREEBSD)
+-#elif defined(OS_MACOSX) || defined(OS_ANDROID)
++#elif defined(OS_MACOSX) || defined(OS_ANDROID) || defined(OS_FREEBSD)
const ImageHandle ImageData::NullHandle = ImageHandle();
#else
const ImageHandle ImageData::NullHandle = 0;
-@@ -120,7 +120,7 @@
+@@ -92,7 +92,7 @@
ImageHandle ImageData::HandleFromInt(int32_t i) {
#if defined(OS_WIN)
return reinterpret_cast<ImageHandle>(i);
--#elif defined(OS_MACOSX)
-+#elif defined(OS_MACOSX) || defined(OS_FREEBSD)
+-#elif defined(OS_MACOSX) || defined(OS_ANDROID)
++#elif defined(OS_MACOSX) || defined(OS_ANDROID) || defined(OS_FREEBSD)
return ImageHandle(i, false);
#else
return static_cast<ImageHandle>(i);
diff --git a/www/chromium/files/patch-ppapi__proxy__serialized_structs.h b/www/chromium/files/patch-ppapi__proxy__serialized_structs.h
index e23ca7e4adf1..e4f62d5ec8e7 100644
--- a/www/chromium/files/patch-ppapi__proxy__serialized_structs.h
+++ b/www/chromium/files/patch-ppapi__proxy__serialized_structs.h
@@ -1,11 +1,11 @@
---- ppapi/proxy/serialized_structs.h.orig 2011-06-27 23:46:48.860441060 +0300
-+++ ppapi/proxy/serialized_structs.h 2011-06-27 23:46:52.210441968 +0300
-@@ -115,7 +115,7 @@
+--- ppapi/proxy/serialized_structs.h.orig 2012-02-21 10:34:02.000000000 +0200
++++ ppapi/proxy/serialized_structs.h 2012-02-27 18:19:15.000000000 +0200
+@@ -111,7 +111,7 @@
#if defined(OS_WIN)
typedef HANDLE ImageHandle;
--#elif defined(OS_MACOSX)
-+#elif defined(OS_MACOSX) || defined(OS_FREEBSD)
+-#elif defined(OS_MACOSX) || defined(OS_ANDROID)
++#elif defined(OS_MACOSX) || defined(OS_ANDROID) || defined(OS_FREEBSD)
typedef base::SharedMemoryHandle ImageHandle;
#else
// On X Windows this is a SysV shared memory key.
diff --git a/www/chromium/files/patch-third_party__WebKit__Source__JavaScriptCore__wtf__NumberOfCores.cpp b/www/chromium/files/patch-third_party__WebKit__Source__JavaScriptCore__wtf__NumberOfCores.cpp
new file mode 100644
index 000000000000..65a1083395a2
--- /dev/null
+++ b/www/chromium/files/patch-third_party__WebKit__Source__JavaScriptCore__wtf__NumberOfCores.cpp
@@ -0,0 +1,10 @@
+--- third_party/WebKit/Source/JavaScriptCore/wtf/NumberOfCores.cpp.orig 2012-03-31 03:21:08.000000000 +0300
++++ third_party/WebKit/Source/JavaScriptCore/wtf/NumberOfCores.cpp 2012-03-31 03:21:30.000000000 +0300
+@@ -27,6 +27,7 @@
+ #include "NumberOfCores.h"
+
+ #if OS(DARWIN) || OS(OPENBSD) || OS(NETBSD) || OS(FREEBSD)
++#include <unistd.h>
+ #include <sys/sysctl.h>
+ #include <sys/types.h>
+ #elif OS(LINUX) || OS(AIX) || OS(SOLARIS)
diff --git a/www/chromium/files/patch-third_party__WebKit__Source__WebCore__WebCore.gyp__WebCore.gyp b/www/chromium/files/patch-third_party__WebKit__Source__WebCore__WebCore.gyp__WebCore.gyp
deleted file mode 100644
index fec554072c31..000000000000
--- a/www/chromium/files/patch-third_party__WebKit__Source__WebCore__WebCore.gyp__WebCore.gyp
+++ /dev/null
@@ -1,38 +0,0 @@
---- third_party/WebKit/Source/WebCore/WebCore.gyp/WebCore.gyp.orig 2011-07-19 20:25:57.839631432 +0300
-+++ third_party/WebKit/Source/WebCore/WebCore.gyp/WebCore.gyp 2011-07-19 20:26:53.497910347 +0300
-@@ -986,7 +986,7 @@
- 'include_dirs+++': ['../dom'],
- },
- }],
-- ['(OS=="linux" or OS=="win") and "WTF_USE_WEBAUDIO_FFTW=1" in feature_defines', {
-+ ['(OS=="linux" or OS=="freebsd" or OS=="win") and "WTF_USE_WEBAUDIO_FFTW=1" in feature_defines', {
- 'include_dirs': [
- '<(chromium_src_dir)/third_party/fftw/api',
- ],
-@@ -1194,7 +1194,7 @@
- 'include_dirs++': ['../dom'],
- },
- }],
-- ['(OS=="linux" or OS=="win") and "WTF_USE_WEBAUDIO_FFTW=1" in feature_defines', {
-+ ['(OS=="linux" or OS=="freebsd" or OS=="win") and "WTF_USE_WEBAUDIO_FFTW=1" in feature_defines', {
- # This directory needs to be on the include path for multiple sub-targets of webcore.
- 'direct_dependent_settings': {
- 'include_dirs': [
-@@ -1202,7 +1202,7 @@
- ],
- },
- }],
-- ['(OS=="mac" or OS=="linux" or OS=="win") and "WTF_USE_WEBAUDIO_FFMPEG=1" in feature_defines', {
-+ ['(OS=="mac" or OS=="linux" or OS=="freebsd" or OS=="win") and "WTF_USE_WEBAUDIO_FFMPEG=1" in feature_defines', {
- # This directory needs to be on the include path for multiple sub-targets of webcore.
- 'direct_dependent_settings': {
- 'include_dirs': [
-@@ -1708,7 +1708,7 @@
- 'include_dirs+++': ['../dom'],
- },
- }],
-- ['OS=="linux" and "WTF_USE_WEBAUDIO_FFTW=1" in feature_defines', {
-+ ['OS=="linux" or OS=="freebsd" and "WTF_USE_WEBAUDIO_FFTW=1" in feature_defines', {
- # FIXME: (kbr) figure out how to make these dependencies
- # work in a cross-platform way. Attempts to use
- # "link_settings" and "libraries" in conjunction with the
diff --git a/www/chromium/files/patch-third_party__WebKit__Source__WebKit__chromium__WebKit.gyp b/www/chromium/files/patch-third_party__WebKit__Source__WebKit__chromium__WebKit.gyp
deleted file mode 100644
index 1ea0497950da..000000000000
--- a/www/chromium/files/patch-third_party__WebKit__Source__WebKit__chromium__WebKit.gyp
+++ /dev/null
@@ -1,10 +0,0 @@
---- third_party/WebKit/Source/WebKit/chromium/WebKit.gyp.orig 2011-09-15 00:29:43.000000000 +0300
-+++ third_party/WebKit/Source/WebKit/chromium/WebKit.gyp 2011-09-15 00:30:28.000000000 +0300
-@@ -1142,6 +1142,7 @@
- ],
- 'include_dirs': [
- '<(chromium_src_dir)',
-+ '<(prefix_dir)/include',
- '../../../Tools/DumpRenderTree/TestNetscapePlugIn',
- '../../../Tools/DumpRenderTree/chromium/TestNetscapePlugIn/ForwardingHeaders',
- ],
diff --git a/www/chromium/files/patch-third_party__libjingle__source__talk__base__timing.cc b/www/chromium/files/patch-third_party__libjingle__source__talk__base__timing.cc
new file mode 100644
index 000000000000..78e22bf01ada
--- /dev/null
+++ b/www/chromium/files/patch-third_party__libjingle__source__talk__base__timing.cc
@@ -0,0 +1,11 @@
+--- third_party/libjingle/source/talk/base/timing.cc.orig 2012-03-27 04:04:08.000000000 +0300
++++ third_party/libjingle/source/talk/base/timing.cc 2012-03-31 03:18:25.000000000 +0300
+@@ -27,7 +27,7 @@
+
+ #include "talk/base/timing.h"
+
+-#if defined(POSIX)
++#if defined(POSIX) && !defined(FREEBSD)
+ #define _POSIX_C_SOURCE 199506L
+ #endif
+
diff --git a/www/chromium/files/patch-third_party__libvpx__libvpx.gyp b/www/chromium/files/patch-third_party__libvpx__libvpx.gyp
deleted file mode 100644
index f98fffd89d02..000000000000
--- a/www/chromium/files/patch-third_party__libvpx__libvpx.gyp
+++ /dev/null
@@ -1,11 +0,0 @@
---- third_party/libvpx/libvpx.gyp.orig 2012-01-29 21:54:54.000000000 +0200
-+++ third_party/libvpx/libvpx.gyp 2012-01-29 21:55:14.000000000 +0200
-@@ -13,7 +13,7 @@
- ],
- },
- 'conditions': [
-- [ '(OS=="linux" or OS=="mac" or OS=="win") and target_arch!="arm"', {
-+ [ '(OS=="linux" or OS=="freebsd" or OS=="mac" or OS=="win") and target_arch!="arm"', {
- 'targets': [
- {
- # This libvpx target contains both encoder and decoder.
diff --git a/www/chromium/files/patch-tools__gyp__pylib__gyp__common.py b/www/chromium/files/patch-tools__gyp__pylib__gyp__common.py
new file mode 100644
index 000000000000..13bc9f1a6961
--- /dev/null
+++ b/www/chromium/files/patch-tools__gyp__pylib__gyp__common.py
@@ -0,0 +1,11 @@
+--- tools/gyp/pylib/gyp/common.py.orig 2012-03-30 01:29:20.000000000 +0300
++++ tools/gyp/pylib/gyp/common.py 2012-03-30 01:29:48.000000000 +0300
+@@ -353,6 +353,8 @@
+ 'sunos5': 'solaris',
+ 'freebsd7': 'freebsd',
+ 'freebsd8': 'freebsd',
++ 'freebsd9': 'freebsd',
++ 'freebsd10': 'freebsd',
+ }
+ flavor = flavors.get(sys.platform, 'linux')
+ return params.get('flavor', flavor)
diff --git a/www/chromium/pkg-plist b/www/chromium/pkg-plist
index 54cd5fea81ee..6de15d3c6032 100644
--- a/www/chromium/pkg-plist
+++ b/www/chromium/pkg-plist
@@ -35,6 +35,7 @@ bin/chrome
%%DATADIR%%/locales/lv.pak
%%DATADIR%%/locales/ml.pak
%%DATADIR%%/locales/mr.pak
+%%DATADIR%%/locales/ms.pak
%%DATADIR%%/locales/nb.pak
%%DATADIR%%/locales/nl.pak
%%DATADIR%%/locales/pl.pak
@@ -87,6 +88,7 @@ bin/chrome
%%DATADIR%%/resources/inspector/Images/disclosureTriangleSmallRightDownBlack.png
%%DATADIR%%/resources/inspector/Images/disclosureTriangleSmallRightDownWhite.png
%%DATADIR%%/resources/inspector/Images/disclosureTriangleSmallRightWhite.png
+%%DATADIR%%/resources/inspector/Images/domain.png
%%DATADIR%%/resources/inspector/Images/errorIcon.png
%%DATADIR%%/resources/inspector/Images/errorMediumIcon.png
%%DATADIR%%/resources/inspector/Images/errorRedDot.png
@@ -222,6 +224,8 @@ bin/chrome
%%DATADIR%%/resources/inspector/profilesPanel.css
%%DATADIR%%/resources/inspector/auditsPanel.css
%%DATADIR%%/resources/inspector/timelinePanel.css
+%%DATADIR%%/resources/inspector/tabbedPane.css
+%%DATADIR%%/resources/inspector/filteredItemSelectionDialog.css
%%DATADIR%%/resources/inspector/scriptsPanel.css
%%DATADIR%%/resources/inspector/dataGrid.css
%%DATADIR%%/resources/inspector/inspectorCommon.css