aboutsummaryrefslogtreecommitdiffstats
path: root/www/chromium
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2011-11-13 19:50:40 +0800
committerrene <rene@FreeBSD.org>2011-11-13 19:50:40 +0800
commitaef0e65e6a0b093433ca8cef799b88bb481d9ae7 (patch)
tree17cddcacbf04f5552d15972ba008776f62249d20 /www/chromium
parentcc050f83ac1f5376b03594aed2e17814e729d64b (diff)
downloadfreebsd-ports-gnome-aef0e65e6a0b093433ca8cef799b88bb481d9ae7.tar.gz
freebsd-ports-gnome-aef0e65e6a0b093433ca8cef799b88bb481d9ae7.tar.zst
freebsd-ports-gnome-aef0e65e6a0b093433ca8cef799b88bb481d9ae7.zip
Optionally use GCC 4.6 instead of GCC 4.5, the latter is disconnected from
Mk/bsd.gcc.mk Prodded by: gerald Feature safe: yes
Diffstat (limited to 'www/chromium')
-rw-r--r--www/chromium/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index ed1af88dee41..f8c69e21b7b3 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -79,12 +79,12 @@ OPTIONS= CODECS "Compile and enable patented codecs like H.264" on \
GCONF "Use GConf2 for preferences" on \
PULSE "Enable Pulse Audio support" off \
CLANG "Build Chromium with Clang" off \
- GCC45 "Build Chromium with GCC 4.5+" off \
+ GCC46 "Build Chromium with GCC 4.6+" off \
DEBUG "Compile with debug symbols and verbose output" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900033 || defined(WITH_GCC45)
+.if ${OSVERSION} < 900033 || defined(WITH_GCC46)
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
@@ -121,12 +121,12 @@ GYP_DEFINES+= use_pulseaudio=0
GYP_DEFINES+= disable_sse2=1
.endif
-.if defined(WITH_GCC45) && defined(WITH_CLANG)
-IGNORE= conflicting options (CLANG or GCC45)
+.if defined(WITH_GCC46) && defined(WITH_CLANG)
+IGNORE= conflicting options (CLANG or GCC46)
.endif
-.if defined(WITH_GCC45)
-USE_GCC?= 4.5+
+.if defined(WITH_GCC46)
+USE_GCC?= 4.6+
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gcc
.endif