aboutsummaryrefslogtreecommitdiffstats
path: root/www/crawl
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2003-05-05 11:16:00 +0800
committerpetef <petef@FreeBSD.org>2003-05-05 11:16:00 +0800
commit239cb628473b6926d7ab82c799cf82d00d35a880 (patch)
treeba36ab80ca2e0417d63de06ad078d9113bde4747 /www/crawl
parent509d3d0a234772dc2fcb5a0ae7ca468f045cab5a (diff)
downloadfreebsd-ports-gnome-239cb628473b6926d7ab82c799cf82d00d35a880.tar.gz
freebsd-ports-gnome-239cb628473b6926d7ab82c799cf82d00d35a880.tar.zst
freebsd-ports-gnome-239cb628473b6926d7ab82c799cf82d00d35a880.zip
- fix build on -current
- no longer need to depend on libmd5 from libwww, libmd does fine - install an example crawl.conf PR: 51696 Submitted by: Rui Lopes <rui@ruilopes.com>
Diffstat (limited to 'www/crawl')
-rw-r--r--www/crawl/Makefile17
-rw-r--r--www/crawl/pkg-plist2
2 files changed, 14 insertions, 5 deletions
diff --git a/www/crawl/Makefile b/www/crawl/Makefile
index ac5e8a3b8e00..bcd03617cc83 100644
--- a/www/crawl/Makefile
+++ b/www/crawl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= crawl
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.monkey.org/~provos/
@@ -15,20 +15,27 @@ MAINTAINER= petef@FreeBSD.org
COMMENT= A small, efficient web crawler with advanced features
BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
-LIB_DEPENDS= md5.1:${PORTSDIR}/www/libwww \
- db3.3:${PORTSDIR}/databases/db3
+LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_REINPLACE= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS= --with-libevent=${LOCALBASE}
-CONFIGURE_ENV= LIBS="${LDFLAGS} -L${LOCALBASE}/lib -lmd5"
+CONFIGURE_ENV= LIBS="${LDFLAGS} -lmd"
+CFLAGS+= -D__FUNCTION__='""'
MAN1= crawl.1
post-patch:
- @${REINPLACE_CMD} -e 's,-ldb,-ldb3,g' ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e 's,/usr/include/db2,${LOCALBASE}/include/db3,g ; \
+ s,db2,db3,g' ${WRKSRC}/configure.in
${CHMOD} u+w ${WRKSRC}/*
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/crawl.conf ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/www/crawl/pkg-plist b/www/crawl/pkg-plist
index 1cdd09ea5311..804521be1a57 100644
--- a/www/crawl/pkg-plist
+++ b/www/crawl/pkg-plist
@@ -1 +1,3 @@
bin/crawl
+%%PORTDOCS%%share/examples/crawl/crawl.conf
+%%PORTDOCS%%@dirrm share/examples/crawl