aboutsummaryrefslogtreecommitdiffstats
path: root/www/dddbl
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-08 23:33:03 +0800
committermarino <marino@FreeBSD.org>2014-08-08 23:33:03 +0800
commitf6de56f3a8f4b4f218451cdf9c0fd833c2153600 (patch)
treef655495df22b75deaca3262ecaba3d2ab0956f58 /www/dddbl
parentb602dd2b4f0381a4107447359ec76c5835059075 (diff)
downloadfreebsd-ports-gnome-f6de56f3a8f4b4f218451cdf9c0fd833c2153600.tar.gz
freebsd-ports-gnome-f6de56f3a8f4b4f218451cdf9c0fd833c2153600.tar.zst
freebsd-ports-gnome-f6de56f3a8f4b4f218451cdf9c0fd833c2153600.zip
Add new port www/dddbl
PR: 190575 Submitted by: Torsten Zuehlsdorff ================================================================ DDDBL is a Definition Driven DataBase Layer written in PHP. It uses PDO to support the work on all supported database systems and eases the handling of the query-results.
Diffstat (limited to 'www/dddbl')
-rw-r--r--www/dddbl/Makefile26
-rw-r--r--www/dddbl/distinfo2
-rw-r--r--www/dddbl/pkg-descr5
-rw-r--r--www/dddbl/pkg-plist16
4 files changed, 49 insertions, 0 deletions
diff --git a/www/dddbl/Makefile b/www/dddbl/Makefile
new file mode 100644
index 000000000000..3c84f55b7aa0
--- /dev/null
+++ b/www/dddbl/Makefile
@@ -0,0 +1,26 @@
+# Created by: Torsten Zühlsdorff <ports@toco-domains.de>
+# $FreeBSD$
+
+PORTNAME= dddbl
+PORTVERSION= 2.0.1
+CATEGORIES= www
+MASTER_SITES= http://www.dddbl.de/dddbl-versions/
+
+MAINTAINER= ports@toco-domains.de
+COMMENT= Definition Driven Database Layer for PHP
+
+USES= tar:bzip2
+
+.include <bsd.port.options.mk>
+
+NO_BUILD= yes
+
+USE_PHP= yes
+
+WRKSRC= ${WRKDIR}/dddbl2
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>
diff --git a/www/dddbl/distinfo b/www/dddbl/distinfo
new file mode 100644
index 000000000000..44b2e14f92fc
--- /dev/null
+++ b/www/dddbl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dddbl-2.0.1.tar.bz2) = fb6d4e9a3e66d872f07a359b19caa0af610dd41d86c3758fe5568389b245649e
+SIZE (dddbl-2.0.1.tar.bz2) = 8236
diff --git a/www/dddbl/pkg-descr b/www/dddbl/pkg-descr
new file mode 100644
index 000000000000..fab372dd0ae9
--- /dev/null
+++ b/www/dddbl/pkg-descr
@@ -0,0 +1,5 @@
+DDDBL is a Definition Driven DataBase Layer written in PHP. It uses PDO to
+support the work on all supported database systems and eases the handling
+of the query-results.
+
+WWW: http://www.dddbl.de/
diff --git a/www/dddbl/pkg-plist b/www/dddbl/pkg-plist
new file mode 100644
index 000000000000..6ca508d43c50
--- /dev/null
+++ b/www/dddbl/pkg-plist
@@ -0,0 +1,16 @@
+%%DATADIR%%/config.inc.php
+%%DATADIR%%/dddbl.php
+%%DATADIR%%/handler/register_queue_handler.inc.php
+%%DATADIR%%/handler/register_result_handler.inc.php
+%%DATADIR%%/inc/DataObject.class.php
+%%DATADIR%%/inc/DataObjectPool.class.php
+%%DATADIR%%/inc/Queue.class.php
+%%DATADIR%%/inc/Singleton.class.php
+%%DATADIR%%/inc/database.func.php
+%%DATADIR%%/inc/exceptions/QueryException.class.php
+%%DATADIR%%/inc/exceptions/UnexpectedParameterTypeException.class.php
+@dirrm %%DATADIR%%
+@dirrm %%DATADIR%%/handler
+@dirrm %%DATADIR%%/inc/
+@dirrm %%DATADIR%%/inc/exceptions
+