aboutsummaryrefslogtreecommitdiffstats
path: root/www/demoroniser
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-12-23 05:32:30 +0800
committerantoine <antoine@FreeBSD.org>2014-12-23 05:32:30 +0800
commitb91214c7207893da973ac8071041560845388487 (patch)
tree44d0707ffde972411d71fcb84b47046fc421e56c /www/demoroniser
parenta3e38120d00268634df9da57cf5c4d958b08d3af (diff)
downloadfreebsd-ports-gnome-b91214c7207893da973ac8071041560845388487.tar.gz
freebsd-ports-gnome-b91214c7207893da973ac8071041560845388487.tar.zst
freebsd-ports-gnome-b91214c7207893da973ac8071041560845388487.zip
- Add missing run dependency on perl
- Shebangfix
Diffstat (limited to 'www/demoroniser')
-rw-r--r--www/demoroniser/Makefile7
-rw-r--r--www/demoroniser/files/patch-demoroniser.pl8
2 files changed, 5 insertions, 10 deletions
diff --git a/www/demoroniser/Makefile b/www/demoroniser/Makefile
index 710a59d74937..deb4c9d2ec3f 100644
--- a/www/demoroniser/Makefile
+++ b/www/demoroniser/Makefile
@@ -3,6 +3,7 @@
PORTNAME= demoroniser
PORTVERSION= 1.0.20030916
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.fourmilab.ch/webtools/demoroniser/ \
${MASTER_SITE_LOCAL}
@@ -12,12 +13,14 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Correct moronic and gratuitously incompatible HTML from MS applications
-USES= zip shebangfix
+USES= perl5 shebangfix zip
+USE_PERL5= run
+perl_OLD_CMD= /bin/perl
+SHEBANG_FILES= demoroniser.pl
NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_FILES= bin/demoroniser man/man1/demoroniser.1.gz
-SHEBANG_FILES= demoroniser.pl
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/demoroniser.pl \
diff --git a/www/demoroniser/files/patch-demoroniser.pl b/www/demoroniser/files/patch-demoroniser.pl
deleted file mode 100644
index 09f9f2337f12..000000000000
--- a/www/demoroniser/files/patch-demoroniser.pl
+++ /dev/null
@@ -1,8 +0,0 @@
---- demoroniser.pl.orig Sat Jan 10 22:29:54 1998
-+++ demoroniser.pl Thu Aug 12 18:36:53 1999
-@@ -1,4 +1,4 @@
--#! /bin/perl
-+#!/usr/bin/perl
- #
- # De-moron-ise Text from Microsoft Applications
- #