aboutsummaryrefslogtreecommitdiffstats
path: root/www/dillo2
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2006-06-03 10:01:25 +0800
committermnag <mnag@FreeBSD.org>2006-06-03 10:01:25 +0800
commitf0f8c3b19c4ff2c6d6f23897c8d9e52ad5e0cefb (patch)
treefbee8c6d53ca91b3dd91d590839c3c886399d7fb /www/dillo2
parentb7d7f8825eece5e460c5f368904c5d8af078f895 (diff)
downloadfreebsd-ports-gnome-f0f8c3b19c4ff2c6d6f23897c8d9e52ad5e0cefb.tar.gz
freebsd-ports-gnome-f0f8c3b19c4ff2c6d6f23897c8d9e52ad5e0cefb.tar.zst
freebsd-ports-gnome-f0f8c3b19c4ff2c6d6f23897c8d9e52ad5e0cefb.zip
- Add kbob to enable dlgui. WITH_DILLO_DLGUI
PR: 98144 Submitted by: maintainer
Diffstat (limited to 'www/dillo2')
-rw-r--r--www/dillo2/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/www/dillo2/Makefile b/www/dillo2/Makefile
index 25e37e6cfb4d..a4f6b66f177f 100644
--- a/www/dillo2/Makefile
+++ b/www/dillo2/Makefile
@@ -6,6 +6,7 @@
#
# Tunables:
# WITH_DILLO_SSL: enable experimental SSL support
+# WITH_DILLO_DLGUI: enable experimental FLTK2 based gui for file downloads
#
PORTNAME= dillo
@@ -29,7 +30,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-cookies --enable-ipv6 --enable-threaded-dns \
- --disable-dlgui \
--libdir=${PREFIX}/libexec
.if defined(WITH_DILLO_SSL)
@@ -40,6 +40,15 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+= --disable-ssl
.endif
+.if defined(WITH_DILLO_DLGUI)
+CONFIGURE_ARGS+= --enable-dlgui
+BUILD_DEPENDS+= fltk>=2.0.r4825:${PORTSDIR}/x11-toolkits/fltk2
+CPPFLAGS+= -I${X11BASE}/include
+LDFLAGS+= -L${X11BASE}/lib
+.else
+CONFIGURE_ARGS+= --disable-dlgui
+.endif
+
CONFLICTS= dillo-i18n-*[0-9]*
post-patch:
@@ -54,6 +63,11 @@ pre-configure:
@${ECHO_CMD} " Set WITH_DILLO_SSL=yes in your make environment or on the"
@${ECHO_CMD} " commandline to enable experimental SSL support."
.endif
+.if !defined(WITH_DILLO_DLGUI)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " Set WITH_DILLO_DLGUI=yes in your make environment or on the"
+ @${ECHO_CMD} " commandline to enable a FLTK2 based gui for download operations."
+.endif
@${ECHO_CMD} ""
.include <bsd.port.mk>