aboutsummaryrefslogtreecommitdiffstats
path: root/www/dotclear
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-02-06 01:00:32 +0800
committermiwi <miwi@FreeBSD.org>2014-02-06 01:00:32 +0800
commit91b333ac1a5acb9efeb8a25156d7da9c074be328 (patch)
treee447a91cc4d4ae6fdc198f8aaedaf93167d1cafd /www/dotclear
parent263c3785892b097b43adf7d13a4afd237bae90cc (diff)
downloadfreebsd-ports-gnome-91b333ac1a5acb9efeb8a25156d7da9c074be328.tar.gz
freebsd-ports-gnome-91b333ac1a5acb9efeb8a25156d7da9c074be328.tar.zst
freebsd-ports-gnome-91b333ac1a5acb9efeb8a25156d7da9c074be328.zip
- Stage support
Diffstat (limited to 'www/dotclear')
-rw-r--r--www/dotclear/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/www/dotclear/Makefile b/www/dotclear/Makefile
index 0b8b27741297..05c1e60e20a4 100644
--- a/www/dotclear/Makefile
+++ b/www/dotclear/Makefile
@@ -16,15 +16,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
SUB_FILES= pkg-message
WWWDIR?= ${PREFIX}/www/${PORTNAME}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
do-install:
- @${MKDIR} ${WWWDIR}
- ${CP} -R ${WRKSRC}/ ${WWWDIR}
- ${TOUCH} ${WWWDIR}/inc/config.php
- @${CHOWN} ${WWWOWN} ${WWWDIR}/inc/config.php
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ ${CP} -R ${WRKSRC}/ ${STAGEDIR}${WWWDIR}
+ ${TOUCH} ${STAGEDIR}${WWWDIR}/inc/config.php
+ @${CHOWN} ${WWWOWN} ${STAGEDIR}${WWWDIR}/inc/config.php
create-plist:
@${FIND} -s ${WRKSRC}/${file} -not -type d \