aboutsummaryrefslogtreecommitdiffstats
path: root/www/elinks
diff options
context:
space:
mode:
authorbrnrd <brnrd@FreeBSD.org>2016-07-02 18:35:17 +0800
committerbrnrd <brnrd@FreeBSD.org>2016-07-02 18:35:17 +0800
commit67f2d56a5213298913d7b29b09a7ff2d0cf8e427 (patch)
tree2438877a7e8736e4c9babae39a0bb9085eb1b22b /www/elinks
parent7af89cd91929b1200d3e5d9957619d07759abbe2 (diff)
downloadfreebsd-ports-gnome-67f2d56a5213298913d7b29b09a7ff2d0cf8e427.tar.gz
freebsd-ports-gnome-67f2d56a5213298913d7b29b09a7ff2d0cf8e427.tar.zst
freebsd-ports-gnome-67f2d56a5213298913d7b29b09a7ff2d0cf8e427.zip
www/elinks: Fix build without RAND_egd
- Add patch for building without EGD (OpenSSL 1.1/LibreSSL) - Move from USE_OPENSSL to USES=ssl PR: 198764
Diffstat (limited to 'www/elinks')
-rw-r--r--www/elinks/Makefile3
-rw-r--r--www/elinks/files/patch-src_network_ssl_ssl.c14
2 files changed, 15 insertions, 2 deletions
diff --git a/www/elinks/Makefile b/www/elinks/Makefile
index 4d2bf659872d..c4489ede3f70 100644
--- a/www/elinks/Makefile
+++ b/www/elinks/Makefile
@@ -11,8 +11,7 @@ MAINTAINER= beat@FreeBSD.org
COMMENT= Links text WWW browser with enhancements
GNU_CONFIGURE= yes
-USES= bison cpe execinfo gmake localbase tar:bzip2
-USE_OPENSSL= yes
+USES= bison cpe execinfo gmake localbase ssl tar:bzip2
CONFIGURE_ARGS= --without-zlib
LIBS+= -lexecinfo
diff --git a/www/elinks/files/patch-src_network_ssl_ssl.c b/www/elinks/files/patch-src_network_ssl_ssl.c
new file mode 100644
index 000000000000..e1497ae2e927
--- /dev/null
+++ b/www/elinks/files/patch-src_network_ssl_ssl.c
@@ -0,0 +1,14 @@
+--- src/network/ssl/ssl.c.orig 2009-08-22 13:15:08.000000000 +0200
++++ src/network/ssl/ssl.c 2015-03-21 12:41:15.886709287 +0100
+@@ -49,7 +49,10 @@ init_openssl(struct module *module)
+ * cannot initialize the PRNG and so every attempt to use SSL fails.
+ * It's actually an OpenSSL FAQ, and according to them, it's up to the
+ * application coders to seed the RNG. -- William Yodlowsky */
+- if (RAND_egd(RAND_file_name(f_randfile, sizeof(f_randfile))) < 0) {
++#ifndef OPENSSL_NO_EGD
++ if (RAND_egd(RAND_file_name(f_randfile, sizeof(f_randfile))) < 0)
++#endif
++ {
+ /* Not an EGD, so read and write to it */
+ if (RAND_load_file(f_randfile, -1))
+ RAND_write_file(f_randfile);