aboutsummaryrefslogtreecommitdiffstats
path: root/www/epiphany
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-02-18 11:50:38 +0800
committeradamw <adamw@FreeBSD.org>2004-02-18 11:50:38 +0800
commitd54a3b0f1a738ab689824d255aa5acf2e0fe3e42 (patch)
treee54f44a172651f143d14bb72b8c2b5ba71f59cdb /www/epiphany
parent85c8f3f941efa685ff55da9ec788c7db82afee6f (diff)
downloadfreebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.tar.gz
freebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.tar.zst
freebsd-ports-gnome-d54a3b0f1a738ab689824d255aa5acf2e0fe3e42.zip
GTK2 mozilla is now the default, and GTK1 support will be built only if explicitly
requested. This means that mozilla-gtk2 and mozilla-devel-gtk2 are now mozilla and mozilla-devel, respectively; and the old mozilla and mozilla-devel are now mozilla-gtk1 and mozilla-devel-gtk1. This is done for a whole plethora of reasons, and should please everybody except galeon1 fanatics and uhm... anybody else who it doesn't please. If you have WITH_MOZILLA set in your /etc/make.conf, you'll need to update the value accordingly. GTK2 ports will automatically install GTK2 mozilla, and GTK1 ports will automatically install GTK1 ports, so WITH_MOZILLA need be defined only if you want the development version... which are dormant right now anyway. For now, all ports that honoured WITH_MOZILLA=mozilla-{,-devel}-gtk2 will still honour those values as well as WITH_MOZILLA=mozilla{,-devel}, but future ports reserve the right to ignore the *-gtk2 values.
Diffstat (limited to 'www/epiphany')
-rw-r--r--www/epiphany/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index 1d08cc40b7da..7254d14909b7 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -21,19 +21,19 @@ RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6"
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.else
-.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+.if ${WITH_MOZILLA}=="mozilla-devel-gtk2" || ${WITH_MOZILLA}=="mozilla-devel"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.6b"
.else
-MOZILLA= mozilla-gtk2
+MOZILLA= mozilla
HEADERS_SUFX=
.endif
.endif
@@ -76,10 +76,10 @@ CONFIGURE_ARGS+= --disable-werror
pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} " By default epiphany uses www/mozilla-gtk2 for html rendering, but you can"
+ @${ECHO_MSG} " By default epiphany uses www/mozilla for html rendering, but you can"
@${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
- @${ECHO_MSG} " mozilla-devel-gtk2 "
+ @${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} ""
post-extract: