aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-02-28 12:39:23 +0800
committermezz <mezz@FreeBSD.org>2008-02-28 12:39:23 +0800
commit5360b3a571f798a57fbdfc4ab2da8aa870537e58 (patch)
tree23f7d2d6584af22234fba8f70cd6407b0d4381fe /www/firefox-esr/Makefile
parentbb662ad2908085f6e6fae1f54461a22c77e0fca3 (diff)
downloadfreebsd-ports-gnome-5360b3a571f798a57fbdfc4ab2da8aa870537e58.tar.gz
freebsd-ports-gnome-5360b3a571f798a57fbdfc4ab2da8aa870537e58.tar.zst
freebsd-ports-gnome-5360b3a571f798a57fbdfc4ab2da8aa870537e58.zip
- Add "--with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA}" to fix other
applications in the runtime. Some applications required to have set MOZILLA_FIVE_HOME or/and LD_LIBRARY_PATH to make it works in the runtime. Now, it's no longer need to set these variables, which this flag takes care of it. The MOZILLA_FIVE_HOME still works with this flag if someone need to use different one. I have learned about this flag from RPM, Debian, Gentoo ebuild and other packages. - Bump the PORTREVISION. Have been tested in MC CVS since Dec.
Diffstat (limited to 'www/firefox-esr/Makefile')
-rw-r--r--www/firefox-esr/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index d16ed0c7697b..06c91017a96c 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -3,11 +3,12 @@
# Whom: Alan Eldridge <alane@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/www/firefox/Makefile,v 1.23 2007/12/03 20:58:20 ahze Exp $
+# $MCom: ports/www/firefox/Makefile,v 1.43 2008/02/09 16:38:43 marcus Exp $
#
PORTNAME= firefox
DISTVERSION= 2.0.0.12
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
@@ -20,7 +21,6 @@ COMMENT= Web browser based on the browser portion of Mozilla
BUILD_DEPENDS= nss>=3.11.2:${PORTSDIR}/security/nss
MOZILLA_NAME= Firefox
-MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/'
WANT_GNOME= yes
ALL_TARGET= default
@@ -36,7 +36,9 @@ GECKO_PLIST_PRE_DIRS= lib/${MOZILLA}/chrome/icons/default lib/${MOZILLA}/chrome/
FIREFOX_ICON= ${MOZILLA}.xpm
FIREFOX_ICON_SRC= ${PREFIX}/lib/${MOZILLA}/icons/default.xpm
-MOZ_OPTIONS= --enable-application=browser \
+MOZ_OPTIONS= --program-transform-name='s/firefox/${MOZILLA}/' \
+ --with-default-mozilla-five-home=${PREFIX}/lib/${MOZILLA} \
+ --enable-application=browser \
--enable-system-cairo \
--enable-official-branding \
--enable-canvas \