aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr/files
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-11-22 12:04:52 +0800
committermarcus <marcus@FreeBSD.org>2004-11-22 12:04:52 +0800
commit923d8a6ec2413e75522da7bf04d230180e560ab1 (patch)
tree0cf5a0a2a602da8b4c9ba5e705f3191905bebc64 /www/firefox-esr/files
parent68b98fa4c1dffd57fd6707d4b5a843173f9a7fb3 (diff)
downloadfreebsd-ports-gnome-923d8a6ec2413e75522da7bf04d230180e560ab1.tar.gz
freebsd-ports-gnome-923d8a6ec2413e75522da7bf04d230180e560ab1.tar.zst
freebsd-ports-gnome-923d8a6ec2413e75522da7bf04d230180e560ab1.zip
Use -Bsymbolic when linking nss to avoid symbol conflicts with libraries
that include OpenSSL (e.g. CUPS). This may help alleviate the problem with Firefox crashing when trying to print when using CUPS.
Diffstat (limited to 'www/firefox-esr/files')
-rw-r--r--www/firefox-esr/files/patch-security-coreconf-FreeBSD.mk24
1 files changed, 19 insertions, 5 deletions
diff --git a/www/firefox-esr/files/patch-security-coreconf-FreeBSD.mk b/www/firefox-esr/files/patch-security-coreconf-FreeBSD.mk
index 73292a7362d5..3e0e14acaaf2 100644
--- a/www/firefox-esr/files/patch-security-coreconf-FreeBSD.mk
+++ b/www/firefox-esr/files/patch-security-coreconf-FreeBSD.mk
@@ -1,14 +1,28 @@
-$FreeBSD$
-
---- security/coreconf/FreeBSD.mk Thu Oct 16 23:03:47 2003
-+++ security/coreconf/FreeBSD.mk Thu Oct 16 22:53:11 2003
-@@ -44,5 +44,9 @@
+--- security/coreconf/FreeBSD.mk.orig Wed Mar 26 20:17:25 2003
++++ security/coreconf/FreeBSD.mk Sun Nov 21 22:59:49 2004
+@@ -43,8 +43,12 @@
+ ifeq ($(OS_TEST),alpha)
CPU_ARCH = alpha
else
+ifeq ($(OS_TEST),amd64)
+CPU_ARCH = amd64
+else
CPU_ARCH = x86
+ endif
+endif
+
+ OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
+
+@@ -71,7 +75,11 @@
+ DLL_SUFFIX = so.1.0
endif
+-MKSHLIB = $(CC) $(DSO_LDOPTS)
++ifneq (,$(filter alpha ia64,$(OS_TEST)))
++MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS) -o $@
++else
++MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS) -o $@
++endif
+ ifdef MAPFILE
+ # Add LD options to restrict exported symbols to those in the map file
+ endif