aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox-esr
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-12-11 10:11:23 +0800
committerahze <ahze@FreeBSD.org>2004-12-11 10:11:23 +0800
commit8425079e49d4868610285e4c5978780d60668cc2 (patch)
treeae16c73d8b8deb9659dc0960a66fddbe8c964278 /www/firefox-esr
parente852908b9fef4921606174105fe01fe7ed5de423 (diff)
downloadfreebsd-ports-gnome-8425079e49d4868610285e4c5978780d60668cc2.tar.gz
freebsd-ports-gnome-8425079e49d4868610285e4c5978780d60668cc2.tar.zst
freebsd-ports-gnome-8425079e49d4868610285e4c5978780d60668cc2.zip
- Fix plist in firefox [1]
- Touch lib/browser_plugins/.${PORTNAME}.keep so this directory will not be removed durring deinstall of mozilla[-devel] or firefox if you still have mozilla[-devel] or firefox installed. Pointed out by: pointy hat [1]
Diffstat (limited to 'www/firefox-esr')
-rw-r--r--www/firefox-esr/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 68abd39f9392..78ea6e7118e1 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -188,6 +188,8 @@ pre-install:
&& ${FIND} -d * -type d | \
${SED} -e 's|^|@dirrm include/${FIREFOX}/|' >> ${PLIST}
${ECHO_CMD} @dirrm include/${FIREFOX} >> ${PLIST}
+ ${ECHO_CMD} lib/browser_plugins/.${PORTNAME}.keep >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${RMDIR} %D/lib/browser_plugins 2>/dev/null || ${TRUE}" >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${FIREFOX}
@@ -197,6 +199,7 @@ do-install:
if [ ! -d ${PREFIX}/lib/browser_plugins ]; then \
${MKDIR} ${PREFIX}/lib/browser_plugins ; \
fi
+ ${TOUCH} -f ${PREFIX}/lib/browser_plugins/.${PORTNAME}.keep
if [ ! -L ${PREFIX}/lib/browser_plugins/libjavaplugin_oji.so ]; then \
for jpi in ${JPI_LIST}; do \
if [ -f $${jpi} ]; then \