aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox10
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-12-04 17:47:27 +0800
committermarcus <marcus@FreeBSD.org>2004-12-04 17:47:27 +0800
commita433f771d4d31172183d7d4b8096454c468d8c3a (patch)
tree3eb0debfca57cdf4a2ee4b78a5efe87133e1098a /www/firefox10
parent821e2d66452a29adfce36f5a46a6e2df486aa0b9 (diff)
downloadfreebsd-ports-gnome-a433f771d4d31172183d7d4b8096454c468d8c3a.tar.gz
freebsd-ports-gnome-a433f771d4d31172183d7d4b8096454c468d8c3a.tar.zst
freebsd-ports-gnome-a433f771d4d31172183d7d4b8096454c468d8c3a.zip
Be sure to create the browser_plugins during package install as well. Some
ports (e.g. www/ump) depend on this directory being there. Reported by: pointyhat via kris
Diffstat (limited to 'www/firefox10')
-rw-r--r--www/firefox10/Makefile1
-rw-r--r--www/firefox10/pkg-install.in4
2 files changed, 5 insertions, 0 deletions
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index 4eb85744734b..83de1a8e522c 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -126,6 +126,7 @@ post-extract::
post-patch:
@${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${FIREFOX}|g ; \
+ s|%%PREFIX%%|${PREFIX}|g ; \
s|%%X11BASE%%|${X11BASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%MOZDIR%%|${PREFIX}/lib/${FIREFOX}|g' \
diff --git a/www/firefox10/pkg-install.in b/www/firefox10/pkg-install.in
index 8f8dbd0c6cc3..f25aa135197d 100644
--- a/www/firefox10/pkg-install.in
+++ b/www/firefox10/pkg-install.in
@@ -29,4 +29,8 @@ cd ${MOZDIR} || exit 1
./run-mozilla.sh ${REGCHROME} || true
./run-mozilla.sh ${FIREFOX} -register > /dev/null 2>&1
+if [ ! -d %%PREFIX%%/lib/browser_plugins ]; then
+ mkdir -p %%PREFIX%%/lib/browser_plugins
+fi
+
exit 0