aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox36/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-10-18 05:29:31 +0800
committermarcus <marcus@FreeBSD.org>2004-10-18 05:29:31 +0800
commitef68e001187c69ddb6811f7d3df3daed2034f4e6 (patch)
treedec8d55633b1148fc0efa04e13449edd8d1d2fc4 /www/firefox36/Makefile
parenta21268054d370450a5007b03919b8a2d32f47161 (diff)
downloadfreebsd-ports-gnome-ef68e001187c69ddb6811f7d3df3daed2034f4e6.tar.gz
freebsd-ports-gnome-ef68e001187c69ddb6811f7d3df3daed2034f4e6.tar.zst
freebsd-ports-gnome-ef68e001187c69ddb6811f7d3df3daed2034f4e6.zip
* Remove some patches that are no longer needed
* Workaround a crash that can be triggered by JavaScript pop-up windows [1] * Use Xvfb to initialize the Firefox extensions datastore as root [1] https://bugzilla.mozilla.org/show_bug.cgi?id=264557
Diffstat (limited to 'www/firefox36/Makefile')
-rw-r--r--www/firefox36/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 1ae047590258..a62cffed60b1 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 1.0.1.p
-PORTREVISION= 2
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${REALVERSION}
@@ -18,10 +18,9 @@ COMMENT= Web browser based on the browser portion of Mozilla
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
- mng.1:${PORTSDIR}/graphics/libmng \
- freetype.9:${PORTSDIR}/print/freetype2
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- freetype-config:${PORTSDIR}/print/freetype2
+ mng.1:${PORTSDIR}/graphics/libmng
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS= Xvfb:${X_VFBSERVER_PORT}
ALL_TARGET= default
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
@@ -139,7 +138,8 @@ post-patch:
.for ii in modules/libpref/src/init extensions/sroaming/resources/content/prefs \
embedding/minimo
${MV} ${WRKSRC}/${ii}/all.js ${WRKSRC}/${ii}/all.js.bak
- ${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/' \
+ ${SED} -e '/accessibility.typeaheadfind.enablesound/s/true/false/ ; \
+ /dom.disable_window_open_feature.toolbar/s/false/true/' \
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
.for ii in ${PKGCONFIG_FILES}
@@ -171,7 +171,8 @@ pre-install:
@${RM} -rf ${FAKEDIR}/lib/${PORTNAME}/lib/${PORTNAME}-${REALVERSION}/chrome/en-${ii}${jj}
.endfor
.endfor
- @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g' \
+ @${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
< ${MASTERDIR}/pkg-install.in > ${PKGINSTALL}
@${SED} -e 's|%%MOZDIR%%|${LOCAL_PREFIX}/lib/${PORTNAME}-${REALVERSION}|g' \
< ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}