aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2017-09-16 02:01:17 +0800
committerdumbbell <dumbbell@FreeBSD.org>2017-09-16 02:01:17 +0800
commit0b663e6dddf67c26d69ee9e838a493969939381c (patch)
treefc0dda6a227504f83fbc652cef96d083c9e79a92 /www/firefox
parenteefc293cf2a313845432c80b58a5fd5fa5ae0472 (diff)
downloadfreebsd-ports-gnome-0b663e6dddf67c26d69ee9e838a493969939381c.tar.gz
freebsd-ports-gnome-0b663e6dddf67c26d69ee9e838a493969939381c.tar.zst
freebsd-ports-gnome-0b663e6dddf67c26d69ee9e838a493969939381c.zip
lang/rust: Install Cargo + use bundled crates
This port now provides Cargo. This is the recommended now because Cargo won't be provided separately in the future. To build Cargo, we set `extended = true` in `config.toml`. As a side effect, this flag also installs Rust source code. The port has a new `SOURCES` option (disabled by default) to keep those sources. As a consequence of this, `devel/cargo` is removed. Several ports and Makefiles in Mk were updated to depend on `lang/rust` instead of `devel/cargo`. The other big change in this patch is the use of the bundled crates, instead of relying on Cargo's registry (which was part of the distfiles, in order to allow offline builds). So now, we don't need to prepare the registry when updating this port. This has several other benefits: * It fixes the build with sudo(8). * It fixes the use of the ino-64 patch (it was not applied to the registry, thus not used). Compilation errors were fixed in the ino-64 patch. Various `.cargo-checksum.json` files are updated after the sources are patched (FBSD10_FIX, ino-64, and so on). This fixes builds which were failing with errors such as: error: the listed checksum of `.../rustc-1.19.0-src/src/vendor/lzma-sys/xz-5.2.3/build-aux/config.rpath` has changed: expected: c8b4c017079da9dfb3086a0583e60ffe736184d89005dc5973f0bb0fd17c04bb actual: 561b00eb30ecaef2c9da17bc195e7d2a7ea63facea38ea9849fbb0ed340bebba PR: 221088 Reported by: joneum@, nwhitehorn@, romain@, Ekaterina Vaartis <vaartis@cock.li>, david@catwhisker.org, fullermd@over-yonder.net, rum1cro@yandex.ru, w.schwarzenfeld@utanet.at Differential Revision: https://reviews.freebsd.org/D11783
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 3777f1653704..d648ad7a4624 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -48,7 +48,7 @@ MOZ_OPTIONS= --enable-application=browser \
OPTIONS_DEFINE= RUST
OPTIONS_DEFAULT= BUNDLED_CAIRO
OPTIONS_EXCLUDE= GNOMEUI
-# XXX lang/rust and devel/cargo currently build only on these platforms
+# XXX lang/rust currently builds only on these platforms
OPTIONS_DEFAULT_aarch64=RUST
OPTIONS_DEFAULT_amd64= RUST
OPTIONS_DEFAULT_i386= RUST