aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-05-01 13:29:08 +0800
committerjbeich <jbeich@FreeBSD.org>2016-05-01 13:29:08 +0800
commit4e5dc93c9101d46316d6d2ed427cb801b71a83cf (patch)
tree3a53b13f346cc5f079624a2713ae3cad28a9a655 /www/firefox
parent794a87750e1c5478a71d61bd71b07809596dd69b (diff)
downloadfreebsd-ports-gnome-4e5dc93c9101d46316d6d2ed427cb801b71a83cf.tar.gz
freebsd-ports-gnome-4e5dc93c9101d46316d6d2ed427cb801b71a83cf.tar.zst
freebsd-ports-gnome-4e5dc93c9101d46316d6d2ed427cb801b71a83cf.zip
gecko: unbreak WebRTC microphone selection popup with ALSA=on
On FreeBSD sound(4) is enabled by default while alsa-plugins-oss assumes a soundcard is always available. https://bugzilla.mozilla.org/show_bug.cgi?id=1269165 MFH: 2016Q2
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug126916524
2 files changed, 25 insertions, 1 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 0e4e4aa41db9..aa35c3478178 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,7 +4,7 @@
PORTNAME= firefox
DISTVERSION= 46.0
DISTVERSIONSUFFIX=.source
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug1269165 b/www/firefox/files/patch-bug1269165
new file mode 100644
index 000000000000..f88f018866a5
--- /dev/null
+++ b/www/firefox/files/patch-bug1269165
@@ -0,0 +1,24 @@
+# getUserMedia fails to enumerate ALSA plugins
+
+--- media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc.orig 2016-04-22 00:37:17 UTC
++++ media/webrtc/trunk/webrtc/modules/audio_device/linux/audio_device_alsa_linux.cc
+@@ -1752,7 +1752,9 @@ int32_t AudioDeviceLinuxALSA::GetDevices
+ // Don't use snd_device_name_hint(-1,..) since there is a access violation
+ // inside this ALSA API with libasound.so.2.0.0.
+ int card = -1;
++#ifdef WEBRTC_LINUX
+ while (!(LATE(snd_card_next)(&card)) && (card >= 0) && keepSearching) {
++#endif
+ void **hints;
+ err = LATE(snd_device_name_hint)(card, "pcm", &hints);
+ if (err != 0)
+@@ -1878,7 +1880,9 @@ int32_t AudioDeviceLinuxALSA::GetDevices
+ LATE(snd_strerror)(err));
+ // Continue and return true anyway, since we did get the whole list.
+ }
++#ifdef WEBRTC_LINUX
+ }
++#endif
+
+ if (FUNC_GET_NUM_OF_DEVICE == function)
+ {