aboutsummaryrefslogtreecommitdiffstats
path: root/www/firefox
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-10-19 11:39:42 +0800
committerJan Beich <jbeich@FreeBSD.org>2017-10-19 11:39:42 +0800
commitb5c8d84a0c3764e3d7c996e6de3e3bc5fa9873e8 (patch)
treec97692fd2ad5efc12fbf2d1b7503b1a4969ed444 /www/firefox
parent70bbedcd744e9f34cdc5fe5a9a469eacb2abc13e (diff)
downloadfreebsd-ports-gnome-b5c8d84a0c3764e3d7c996e6de3e3bc5fa9873e8.tar.gz
freebsd-ports-gnome-b5c8d84a0c3764e3d7c996e6de3e3bc5fa9873e8.tar.zst
freebsd-ports-gnome-b5c8d84a0c3764e3d7c996e6de3e3bc5fa9873e8.zip
www/firefox: trim package by ~50 Mb
DTRACE=on and PROFILE=on builds only want non-debug symbols. MFH: 2017Q4
Diffstat (limited to 'www/firefox')
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-bug140968027
2 files changed, 28 insertions, 0 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 7da37422ad82..adb28af05399 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -4,6 +4,7 @@
PORTNAME= firefox
DISTVERSION= 56.0.1
DISTVERSIONSUFFIX=.source
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
diff --git a/www/firefox/files/patch-bug1409680 b/www/firefox/files/patch-bug1409680
new file mode 100644
index 000000000000..37c71ec234b2
--- /dev/null
+++ b/www/firefox/files/patch-bug1409680
@@ -0,0 +1,27 @@
+Bug 1409680 - Extend --disable-debug-symbols to Rust code.
+
+This reduces disk I/O and memory usage during build that already lacks
+debugging symbols from C++ code, allowing to use more jobs on 32bit hosts.
+
+--disable-debug-symbols build on FreeBSD 10.3 i386 (8 cores) host:
+Max RSS before: libxul - 612 Mb, libgkrust - 1908 Mb
+Max RSS after: libxul - 444 Mb, libgkrust - 1471 Mb
+Binary before: libxul - 203 Mb, libgkrust - 732 Mb
+Binary after: libxul - 123 Mb, libgkrust - 301 Mb
+
+--- config/rules.mk.orig 2017-09-14 20:15:53 UTC
++++ config/rules.mk
+@@ -906,11 +906,13 @@ ifdef MOZ_USING_SCCACHE
+ sccache_wrap := RUSTC_WRAPPER='$(CCACHE)'
+ endif
+
++ifdef MOZ_DEBUG_SYMBOLS
+ # XXX hack to work around dsymutil failing on cross-OSX builds (bug 1380381)
+ ifeq ($(HOST_OS_ARCH)-$(OS_ARCH),Linux-Darwin)
+ default_rustflags += -C debuginfo=1
+ else
+ default_rustflags += -C debuginfo=2
++endif
+ endif
+
+ # We use the + prefix to pass down the jobserver fds to cargo, but we