aboutsummaryrefslogtreecommitdiffstats
path: root/www/flock/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-19 08:51:17 +0800
committermarcus <marcus@FreeBSD.org>2004-06-19 08:51:17 +0800
commit66fa69b7d4a74a486a3a4589c076870fc23809ff (patch)
tree1eb917b40cb680e1db824e84e27fb653ba4a0e70 /www/flock/Makefile
parent3a4bbe1da1eb873df438fa2347b0fddd4d1df0c7 (diff)
downloadfreebsd-ports-gnome-66fa69b7d4a74a486a3a4589c076870fc23809ff.tar.gz
freebsd-ports-gnome-66fa69b7d4a74a486a3a4589c076870fc23809ff.tar.zst
freebsd-ports-gnome-66fa69b7d4a74a486a3a4589c076870fc23809ff.zip
* Try a little harder to get firefox to work without first running as root
* Make sure optimized CFLAGS are actually respected [1] * Frobnicate the mozconfig file a little bit to be more inline with typical Linux builds * Try a safer hack to ensure the install completes okay Reported by: kris [1]
Diffstat (limited to 'www/flock/Makefile')
-rw-r--r--www/flock/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/www/flock/Makefile b/www/flock/Makefile
index ec944c9ba17b..6c77fb3bc839 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -7,7 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
@@ -57,10 +57,6 @@ OPTIONS= DEBUG "Build a debugging image" off \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-CONFIGURE_ENV+= WITH_REORDER=yes
-.endif # ${ARCH} == "i386"
-
.if defined(WITH_DEBUG)
WITH_LOGGING= yes
CONFIGURE_ENV+= WITH_DEBUG=yes
@@ -68,6 +64,9 @@ CONFIGURE_ENV+= WITH_DEBUG=yes
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O2
+CONFIGURE_ENV+= WITH_OPTIMIZE=-O2
+.else
+CONFIGURE_ENV+= WITH_OPTIMIZE=-O
.endif # defined(WITH_OPTIMIZED_CFLAGS)
.if defined(WITH_LOGGING)
@@ -137,10 +136,11 @@ pre-configure:
fi
post-build:
- # XXX This works around an install problem that is triggered when
- # toolkit/profile/src is built after profile/src.
- @(cd ${WRKSRC}/dist/lib && ${LN} -sf ../../profile/src/libprofile_s.a \
- .)
+# XXX This works around an install problem that is triggered when
+# toolkit/profile/src is built after profile/src.
+# @(cd ${WRKSRC}/dist/lib && ${LN} -sf ../../profile/src/libprofile_s.a \
+# .)
+ @${TOUCH} -f ${WRKSRC}/profile/build/libprofile.so
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the