aboutsummaryrefslogtreecommitdiffstats
path: root/www/fluxbb
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-03 21:24:39 +0800
committermiwi <miwi@FreeBSD.org>2008-06-03 21:24:39 +0800
commit13d36c1543941fdfbef412b87d28e7318abfa731 (patch)
tree4dfca20a36de1e888d7d8024aca245d07ea229d6 /www/fluxbb
parentdeda9d2b3f7730270a68e5343dcbcc2a6503de40 (diff)
downloadfreebsd-ports-gnome-13d36c1543941fdfbef412b87d28e7318abfa731.tar.gz
freebsd-ports-gnome-13d36c1543941fdfbef412b87d28e7318abfa731.tar.zst
freebsd-ports-gnome-13d36c1543941fdfbef412b87d28e7318abfa731.zip
FluxBB is an open source forum application released under the
GNU General Public Licence. It is free to download and use and will remain so. FluxBB was conceived and designed to be fast and light with less of the "not so essential" features that some of the other forums have whilst not sacrificing essential functionality or usability. WWW: http://www.fluxbb.org/ PR: ports/123863 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'www/fluxbb')
-rw-r--r--www/fluxbb/Makefile46
-rw-r--r--www/fluxbb/distinfo3
-rw-r--r--www/fluxbb/files/pkg-message.in30
-rw-r--r--www/fluxbb/pkg-descr8
-rw-r--r--www/fluxbb/pkg-plist125
5 files changed, 212 insertions, 0 deletions
diff --git a/www/fluxbb/Makefile b/www/fluxbb/Makefile
new file mode 100644
index 000000000000..cb648b5c3455
--- /dev/null
+++ b/www/fluxbb/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: fluxbb
+# Date created: 19 May 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fluxbb
+PORTVERSION= 1.2.18
+CATEGORIES= www
+MASTER_SITES= http://fluxbb.org/download/releases/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A fast and lightweight PHP-powered discussion board
+
+SUB_FILES= pkg-message
+NO_BUILD= yes
+USE_PHP= yes
+
+OPTIONS= MYSQL "Add support for a MySQL database server" On \
+ PGSQL "Add support for a PostgreSQL database server" Off \
+ SQLITE "Add support for a SQLite database server" Off
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MYSQL)
+USE_PHP+= mysql
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.if defined(WITH_SQLITE)
+USE_PHP+= sqlite
+.endif
+
+do-install:
+ @cd ${WRKSRC}/upload && ${COPYTREE_SHARE} . ${WWWDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}' >> ${TMPPLIST}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/fluxbb/distinfo b/www/fluxbb/distinfo
new file mode 100644
index 000000000000..114df46a4e2b
--- /dev/null
+++ b/www/fluxbb/distinfo
@@ -0,0 +1,3 @@
+MD5 (fluxbb-1.2.18.tar.gz) = f3078837e951352c122f119c5e4d7716
+SHA256 (fluxbb-1.2.18.tar.gz) = 912f1dff8c2f4f2e0522eb1fd675df3a516a5815fac877dc22fe5df712c9cb0e
+SIZE (fluxbb-1.2.18.tar.gz) = 162675
diff --git a/www/fluxbb/files/pkg-message.in b/www/fluxbb/files/pkg-message.in
new file mode 100644
index 000000000000..1130c3fe0f04
--- /dev/null
+++ b/www/fluxbb/files/pkg-message.in
@@ -0,0 +1,30 @@
+-------------------------------------------
+Congratulations, FluxBB is now installed!
+
+To complete the installation , please:
+1) Create a user and a database for FluxBB to store all
+ its tables in (or choose an existing database).
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /fluxbb %%WWWDIR%%/
+ AcceptPathInfo On
+ <Directory %%WWWDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+
+3) Visit your FluxBB site with a browser (i.e.,
+ http://your.server.com/fluxbb/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up FluxBB.
+
+For more information, see the official website:
+
+ http://www.fluxbb.org/
+
+-------------------------------------------
diff --git a/www/fluxbb/pkg-descr b/www/fluxbb/pkg-descr
new file mode 100644
index 000000000000..fce975afd52b
--- /dev/null
+++ b/www/fluxbb/pkg-descr
@@ -0,0 +1,8 @@
+FluxBB is an open source forum application released under the
+GNU General Public Licence. It is free to download and use and
+will remain so. FluxBB was conceived and designed to be fast and
+light with less of the "not so essential" features that some of
+the other forums have whilst not sacrificing essential functionality
+or usability.
+
+WWW: http://www.fluxbb.org/
diff --git a/www/fluxbb/pkg-plist b/www/fluxbb/pkg-plist
new file mode 100644
index 000000000000..6395af00df55
--- /dev/null
+++ b/www/fluxbb/pkg-plist
@@ -0,0 +1,125 @@
+%%WWWDIR%%/admin_bans.php
+%%WWWDIR%%/admin_categories.php
+%%WWWDIR%%/admin_censoring.php
+%%WWWDIR%%/admin_forums.php
+%%WWWDIR%%/admin_groups.php
+%%WWWDIR%%/admin_index.php
+%%WWWDIR%%/admin_loader.php
+%%WWWDIR%%/admin_maintenance.php
+%%WWWDIR%%/admin_options.php
+%%WWWDIR%%/admin_permissions.php
+%%WWWDIR%%/admin_prune.php
+%%WWWDIR%%/admin_ranks.php
+%%WWWDIR%%/admin_reports.php
+%%WWWDIR%%/admin_users.php
+%%WWWDIR%%/cache/.htaccess
+%%WWWDIR%%/cache/index.html
+%%WWWDIR%%/delete.php
+%%WWWDIR%%/edit.php
+%%WWWDIR%%/extern.php
+%%WWWDIR%%/footer.php
+%%WWWDIR%%/header.php
+%%WWWDIR%%/help.php
+%%WWWDIR%%/img/avatars/index.html
+%%WWWDIR%%/img/index.html
+%%WWWDIR%%/img/smilies/big_smile.png
+%%WWWDIR%%/img/smilies/cool.png
+%%WWWDIR%%/img/smilies/hmm.png
+%%WWWDIR%%/img/smilies/index.html
+%%WWWDIR%%/img/smilies/lol.png
+%%WWWDIR%%/img/smilies/mad.png
+%%WWWDIR%%/img/smilies/neutral.png
+%%WWWDIR%%/img/smilies/roll.png
+%%WWWDIR%%/img/smilies/sad.png
+%%WWWDIR%%/img/smilies/smile.png
+%%WWWDIR%%/img/smilies/tongue.png
+%%WWWDIR%%/img/smilies/wink.png
+%%WWWDIR%%/img/smilies/yikes.png
+%%WWWDIR%%/include/cache.php
+%%WWWDIR%%/include/common.php
+%%WWWDIR%%/include/common_admin.php
+%%WWWDIR%%/include/dblayer/common_db.php
+%%WWWDIR%%/include/dblayer/index.html
+%%WWWDIR%%/include/dblayer/mysql.php
+%%WWWDIR%%/include/dblayer/mysqli.php
+%%WWWDIR%%/include/dblayer/pgsql.php
+%%WWWDIR%%/include/dblayer/sqlite.php
+%%WWWDIR%%/include/email.php
+%%WWWDIR%%/include/functions.php
+%%WWWDIR%%/include/parser.php
+%%WWWDIR%%/include/search_idx.php
+%%WWWDIR%%/include/template/admin.tpl
+%%WWWDIR%%/include/template/help.tpl
+%%WWWDIR%%/include/template/index.html
+%%WWWDIR%%/include/template/main.tpl
+%%WWWDIR%%/include/template/maintenance.tpl
+%%WWWDIR%%/include/template/redirect.tpl
+%%WWWDIR%%/index.php
+%%WWWDIR%%/install.php
+%%WWWDIR%%/lang/index.html
+%%WWWDIR%%/lang/English/common.php
+%%WWWDIR%%/lang/English/delete.php
+%%WWWDIR%%/lang/English/forum.php
+%%WWWDIR%%/lang/English/help.php
+%%WWWDIR%%/lang/English/index.html
+%%WWWDIR%%/lang/English/index.php
+%%WWWDIR%%/lang/English/login.php
+%%WWWDIR%%/lang/English/misc.php
+%%WWWDIR%%/lang/English/post.php
+%%WWWDIR%%/lang/English/prof_reg.php
+%%WWWDIR%%/lang/English/profile.php
+%%WWWDIR%%/lang/English/register.php
+%%WWWDIR%%/lang/English/search.php
+%%WWWDIR%%/lang/English/stopwords.txt
+%%WWWDIR%%/lang/English/topic.php
+%%WWWDIR%%/lang/English/userlist.php
+%%WWWDIR%%/lang/English/mail_templates/activate_email.tpl
+%%WWWDIR%%/lang/English/mail_templates/activate_password.tpl
+%%WWWDIR%%/lang/English/mail_templates/form_email.tpl
+%%WWWDIR%%/lang/English/mail_templates/index.html
+%%WWWDIR%%/lang/English/mail_templates/new_reply.tpl
+%%WWWDIR%%/lang/English/mail_templates/new_reply_full.tpl
+%%WWWDIR%%/lang/English/mail_templates/welcome.tpl
+%%WWWDIR%%/login.php
+%%WWWDIR%%/misc.php
+%%WWWDIR%%/moderate.php
+%%WWWDIR%%/plugins/AMP_Example.php
+%%WWWDIR%%/plugins/index.html
+%%WWWDIR%%/post.php
+%%WWWDIR%%/profile.php
+%%WWWDIR%%/register.php
+%%WWWDIR%%/search.php
+%%WWWDIR%%/style/Cobalt.css
+%%WWWDIR%%/style/Lithium.css
+%%WWWDIR%%/style/Mercury.css
+%%WWWDIR%%/style/Oxygen.css
+%%WWWDIR%%/style/Radium.css
+%%WWWDIR%%/style/Sulfur.css
+%%WWWDIR%%/style/imports/Cobalt_cs.css
+%%WWWDIR%%/style/imports/Lithium_cs.css
+%%WWWDIR%%/style/imports/Mercury_cs.css
+%%WWWDIR%%/style/imports/Oxygen_cs.css
+%%WWWDIR%%/style/imports/Radium_cs.css
+%%WWWDIR%%/style/imports/Sulfur_cs.css
+%%WWWDIR%%/style/imports/base.css
+%%WWWDIR%%/style/imports/base_admin.css
+%%WWWDIR%%/style/imports/index.html
+%%WWWDIR%%/style/imports/minmax.js
+%%WWWDIR%%/style/index.html
+%%WWWDIR%%/userlist.php
+%%WWWDIR%%/viewforum.php
+%%WWWDIR%%/viewtopic.php
+@dirrm %%WWWDIR%%/style/imports
+@dirrm %%WWWDIR%%/style
+@dirrm %%WWWDIR%%/plugins
+@dirrm %%WWWDIR%%/lang/English/mail_templates
+@dirrm %%WWWDIR%%/lang/English
+@dirrm %%WWWDIR%%/lang
+@dirrm %%WWWDIR%%/include/template
+@dirrm %%WWWDIR%%/include/dblayer
+@dirrm %%WWWDIR%%/include
+@dirrm %%WWWDIR%%/img/smilies
+@dirrm %%WWWDIR%%/img/avatars
+@dirrm %%WWWDIR%%/img
+@dirrm %%WWWDIR%%/cache
+@dirrm %%WWWDIR%%