aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon2/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-08-01 17:05:58 +0800
committersobomax <sobomax@FreeBSD.org>2000-08-01 17:05:58 +0800
commited21297b137a1cf58e38fe0b9a6b254234f3dcf8 (patch)
tree7901cfb803f3af4d3589f5817700fac24e388457 /www/galeon2/Makefile
parent0274f5cd70739902c18618119220fdcef3e7fab4 (diff)
downloadfreebsd-ports-gnome-ed21297b137a1cf58e38fe0b9a6b254234f3dcf8.tar.gz
freebsd-ports-gnome-ed21297b137a1cf58e38fe0b9a6b254234f3dcf8.tar.zst
freebsd-ports-gnome-ed21297b137a1cf58e38fe0b9a6b254234f3dcf8.zip
Add galeon - a GNOME Web browser based on gecko (the mozilla rendering engine).
It allows to use state-of-the-art HTML rendering engine without much overhead imposed my Mozilla itself. Obtained from: http://www.gnome.org/
Diffstat (limited to 'www/galeon2/Makefile')
-rw-r--r--www/galeon2/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
new file mode 100644
index 000000000000..8288f7f83028
--- /dev/null
+++ b/www/galeon2/Makefile
@@ -0,0 +1,49 @@
+# Ports collection Makefile for: galeon
+# Date created: 1 August 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= galeon
+PORTVERSION= 0.7.1
+CATEGORIES= www gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/www/mozilla:build
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
+ glade.4:${PORTSDIR}/devel/libglade
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ mozilla:${PORTSDIR}/www/mozilla
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+CFLAGS+= -D_REENTRANT -D_THREAD_SAFE
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-mozilla-headers=${WRKDIRPREFIX}${.CURDIR}/../../www/mozilla/work/mozilla/dist/include \
+ --with-mozilla-libs=${WRKDIRPREFIX}${.CURDIR}/../../www/mozilla/work/mozilla/dist/lib
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|-lpthread|-pthread|g'
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/src/galeon
+
+.include <bsd.port.mk>