aboutsummaryrefslogtreecommitdiffstats
path: root/www/galeon
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-10-17 02:47:54 +0800
committermarcus <marcus@FreeBSD.org>2003-10-17 02:47:54 +0800
commitd822f0fd44baaa97913437a031c6cfb8ef12c8b9 (patch)
tree5c365f774db80b7dcc554c3d651ff39913b4f8c2 /www/galeon
parent1b6b819cd772d5ca78ed5e0e293e2793661eece9 (diff)
downloadfreebsd-ports-gnome-d822f0fd44baaa97913437a031c6cfb8ef12c8b9.tar.gz
freebsd-ports-gnome-d822f0fd44baaa97913437a031c6cfb8ef12c8b9.tar.zst
freebsd-ports-gnome-d822f0fd44baaa97913437a031c6cfb8ef12c8b9.zip
Remove any chance of linking galeon with -pthread. Instead, make sure
${PTHREAD_LIBS} is used. Submitted by: sf
Diffstat (limited to 'www/galeon')
-rw-r--r--www/galeon/Makefile5
-rw-r--r--www/galeon/files/patch-configure17
2 files changed, 17 insertions, 5 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 67cca7def50c..08db12c13118 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -74,8 +74,9 @@ pre-everything::
@${ECHO_MSG} ""
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g'
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|' \
+ -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
@${MKDIR} ${WRKSRC}/src/libnautilus
diff --git a/www/galeon/files/patch-configure b/www/galeon/files/patch-configure
index cd7487253b76..b78ce2790640 100644
--- a/www/galeon/files/patch-configure
+++ b/www/galeon/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Mar 17 15:31:41 2003
-+++ configure Mon Apr 7 23:32:37 2003
-@@ -7950,6 +7950,7 @@
+--- configure.orig Fri Oct 17 01:15:31 2003
++++ configure Fri Oct 17 01:16:29 2003
+@@ -7968,6 +7968,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,14 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -11890,8 +11891,8 @@
+ ;;
+ FreeBSD)
+ USE_PTHREADS=1
+- _PTHREAD_CFLAGS="-pthread -D_THREAD_SAFE"
+- _PTHREAD_LDFLAGS="";;
++ _PTHREAD_CFLAGS="%%PTHREAD_CFLAGS%%"
++ _PTHREAD_LDFLAGS="%%PTHREAD_LIBS%%";;
+ *)
+ USE_PTHREADS=1
+ _PTHREAD_LDFLAGS="-lc_r";;