aboutsummaryrefslogtreecommitdiffstats
path: root/www/gohugo/Makefile
diff options
context:
space:
mode:
authorjoneum <joneum@FreeBSD.org>2019-01-01 19:47:54 +0800
committerjoneum <joneum@FreeBSD.org>2019-01-01 19:47:54 +0800
commit0a4a09b546852849a9469eac3b6dfe027d054f9e (patch)
tree542350eb76cd1e00f972a57c3154034b6fda8484 /www/gohugo/Makefile
parentb33f8a8205b64ef84f023046acb0a075ba6acf59 (diff)
downloadfreebsd-ports-gnome-0a4a09b546852849a9469eac3b6dfe027d054f9e.tar.gz
freebsd-ports-gnome-0a4a09b546852849a9469eac3b6dfe027d054f9e.tar.zst
freebsd-ports-gnome-0a4a09b546852849a9469eac3b6dfe027d054f9e.zip
Update to 0.53
Changelog: https://github.com/gohugoio/hugo/releases/tag/v0.53 PR: 234424 Submitted by: ben.lavery@hashbang0.com (maintainer) Sponsored by: Netzkommune GmbH
Diffstat (limited to 'www/gohugo/Makefile')
-rw-r--r--www/gohugo/Makefile37
1 files changed, 22 insertions, 15 deletions
diff --git a/www/gohugo/Makefile b/www/gohugo/Makefile
index a9cdc020630a..3b42aa486376 100644
--- a/www/gohugo/Makefile
+++ b/www/gohugo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hugo
DISTVERSIONPREFIX= v
-DISTVERSION= 0.52
+DISTVERSION= 0.53
CATEGORIES= www
PKGNAMEPREFIX= go
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -25,11 +25,15 @@ GH_TUPLE= BurntSushi:locker:a6e239e:locker/src/github.com/BurntSushi/locker \
alecthomas:chroma:v0.6.0:chroma/src/github.com/alecthomas/chroma \
alecthomas:colour:60882d9:colour/src/github.com/alecthomas/colour \
alecthomas:repr:117648c:repr/src/github.com/alecthomas/repr \
+ armon:consul-api:eb2c6b5:consul_api/src/github.com/armon/consul-api \
bep:debounce:v1.1.0:debounce/src/github.com/bep/debounce \
bep:gitmap:v1.0.0:gitmap/src/github.com/bep/gitmap \
bep:go-tocss:v0.6.0:go_tocss/src/github.com/bep/go-tocss \
chaseadamsio:goorgeous:v1.1.0:goorgeous/src/github.com/chaseadamsio/goorgeous \
cheekybits:is:68e9c06:cheekybits_is/src/github.com/cheekybits/is \
+ coreos:etcd:v3.3.10:etcd/src/github.com/coreos/etcd \
+ coreos:go-etcd:v2.0.0:go_etcd/src/github.com/coreos/go-etcd \
+ coreos:go-semver:v0.2.0:go_semver/src/github.com/coreos/go-semver \
cpuguy83:go-md2man:v1.0.8:go_md2man/src/github.com/cpuguy83/go-md2man \
danwakefield:fnmatch:cbb64ac:fnmatch/src/github.com/danwakefield/fnmatch \
davecgh:go-spew:v1.1.1:go_spew/src/github.com/davecgh/go-spew \
@@ -59,7 +63,7 @@ GH_TUPLE= BurntSushi:locker:a6e239e:locker/src/github.com/BurntSushi/locker \
mattn:go-runewidth:v0.0.3:go_runewidth/src/github.com/mattn/go-runewidth \
miekg:mmark:v1.3.6:mmark/src/github.com/miekg/mmark \
mitchellh:hashstructure:v1.0.0:hashstructure/src/github.com/mitchellh/hashstructure \
- mitchellh:mapstructure:v1.0.0:mapstructure/src/github.com/mitchellh/mapstructure \
+ mitchellh:mapstructure:v1.1.2:mapstructure/src/github.com/mitchellh/mapstructure \
muesli:smartcrop:f6ebaa7:smartcrop/src/github.com/muesli/smartcrop \
nfnt:resize:83c6a99:resize/src/github.com/nfnt/resize \
nicksnyder:go-i18n:v1.10.0:go_i18n/src/github.com/nicksnyder/go-i18n \
@@ -71,29 +75,32 @@ GH_TUPLE= BurntSushi:locker:a6e239e:locker/src/github.com/BurntSushi/locker \
sanity-io:litter:v1.1.0:litter/src/github.com/sanity-io/litter \
sergi:go-diff:v1.0.0:sergi_go_diff/src/github.com/sergi/go-diff \
shurcooL:sanitized_anchor_name:86672fc:sanitized_anchor_name/src/github.com/shurcooL/sanitized_anchor_name \
- spf13:afero:v1.1.2:afero/src/github.com/spf13/afero \
+ spf13:afero:v1.2.0:afero/src/github.com/spf13/afero \
spf13:cast:v1.3.0:cast/src/github.com/spf13/cast \
spf13:cobra:v0.0.3:cobra/src/github.com/spf13/cobra \
spf13:fsync:12a01e6:fsync/src/github.com/spf13/fsync \
spf13:jwalterweatherman:94f6ae3:jwalterweatherman/src/github.com/spf13/jwalterweatherman \
spf13:nitro:24d7ef3:nitro/src/github.com/spf13/nitro \
spf13:pflag:v1.0.3:pflag/src/github.com/spf13/pflag \
- spf13:viper:v1.2.0:viper/src/github.com/spf13/viper \
+ spf13:viper:v1.3.1:viper/src/github.com/spf13/viper \
stretchr:testify:04af852:testify/src/github.com/stretchr/testify \
tdewolff:minify:v2.3.7:minify/src/github.com/tdewolff/minify \
tdewolff:parse:v2.3.5:parse/src/github.com/tdewolff/parse \
tdewolff:test:v1.0.0:tdewolff_test/src/github.com/tdewolff/test \
+ ugorji:go:d75b2dc:ugorji_go/src/github.com/ugorji/go/codec \
wellington:go-libsass:c636442:go_libsass/src/github.com/wellington/go-libsass \
+ xordataexchange:crypt:b2862e3:xordataexchange_crypt/src/github.com/xordataexchange/crypt \
yosssi:ace:v0.0.5:ace/src/github.com/yosssi/ace \
+ golang:crypto:505ab14:crypto/src/golang.org/x/crypto \
golang:image:c73c2af:image/src/golang.org/x/image \
golang:net:161cd47:net/src/golang.org/x/net \
golang:sync:1d60e46:golang_sync/src/golang.org/x/sync \
- golang:sys:9b800f9:sys/src/golang.org/x/sys \
+ golang:sys:70b957f:sys/src/golang.org/x/sys \
golang:text:v0.3.0:golang_text/src/golang.org/x/text \
go-check:check:788fd78:go_check_check/src/gopkg.in/check.v1 \
- go-yaml:yaml:v2.2.1:go_yaml_yaml/src/gopkg.in/yaml.v2
+ go-yaml:yaml:v2.2.2:go_yaml_yaml/src/gopkg.in/yaml.v2
-COMMIT_ID= 9433cf5a92176b4a8005ddb5f4d524c0dc8c5c43
+COMMIT_ID= 8fc339dc2529ff77e494a1c12cd1ff9fbcb880a4
OPTIONS_DEFINE= MANPAGES EXTENDED
@@ -110,14 +117,14 @@ GOENV= GOPATH=${WRKSRC} CGO_CFLAGS="${CGO_CFLAGS}" \
CGO_LDFLAGS="${CGO_LDFLAGS}" GOBIN=""
CGO_ENABLED= 0
-PORTMANS= hugo-benchmark.1 hugo-config.1 hugo-convert-toJSON.1 \
- hugo-convert-toTOML.1 hugo-convert-toYAML.1 hugo-convert.1 \
- hugo-env.1 hugo-gen-autocomplete.1 hugo-gen-chromastyles.1 \
- hugo-gen-doc.1 hugo-gen-man.1 hugo-gen.1 hugo-import-jekyll.1 \
- hugo-import.1 hugo-list-drafts.1 hugo-list-expired.1 \
- hugo-list-future.1 hugo-list.1 hugo-new-site.1 \
- hugo-new-theme.1 hugo-new.1 hugo-server.1 hugo-version.1 \
- hugo.1
+PORTMANS= hugo-config.1 hugo-convert-toJSON.1 hugo-convert-toTOML.1 \
+ hugo-convert-toYAML.1 hugo-convert.1 hugo-env.1 \
+ hugo-gen-autocomplete.1 hugo-gen-chromastyles.1 \
+ hugo-gen-doc.1 hugo-gen-man.1 hugo-gen.1 \
+ hugo-import-jekyll.1 hugo-import.1 hugo-list-drafts.1 \
+ hugo-list-expired.1 hugo-list-future.1 hugo-list.1 \
+ hugo-new-site.1 hugo-new-theme.1 hugo-new.1 hugo-server.1 \
+ hugo-version.1 hugo.1
do-build:
@(if [ -z "$${SOURCE_DATE_EPOCH}" ]; then\